Community Forums Today's Posts     Member List     Archive    
Page 4 of 4 FirstFirst ... 234
Results 46 to 56 of 56
  1. #46
    Join Date
    May 2006
    Location
    germany
    Posts
    2

    Unhappy

    Hallo,

    Ich habe setarch installiert, aber es funktioniert trotdzem nicht (ich verwende Fedora Core 2):
    Code:
    [ts@machine tss2_rc2]$ setarch i686 ./teamspeak2-server_startscript start
    starting the teamspeak2 server
    Runtime error   0 at BFFFF658
    ./teamspeak2-server_startscript: line 92: 28102 Segmentation fault      ./server_linux -PID=tsserver2.pid
    woran könnte das liegen?

  2. #47
    Bastian Guest
    Laut der FAQ solltest du es mal hiermit probieren:

    Code:
    setarch i386 ./teamspeak2-server_startscript start
    Damit haben wir den Server auf einem Fedora Core Testsystem zum Laufen gebracht.

  3. #48
    Join Date
    May 2006
    Location
    germany
    Posts
    2
    Quote Originally Posted by Bastian
    Laut der FAQ solltest du es mal hiermit probieren:

    Code:
    setarch i386 ./teamspeak2-server_startscript start
    Damit haben wir den Server auf einem Fedora Core Testsystem zum Laufen gebracht.
    Damit hatte ich es auch schon probiert und dann die selbe ausgabe...

    mfg
    Tasmas

  4. #49
    Join Date
    May 2006
    Location
    Berlin
    Posts
    1
    es scheint als würde ich mit meinem Runtime Error 234 ein wenig aus der Rolle fallen.

    habe alles nach Tutorial gemacht und bei ./teamspeak2-server_startscript start kommt dann halt der Fehler.

    habe den Support von 1blu bereits angeschrieben jedoch hätte ich hier eventuell auch gern ein feedback falls von dort nichts kommt.

    Vielen Dank im Vorraus

    Gruß Scorpi

  5. #50
    Join Date
    Aug 2006
    Location
    Switzerland
    Posts
    2
    Gibt es immer noch keine funktionierende Lösung dafür?

    Benutze auch Fedora Core 2 Version 2.6.8-022stab067.1-enterprise

    Auch bei mir Runtime Error

    ./teamspeak2-server_startscript start
    /bin/bash: /root/.bashrc: Permission denied
    starting the teamspeak2 server
    Runtime error 0 at BFFFF8D8
    ./teamspeak2-server_startscript: line 92: 5952 Segmentation fault ./server_linux -PID=tsserver2.pid


    Was bei mir jedoch auffällt, Segmentation fault bekommt er erst ab line 92, nicht wie fast alle melden ab line 7 !!?

    2. Problem bei mir ist noch /root/.bashrc: Permission denied, weiss gerade jemand wie ich das am besten behebe? Führe ich das script als root aus, fällt dieser Fehler ja schonmal weg...


    Beim Kollege nebenan lief alles ohne Probleme, gleicher Kernel, einfach CentOS und nicht Fedora, an dem sollte es doch nicht liegen.

    Fehlen da welche LIB's, Packages!?
    Was wir alles verwendet von TS - Perl, PHP, MySQL !?

    Wär wirklich dankbar, wenn ich TS2 zum laufen bringe, da an einen Kernel wechsel nicht zu denken ist bei ein vServer

    Danke
    MFG
    Hertus

  6. #51
    Join Date
    Feb 2005
    Location
    Germany
    Posts
    16
    Moin

    Mal eine kleine einführung in Setarch...
    Oder einfach die MANPAGE.
    Setarch-Manpage

    demnach... sollten ein paar "schalterchen" zum ziel führen..
    Scheinbar sind es oft 64Bit maschinen und dafür optimierte Kernel..

    Also mal mit Option -L oder -B versuchen, ja nach Maschine bzw Kernel..

    Bei wem Setarch probleme bereitet, fehlende abhängigkeiten und soo...
    Der sollte sich diese Sourcen auf seine Maschine ziehen... Entpacken und dann ein
    gcc -o setarch setarch.c
    in dem Verzeichnis wo diese setarch.c liegt ausführen...
    Die entstandene Binär Datei setarch dann nach /usr/local/bin kopieren..

    Damit sollten die Kompatibilitätsprobleme in bezug auf Setarch ausgemerzt sein..



    Lesen Bildet, und wer zu faul ist zum Lesen, und absolut keinen Plan hat, sollte besser die Finger von Linux lassen, und sich nen Windoof Server zulegen...
    Die lassen sich sicher einfacher Administrieren

  7. #52
    Join Date
    Aug 2006
    Location
    Switzerland
    Posts
    2
    Hm, seit man bei mir die "diskinodes" Limite erhöht hat, funktionierts wunderbar (mit setarch)

    Weiss aber nicht ob's wirklich an dem gelegen hat

    (diskinodes hard/soft-limite von 200 auf 300 erhöht)

  8. #53
    Join Date
    Nov 2006
    Location
    Germany
    Posts
    2
    ts@v574:~/tss2_rc2$ setarch i386 -X ./teamspeak2-server_startscript start
    starting the teamspeak2 server
    ./teamspeak2-server_startscript: line 92: 26363 Getötet ./server_linux -PID=tsserver2.pid
    ts@v574:~/tss2_rc2$
    Mir hilft setarch leider nicht weiter, such auch schon seit 3 Tagen nach einer Lösung die auch tatsächlich funktioniert, achja ich bin natürlich auch einer der doofen debian VServerUser, die zwar nicht zu doof zum mitlesen ist, aber die Lösung noch nicht gefunden hat.

  9. #54
    Join Date
    Sep 2006
    Location
    Germany
    Posts
    3
    Also was meinen sie jetzt mit dem port ich habe auch nen runtime error Problem und war dieses

    Runtime error 230 at 0804CDF3

    Kann mir da jemand helfen warum er nicht starten will???

    MFg: mofde2003

  10. #55
    Join Date
    Jul 2006
    Posts
    1,641
    Quote Originally Posted by mofde2003 View Post
    Also was meinen sie jetzt mit dem port ich habe auch nen runtime error Problem und war dieses

    Runtime error 230 at 0804CDF3

    Kann mir da jemand helfen warum er nicht starten will???

    MFg: mofde2003
    Klick hier und hier

  11. #56
    Join Date
    Feb 2008
    Location
    /dev/null
    Posts
    14
    Hallo!
    Ich weiß leider nicht ob das Thema noch aktuell ist, da ich keinen post nach 2007 finde, für mich ist es aber seit zwei Tagen aktuell, da ich nach etwa drei verschiedenen foren und bestimmt an die 50 threads dazu zu keiner Lösung gekommen bin.

    ich bin anfänger bis fortgeschritten im Umgang mit linux und der shell. vor ein paar tagen mussten wir zwei usrer server auf ein neues ubuntu mit neuem kernel upgraden, da dies andere wichtige applikationen verlangten.
    seitdem kriege ich kein teamspeak mehr zum laufen, auf keinem der server.

    auf dem wo ich teamspeak laufen lassen will, läuft Ubuntu 4.1.2-16ubuntu2

    uname -a
    Linux 83-142-84-226 2.6.22-14-server #1 SMP Sun Oct 14 23:34:23 GMT 2007 i686 GNU/Linux

    Das Problem:
    Der User teamspeak wurde angelegt und in seinem homeverzeichnis liegt der inhalt des tss_rc2 installationsverzeichnisses. Alle ausführbaren dateien haben ausführrechte und sollten mit
    ./teamspeak2-server_startscript start

    gestartet werden können. Was aber nicht der Fall ist.
    Code:
    starting the teamspeak2 server
    ./teamspeak2-server_startscript: line 7:  5643 Segmentation fault      ./server_linux -PID=tsserver2.pid
    Das Problem kennen bestimmt viele, ich kenne es auch sehr gut.
    Nun habe ich von setarch gehört und habe durch unzählige Threads wälzen erfahren, dass
    Code:
    setarch i686 -X (oder -L oder -B) ./teamspeak2-server_startscript start
    das Problem behoben sein sollte. Dem ist aber nicht so. Es geht nichts. egal in welcher kombination, als root oder als teamspeak, unterschiedliche architekturen, andere anwendung, verschiedene versionen, nada. Immer segmentation fault.
    Ich habe auch schon das backup unsres vorherigen gesicherten teamspeaks drauf, das auf der Maschine LIEF. Hier genau das selbe...

    habe schon gelesen dass man mysql ein rootpasswort geben soll. Habe extra dafür mysql installiert und ein root pw vergeben. egal ob es an oder aus ist, keine änderung.

    Mir gehen die Ideen aus, dem Forum scheinbar auch. Zumindest dem zu urteilen was ich gelesen habe.
    Ein WEchsel auf einen kernel kommt eigentlich nicht in Frage, das Teil muss doch irgendwie zum laufen gebracht werden...

    Hat jemand Ideen/links was ich noch nicht ausprobiert haben könnte?

    Ahja, setarch war übrigens schon vorinstalliert, weshalb ich mir die hälfte der threads sparen konnte, in denen es eigentlich nur darum ging dieses setarch zum laufen zu kriegen.

    Ich hoffe das ist ausreichend um mir zu helfen! ich bitte drum

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Runtime Error problem + glibc problem
    By MaRlik in forum [TeamSpeak 2] Server Support
    Replies: 0
    Last Post: 18-08-2004, 18:15
  2. login problem (runtime error)
    By mirko231078 in forum [TeamSpeak 2] Server Support
    Replies: 7
    Last Post: 01-03-2004, 14:55
  3. Andere hören alles was ich höre.altes Problem keine Lösung
    By Barzar in forum [TeamSpeak 2] Client Support
    Replies: 8
    Last Post: 02-10-2003, 19:36
  4. AUDIGY 2 & TS weird very (!) annoying problem!!!
    By doc.pepper in forum [TeamSpeak 2] Client Support
    Replies: 4
    Last Post: 30-04-2003, 17:06
  5. Server gets Runtime Error. Lib problem?
    By Dummer Sack in forum [TeamSpeak 2] Server Support
    Replies: 6
    Last Post: 10-12-2002, 18:06

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •