Community Forums Today's Posts     Member List     Archive    
Results 1 to 5 of 5
  1. #1
    Join Date
    Feb 2007
    Location
    Norway
    Posts
    3

    auto connect to private server

    well basicly I've got a question that's been asked here before. But on a diff type of server. This one is privat... like you MUST have a password to join it.

    the server I'm trying to auto connect to is on port 8768 and is our main clan server. I finally just managed to connect to it after about 5-6 hours of work... BUT there's a big problem.. I can't log in with my own account...

    the only way I've managed to connect to the server now is by using this command line

    Code:
    C:\Programfiler\Teamspeak2_RC2\TeamSpeak.exe localhost:8768?password=****
    but then i get signed on as Guest1.

    what I cant get to work is

    Code:
    C:\Programfiler\Teamspeak2_RC2\TeamSpeak.exe "localhost:8768?loginname=RamboClown&password=****&nickname=-MBD- RamboClown"
    is there anyone here that might be able to guide me a little bit further here?

    Thanks, RamboClown

    **EDIT**
    I have even tried to make a URL shortcut on my desktop.. and using the "teamspeak://" link... but with no luck...

  2. #2
    Join Date
    Oct 2006
    Location
    UK
    Posts
    1,027
    Quote Originally Posted by ramboclown View Post
    well basicly I've got a question that's been asked here before. But on a diff type of server. This one is privat... like you MUST have a password to join it.

    the server I'm trying to auto connect to is on port 8768 and is our main clan server. I finally just managed to connect to it after about 5-6 hours of work... BUT there's a big problem.. I can't log in with my own account...

    the only way I've managed to connect to the server now is by using this command line

    Code:
    C:\Programfiler\Teamspeak2_RC2\TeamSpeak.exe localhost:8768?password=****
    but then i get signed on as Guest1.

    what I cant get to work is

    Code:
    C:\Programfiler\Teamspeak2_RC2\TeamSpeak.exe "localhost:8768?loginname=RamboClown&password=****&nickname=-MBD- RamboClown"
    is there anyone here that might be able to guide me a little bit further here?

    Thanks, RamboClown

    **EDIT**
    I have even tried to make a URL shortcut on my desktop.. and using the "teamspeak://" link... but with no luck...

    Try

    Code:
    C:\Program Files\Teamspeak2_RC2\TeamSpeak.exe serverip/nickname=nickname?loginname=loginname?password=password?channel=channel


    I have written a small peice of software for something very similar here
    http://forum.goteamspeak.com/showthread.php?t=35396

    And Bastian lists how to do it with a batch file

    Ie
    Code:
    start pathtofile

  3. #3
    Join Date
    Mar 2003
    Location
    US
    Posts
    7

    Lightbulb

    Quote Originally Posted by ramboclown View Post
    well basicly I've got a question that's been asked here before. But on a diff type of server. This one is privat... like you MUST have a password to join it.

    the server I'm trying to auto connect to is on port 8768 and is our main clan server. I finally just managed to connect to it after about 5-6 hours of work... BUT there's a big problem.. I can't log in with my own account...

    the only way I've managed to connect to the server now is by using this command line

    Code:
    C:\Programfiler\Teamspeak2_RC2\TeamSpeak.exe localhost:8768?password=****
    but then i get signed on as Guest1.

    what I cant get to work is

    Code:
    C:\Programfiler\Teamspeak2_RC2\TeamSpeak.exe "localhost:8768?loginname=RamboClown&password=****&nickname=-MBD- RamboClown"
    is there anyone here that might be able to guide me a little bit further here?

    Thanks, RamboClown

    **EDIT**
    I have even tried to make a URL shortcut on my desktop.. and using the "teamspeak://" link... but with no luck...
    The Reason you get signed on as guest is that you did not assign a nickname or password correctly.
    Your code is incorrect.
    C:\Programfiler\Teamspeak2_RC2\TeamSpeak.exe "localhost:8768?loginname=RamboClown&password=****&nickname=-MBD- RamboClown"

    These should be ?

    Here is the TS Shortcut i use.
    btw, if you created a url shortcut on your desktop and placed the full shortcut in the Target, fo back into the properties and re-add the full path. In Windows, the url shortcut icon limits the url path at first to a limited amount of characters, so your login information is more than likely missing.
    Heres the instructions, Start to finish to get you up and going....
    --------------------
    Right click on your Desktop and select NEW > Shortcut
    Enter ONLY teamspeak:// in the first available field and click next.
    Enter the name of the shortcut you want to show up on your desktop IE "My TS Server" and click finish.
    Now you should see your TS Icon on your desktop.
    Right click on it and select properties.
    Enter the following link in the URL Field and substitue your login and TS information in it.
    teamspeak://localhost:8768?nickname=SomeNick?loginname=LoginName?password=SomePWD?channel=ChannelName?subchannel=SubChannelName
    Click ok.
    Double click on the icon.

    Note: The login should be YOUR login name and YOUR password, not the TS server password.
    Last edited by yubin; 06-02-2007 at 14:37.

  4. #4
    Join Date
    Feb 2007
    Location
    Norway
    Posts
    3
    thanks for the fast replys... i just woke up right now... so i'm gonna try out what you both said... :-) again...thanks for the fast replys

    **EDIT**
    I've now tried out both ways... and i had a problem with the little software bro... it did start the server correctly and the client... but it didnt start the ts2perlmod ..

    so what i've done is that i use windows to trigger them and the command line provided by yubin...

    thanks for the help guys.. (nice little app you have there anyway tho)
    Last edited by ramboclown; 06-02-2007 at 15:33.

  5. #5
    Join Date
    May 2008
    Location
    Arizona, USA
    Posts
    3
    Great thread helped me out a ton, just wanted to add that if the channel is password protected the option channelpassword=chanpw? needs to be thrown in, if there are spaces in channel names qoutes are needed around the channel names (ie, channel="Channel that has spaces in it"?)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. »»» FAQ - TS 2.x Server
    By Michael in forum [TeamSpeak 2] Server Support
    Replies: 157
    Last Post: 30-12-2009, 00:20
  2. Server Issue's When PC Reboots
    By gokub27 in forum [TeamSpeak 2] Client Support
    Replies: 3
    Last Post: 14-09-2006, 22:32
  3. Server
    By lars-andre-petersen in forum [TeamSpeak 2] Server Support
    Replies: 70
    Last Post: 26-09-2005, 12:54
  4. TS2 Linux Server per webscript starten
    By -OSAMBA-Michel in forum [TeamSpeak 2] Server Support
    Replies: 17
    Last Post: 16-09-2005, 14:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •