Community Forums Today's Posts     Member List     Archive    
Results 1 to 7 of 7
  1. #1
    Join Date
    Feb 2007
    Location
    Kent, England
    Posts
    3

    Start TS from ssh - ssh hangs on exit

    Hi,

    I've trawled the TS forums and not seen a similar problem, any advice for solving the following would be very welcome.

    I have run TS for several years, my 32bit server died and was replaced with a 64bit machine, problems started soon after but it's taken me four months to work out roughly what's the cause. TeamSpeak server_linux starts OK, everyone can use it as normal but after a couple of days the server itself will fail complaining about being unable to setuid it starts to reject post and needs rebooting. Leave TeamSpeak off and the server will run indefinitely.
    If I ssh to the server and start TeamSpeak and then 'exit' from ssh the window blanks and freezes. ssh-ing in from another terminal and stopping TeamSpeak releases the frozen ssh.

    The server is running Fedora Core 6 x86_64 with all updates applied, I've tried vanilla kernels up to 2.6.20-rc7. Uninstalled and re-installed the 32bit libraries.
    Now using the very latest TeamSpeak 2.0.23.15 BETA
    I have tested it works fine on my workstation also on FC6 64bit, just not working on the machine I actually need it on...

    Checking the log there are no errors from TeamSpeak at all.

    Expect it's my own fauly, the problems might well have been caused by my rashly ugrading Fedora from 32bit to 64bit, a fresh install might cure it BUT I'd rather not have to!

    Any ideas, insights, solutions or suggestions?

    Thanks to anyone who is able to help,

    Jason

  2. #2
    Join Date
    Feb 2007
    Location
    Kent, England
    Posts
    3
    Thanks to anyone who took the time to read my original message.
    I'm happy to say the wonderful TeamSpeak is blameless!

    Whatever it is can reliably be triggered by starting TS but I can also generate the problem by stressing the server with a high load. Time for a re-install...

  3. #3
    Join Date
    Sep 2005
    Location
    Germany / Dortmund
    Posts
    1,298
    How do you start the server?

  4. #4
    Join Date
    Feb 2007
    Location
    Kent, England
    Posts
    3
    The server has been started with an init.d script.
    Here's a snippit of the current version, you can see I've tried many combinations based on what I've read in the forums regarding 64bit issues.

    'start')
    cd /home/tss
    # echo 1 > /proc/sys/vm/legacy_va_layout
    # setarch `uname -m` su tss -c /home/tss/server_linux
    # linux32 su tss -c /home/tss/server_linux
    #setarch x86_64
    su tss -c /home/tss/server_linux


    I also tried teamspeak2-server_startscript, same result.

    If you have any ideas I'd love to hear them but please don't spend any time unless you think it might be a problem that I can help YOU to learn something from and, hopefully, resolve. I am sure it is not a TS problem just something of my own creation so I fear I might be wasting your time on a wild goose chase.
    Sometime in the next couple of days the server is going to be replaced with something older, I didn't think 64bit was still this close to the bleeding edge... I've been using it on my workstation for 18months(!) back to 32bit land for my server :-)
    (The 64bit server will still be available if you'd like me to try anything out)

    Thanks,
    Jason

  5. #5
    Join Date
    Nov 2009
    Location
    Here
    Posts
    1
    I am having a very similar issue. I don't have problems when the server gets put under load, only after starting the service in a shell. To recap:

    OS: Redhat Enterprise Linux 5.1 x86 64bit

    I start the process using the supplied script (or even starting it manually using $INSTALLDIR/server_linux -PID-tsserver.pid) the server starts fine but the shell will not exit cleanly.

    Running a ps shows that the tsserver is running and thing connect fine, but the shell does not exit cleanly. Generally I wouldn't mind much (just click the x to close the window) but I restart services with a front end script which restarts TS (among other things) and this causes the script to never finish due the ssh session never ending.

    I ran an strace on the process and things appear to be ok and the process itself exits cleanly (0 exit status from $?). I checked to see if it started as a background job (which could in turn hang the session) but it does not. jobs -l returns no jobs.

    Now the short and dirty summary:

    Log in and start tsserver
    Type exit and shell hangs (using PuTTY)
    Start a new ssh session in and stop tsserver and the old shell finally quits

    Somehow the process is starting something that the shell thinks is still active but the server_linux is a binary and I am unable to truly watch it run. strace is the closest tool I have to watching it start but it shows a clean exit and a return to the shell.

    I looked all through the forums and goolge but no one has an answer and this thread was showing similar symptoms as what I am seeing.

    Ideas?

  6. #6
    Join Date
    Mar 2009
    Location
    Groningen
    Posts
    29
    I've found that x64 systems, (Windows and Linux) has issues with certain pointers TS use to run it core.
    My recommendations: Run 32 bit version of linux/windows (Win2k7, Win2k3 and Linux Debian are able to handle over 3 GB DDR1/DDR2 or DDR3 memory, regardless of the x86 or x64 system).

    We run on a Debian x86 system, while we have 2x Xeon 64 core, and, recently, upgraded to 32 GB ram memory.
    And we have no issue using x86 OS.

  7. #7
    Join Date
    Mar 2009
    Location
    USA
    Posts
    23
    I would suggest try using screen. You could start a screen, then launch the TS server, then disconnect from the screen (by default ctrl-A-D) and then putty should exit cleanly. Assuming that works, you could probably also have screen start in a disconnected mode while running the start script for teamspeak. To launch screen in disconnected with a command run:
    Code:
    screen -A -d -m  <command>
    replacing <command> with the actual command to run

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TeamSpeak 2 Anti-Flood Daemon
    By ScP in forum [TeamSpeak 2] Addons & Scripts
    Replies: 193
    Last Post: 07-09-2009, 18:27
  2. Auto Start :: Windows 2003 SBS
    By linsys in forum [TeamSpeak 2] Server Support
    Replies: 9
    Last Post: 21-06-2006, 19:26
  3. Start stop script for TeamSpeak daemon (init)
    By Cybernaut in forum [TeamSpeak 2] Server Support
    Replies: 2
    Last Post: 11-11-2004, 17:07
  4. Start script..
    By NitroSniper in forum [TeamSpeak 2] Addons & Scripts
    Replies: 3
    Last Post: 27-08-2002, 07:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •