Community Forums Today's Posts     Member List     Archive    
Results 1 to 6 of 6

Hybrid View

  1. #1
    Join Date
    Feb 2008
    Location
    USA
    Posts
    2

    libgcc_s.so.1 must be installed for pthread_cancel to work

    This is what I get when I try to run the latest server:

    $ ./server_linux
    libgcc_s.so.1 must be installed for pthread_cancel to work
    Aborted

    I am running on an AMD64 Fedora Core 6 box. Thanks.

  2. #2
    Join Date
    Feb 2008
    Location
    USA
    Posts
    2
    I got this to work. Apparently I had the 64-bit version of that library, while the TS server wants the 32-bit one. I obtained the last 32-bit rpm for libgcc for Fedora 6 from rpm.pbone.net, then did:

    rpm -ivh libgcc-4.1.2-13.fc6.i386.rpm

    It installed the 32-bit version side-by-side next to my 64-bit version.

    And now it is running. Hope this helps someone.

  3. #3
    Join Date
    Mar 2008
    Location
    spain
    Posts
    1
    you did it!. thank you very much Gremmie!.

    that was i did in a debian amd64 server (you need ia32-libs package installed previously, more info here):
    quick way (admin rights needed):
    Code:
    sudo apt-get install ia32-libs
    1.- download the libgcc package for i386
    http://packages.debian.org/etch/libgcc1

    2.- extract the package in a temp directory, in my case:
    Code:
    dpkg -x libgcc1_4.1.1-21_i386.deb ./libgcctemp
    3.- copy libgcc_s.so.1 in /lib32 (linked to /emul/ia32-linux/lib):
    Code:
    sudo cp ./libgcctemp/lib/libgcc_s.so.1 /lib32
    4.- if *the force* is with you, you are done! i hope so...

  4. #4
    Join Date
    Nov 2009
    Location
    UK
    Posts
    1
    Thanks to both of you! I had the same problem while installing Bitami LAMP stack on Debian Lenny. topete's comment helped me get it to work on my ADM64 system, except that I got the package from http://packages.debian.org/lenny/libgcc1 instead of http://packages.debian.org/etch/libgcc1

  5. #5
    Join Date
    Jan 2012
    Posts
    1

    teamspeak2 erro

    /teamspeak/tss2_rc2$ ./teamspeak2-server_startscript st art
    starting the teamspeak2 server
    libgcc_s.so.1 must be installed for pthread_cancel to work
    ./teamspeak2-server_startscript: line 7: 28735 Abandon ./server_ linux -PID=tsserver2.pid


    My server is debian already have installed Webmin

    thread has been merged
    Last edited by dante696; 19-01-2012 at 10:30.

  6. #6
    Join Date
    Mar 2012
    Posts
    1

    This also helps with IronKey secure USB drive...

    The software handling access to USB drive internals, when launched with ./ironkey, failed with a complaint of lack of aforementioned libs (not found). apt-get install only was enough to deal with that, after that IronKey secure USB drive works on amd64 Debian Squeeze linux and now I can use that expensive piece of USB stick nicely under Linux, thanks to you.

    Thx for tip!

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. Have to have TS on top for it to work?
    By Bargy in forum [TeamSpeak 2] Client Support
    Replies: 2
    Last Post: 19-04-2011, 00:20
  2. My mic start work but fail after a time!
    By RodolfoJV in forum [TeamSpeak Classic] General Questions
    Replies: 4
    Last Post: 18-01-2006, 20:48
  3. Links won't work in Opera
    By Siberian in forum [TeamSpeak 2] Client Support
    Replies: 0
    Last Post: 05-01-2006, 00:36
  4. Everything installed but ICONS Buttons wont work
    By Unhappyatnyc in forum [TeamSpeak 2] Server Support
    Replies: 0
    Last Post: 10-04-2005, 22:03
  5. Cant get TeamSpeak 2 to work under KDE
    By Goniak in forum [TeamSpeak 2] Client Support
    Replies: 2
    Last Post: 02-04-2003, 21:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •