Community Forums Today's Posts     Member List     Archive    
Results 1 to 6 of 6
  1. #1
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    10

    Voice activation - Enforcing push-to-talk

    Hi together,

    I can't use the voice activation anymore. In the beginning, I had only the problem right after starting the client. If I changed the settings once to push-to-talk and back, it was ok. Now, after Beta 6 client, it's not working at all.

    Following Error message if I change the settings to permanent or voice activation:
    2009-12-24 21:26:24.966990 ClientUI Info Enforcing push-to-talk

    I can only speak if I use the push to talk button, even if the setting is voice activation.

    Any ideas what's going wrong?

    Regards, Helicon


    BTW: With the test voice option in the settings everything works fine. So the microphone is working and has the right level to activate the playback. So I assume the settings are ok.
    Last edited by Helicon; 25-12-2009 at 10:28.

  2. #2
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    10
    Today I made a new installation on my Mac Book. Teamspeak was never installed before. Unfortunately, I got the same results. Voice activation is not working at all regardless if I use the internal, the line-in or USB microphone. Test Voice is working fine and I can hear my own voice as long as the test is active. If I apply the settings I can only use push-to-talk even if the voice activation is active.

    Am I the only one with this problem? I'm using Snow Leopard obviously on an Intel based Mac.

    Regards, Helicon


    P.S.: I've tested Beta 2 again and there is some strange behavior. If I start TS3, voice activation is not working. If I apply push-to-talk or continuos and go back then to voice activation, it works till I start TS3 again. I don't have the Beta 3 and 4 release so it may work too, but I don't know.
    Last edited by Helicon; 25-12-2009 at 10:43.

  3. #3
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    10
    I still have the same issue which is getting very annoying. Today I checked Beta 8 and voice activation is still not working.
    Log file:
    Code:
    2009-12-30 13:43:55.304101|INFO    |              |   | Logging started, clientlib version: 3.0.0-beta8 [Build: 9559]
    2009-12-30 13:43:55.600626|INFO    |ClientUI      |   | TeamSpeak 3 client version: 3.0.0-beta8 [Build: 9559]
    2009-12-30 13:43:55.600736|INFO    |ClientUI      |   | Qt version: 4.5.3
    2009-12-30 13:43:55.600783|INFO    |ClientUI      |   | Using configuration location: /Users/helicon/.ts3client/ts3clientui_qt.conf
    2009-12-30 13:43:56.029049|INFO    |ClientUI      |   | Last update check was: Mi. Dez 30 13:39:12 2009
    2009-12-30 13:44:01.018509|INFO    |PreProSpeex   |  1| Speex version: 1.2rc1
    2009-12-30 13:44:03.691660|INFO    |ClientUI      |  1| getServerHostPort result: xxx.xxx.xxx.xxx 9987
    2009-12-30 13:44:46.355252|INFO    |ClientUI      |  1| Enforcing push-to-talk <-- I switched setting to permanent
    2009-12-30 13:44:59.530835|INFO    |ClientUI      |  1| Enforcing push-to-talk <-- I switched setting to push-to-talk
    2009-12-30 13:45:02.898819|INFO    |ClientUI      |  1| Enforcing push-to-talk <-- I switched setting to voice activation
    2009-12-30 13:45:15.591773|INFO    |ClientUI      |   | Disconnect, total time: 71 - 208352
    No matter what I do, the only way I can talk is by pushing the push-to-talk button.

    Here the log file of Beta 2 (connected to the same server)
    Code:
    2009-12-30 13:52:47.514924|INFO    |              |   | Logging started, clientlib version: 3.0.0-beta2 [Build: 9400]
    2009-12-30 13:52:48.194184|INFO    |ClientUI      |   | TeamSpeak 3 client version: 3.0.0-beta2 [Build: 9400]
    2009-12-30 13:52:48.194295|INFO    |ClientUI      |   | Qt version: 4.5.3
    2009-12-30 13:52:53.628694|WARNING |              |   | Update check timeout
    2009-12-30 13:53:01.679789|INFO    |PreProSpeex   |  1| Speex version: 1.2rc1
    2009-12-30 13:53:01.846479|INFO    |ClientUI      |  1| getServerHostPort result: xxx.xxx.xxx.xxx 9987
    2009-12-30 13:53:37.556518|INFO    |ClientUI      |   | Disconnect, total time: 35 - 208387
    After connecting voice activation is not working even it is active in the preferences. If I switch to permanent sending or push-to-talk (doesn't matter) and back to voice activation, everything works fine till I quit Teamspeak. Moreover, I don't get the error message in the log: Enforcing push-to-talk

    I don't expect a quick fix, it would be just nice to get a hint what can it be or just to know if anybody has an eye on it. No reply at all is a little bit irritating me because I still don't know if anybody else has this issue or is it my own fault.

    Regards, Helicon

  4. #4
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    10
    Found a hint in the changelog:
    Code:
    * Updated German translation
    - Prevent enabling VAD/continuous transmission via options dialog when
      force-push-to-talk permission is set
    Where can I find this setting?! Please help me, I'm going crazy

    Who is enforcing push-to-talk? The server or the client? I cannot find any option in the client and if it is the server, why can my buddies use voice activation in the same channel (mostly Win users as far as I know)?

    Regards, Helicon


    P.S.: Ok, I found a public server and voice activation worked. So it is a server setting. I would be nice if the client shows a message if the server is forcing push-to-talk. I will have a chat with my server admin and will post an update as soon as possible for others. BTW I just asked a buddy in the same channel and his voice activation works.
    Last edited by Helicon; 02-01-2010 at 12:13.

  5. #5
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    10
    Problem fixed. The Group I belong to was forced to push-to-talk at the server. Our admin fixed the setting and everything works fine again.

    It's not a bug, it's a feature nobody knows

    Happy new year,
    Helicon

  6. #6
    Join Date
    Dec 2009
    Location
    Johnson City, N.Y.
    Posts
    9
    Sorry I didn't see this until now. I would have mentioned it. I do it on our server as it can be annoying hearing everything going on at someone elses location. It will also use less resources if clients can only transmit while they are meaning to. Less chance of resources being used if they have to push the button rather than every little peep burp cough or fart coming over ts3.

    Regards,Z_V

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Push to talk & Voice Activation - Neither Work
    By Spencerjdb in forum [TeamSpeak 2] Client Support
    Replies: 5
    Last Post: 03-01-2010, 19:43
  2. Toggle between Push to Talk and Voice activated
    By Thoorleif in forum Client Support
    Replies: 2
    Last Post: 23-12-2009, 10:29
  3. mic and push to talk and voice activation not working
    By lpphoenix in forum [TeamSpeak 2] Client Support
    Replies: 0
    Last Post: 07-12-2007, 23:31
  4. Push to talk works, but not voice activation?
    By AOWKralizec in forum [TeamSpeak 2] Client Support
    Replies: 1
    Last Post: 26-01-2007, 16:51
  5. Push to talk und Voice activation funktionieren nicht mehr
    By newbroker in forum [TeamSpeak 2] Client Support
    Replies: 8
    Last Post: 03-07-2006, 15:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •