Community Forums Today's Posts     Member List     Archive    
Page 4 of 95 FirstFirst ... 234561454 ... LastLast
Results 46 to 60 of 1417
  1. #46
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    1,869
    Quote Originally Posted by oceanseye View Post
    the bot is now running and running and running and it is great, thanks so far.

    But one more things makes me wonder. Is it possible to run the bot on multiple virtual server. I know I have to enter either the port or the sid. Is it possible to manage a second cfg and the script will take both cfg at once?
    Currently not as single process. Of course you can start the Bot in a second process, but you should use a different working directory.

    Example:
    cd JTS3ServerMod/server2/
    java -jar JTS3ServerMod.jar

    So the config file has to be in the directory server2 and the logfile will be created in the server2 directory.

  2. #47
    Join Date
    Jan 2010
    Location
    Netherlands
    Posts
    76
    Hello Stefan,

    I tried the welcome message function but i think it dosn't work.
    I don't get a error or anything like that.
    But when i join the server i don't get the welcome message.
    # Enable default welcome message, 0 = disable, 1 = enable
    # This welcome message, if enabled, will be used for all other groups than specified for welcomemessage_groups.
    # If welcomemessage_enable is disabled, the this will be used for all clients in all groups.
    default_welcomemessage_enable = 1
    # Put default welcome message here. You can use \n for a new line and typical BBCode like in Teamspeak 3 Client.
    # You can use the following keywords, which will be replaced:
    # %CLIENT_NICKNAME% - Nickname of the client
    # %CLIENT_VERSION% - Client version
    # %CLIENT_PLATFORM% - Client platform (Windows, Linux, ...)
    # %CLIENT_CREATED% - Date and time of the first connection of the client
    # %CLIENT_TOTALCONNECTIONS% - Total connection count of the client
    # %CLIENT_UNREAD_MESSAGES% - Offline message count
    # %CLIENT_MONTH_BYTES_UPLOADED% - Uploaded data in current month (filetransfer and avatar)
    # %CLIENT_MONTH_BYTES_DOWNLOADED% - Downloaded data in current month (filetransfer and avatar)
    # %CLIENT_TOTAL_BYTES_UPLOADED% - Uploaded data all times (filetransfer and avatar)
    # %CLIENT_TOTAL_BYTES_DOWNLOADED% - Downloaded data all times (filetransfer and avatar)
    default_welcomemessage_message = Welkom %CLIENT_NICKNAME% op de TeC The Elite Corps Teamspeak! Installed Mods: JTS3ServerMod rc4
    # You can set another welcome message for specified server groups.
    welcomemessage_enable = 0
    # Write a comma seperated list of server group ids here, which should get this welcome message.
    welcomemessage_groups =
    # Put welcome message here. Same keywords like default_welcomemessage_message.
    # You can also use \n for a new line and typical BBCode like in Teamspeak 3 Client.
    welcomemessage_message = Welkom %CLIENT_NICKNAME% op de TeC The Elite Corps Teamspeak! Installed Mods: JTS3ServerMod rc4
    Can you have a look at this function.

  3. #48
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    1,869
    Quote Originally Posted by DarRoe View Post
    I tried the welcome message function but i think it dosn't work.
    I don't get a error or anything like that.
    But when i join the server i don't get the welcome message.

    Can you have a look at this function.
    You found a bug . Will be fixed in next version, maybe tomorrow.

    But there is a workaround, set in config file:
    Code:
    welcomemessage_enable = 1
    welcomemessage_groups = -1
    welcomemessage_message = Any text, will never be displayed. But at least two characters.
    Now everyone should get the message you set at default_welcomemessage_message.

  4. #49
    Join Date
    Mar 2009
    Location
    Netherlands
    Posts
    41
    Uhm, as I see he just forgot to enable it:

    welcomemessage_enable = 0

    Also, he didn't set the welcomemessage_groups...

    Dunno if this is the copy paste from the server?

    Edit: Stefan, you should change the config file to:
    default_welcomemessage_message = Welcome MSG
    # The fields below cannot be blank, if you don't want to use these functions just leave the defaults.
    # You can set another welcome message for specified server groups.
    welcomemessage_enable = 1
    # Write a comma seperated list of server group ids here, which should get this welcome message.
    welcomemessage_groups = -1
    # Put welcome message here. Same keywords like default_welcomemessage_message.
    # You can also use \n for a new line and typical BBCode like in Teamspeak 3 Client.
    welcomemessage_message = ..

  5. #50
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    1,869
    Quote Originally Posted by ThaLegend View Post
    Uhm, as I see he just forgot to enable it:

    welcomemessage_enable = 0

    Also, he didn't set the welcomemessage_groups...
    But he enabled default_welcomemessage_enable. There was really a bug, RC4 only register server events (to see "connecting clients") if welcomemessage_enable = 1, not if default_welcomemessage_enable = 1. This is already fixed in my version.

    But the workaround posted 12 hours ago works without problem, so I delay a bugfix release until I get the next big feature ready: Internal multiple instances of the bot, which allows the bot to connect to many (virtual and physical) servers with only one bot process. Two another great features was also added, so stay tuned .

  6. #51
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    1,869
    A new version with big changes. Almost anything can be done now with chat commands. Just type !bothelp and be surprised (you need bot admin rights, of course).

    Version 1.0 RC 5 (19.02.2010)
    + New feature: Chat command !lastseen to see somebody's last online time. Possible to disable this for public use.
    + New: Bot Instance Manager, start many bot instances for different Teamspeak 3 servers with one bot process.
    + New: Admin chat commands !botcfghelp, !botcfgget, !botcfgset, !botcfgcheck, !botcfgsave, !botinstancestart, !botinstancestop and !botinstancelist
    + New: !bothelp <command> can now display an info text about a command.
    - Bugfix: Default welcome message did not work if the second welcome message is disabled. (thx to DarRoe)
    o Added connect message, if the connection to Teamspeak server is successful.
    Download and more informations in first post.

  7. #52
    Join Date
    Jan 2010
    Location
    Netherlands
    Posts
    76
    It's working.
    But it's not working as i hoped. I thought you were getting a welcome message in the virtualserver chat but instead you get a private message.

    But beside that it's still a great tool.

  8. #53
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    1,869
    Quote Originally Posted by DarRoe View Post
    But it's not working as i hoped. I thought you were getting a welcome message in the virtualserver chat but instead you get a private message.
    Sorry, that is not possible. Since everyone on the server will get this message everytime someone connects. This would bug everyone, I think .

    Maybe someday it will be possible to display a message in the server tab for one client only with a special telnet command, but I don't think that this will be implemented by the Teamspeak developers .

  9. #54
    Join Date
    Jan 2010
    Location
    Netherlands
    Posts
    76
    Quote Originally Posted by Stefan1200 View Post
    Sorry, that is not possible. Since everyone on the server will get this message everytime someone connects. This would bug everyone, I think .
    It dosn't mather. Maybe they can make this post a sticky because it's a great tool and simple to use.

  10. #55
    Join Date
    Mar 2009
    Location
    Netherlands
    Posts
    41
    Yeah would be cool,

    btw DarRoe

    dosnt mather = Doesn't Matter hahaah

  11. #56
    Join Date
    Dec 2009
    Location
    E US
    Posts
    12
    Working fine for me, WinXP SP2 and Win7 Ultimate :] Love the features, many should be built in to TS3 i think.
    Just wondering, what are the chat commands? EDIT: Got it, helps to read the readme
    Last edited by UnitZ; 21-02-2010 at 00:25.

  12. #57
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    1,869
    Now we reach version 1.0 final. Only one bugfix and some small changes.

    Version 1.0 Final (21.02.2010)
    - Bugfix: If a start error in a bot instance occurred, the whole bot process quits. This is now changed, only the bot instance stops working.
    o The instance manager checks now if the config file exists. If not, a special error message will be displayed.
    o Changed the text output on the command line.
    See first post for more informations and download link.
    Last edited by Stefan1200; 21-02-2010 at 16:22.

  13. #58
    Join Date
    Dec 2009
    Location
    Hungary
    Posts
    428
    Hi,
    Is it possible to implement this feature: send private message to a Server Group or to Channel Admins only? This way I can send messages only to Server / Channel Admins for example.

  14. #59
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    1,869
    Quote Originally Posted by Slater View Post
    Hi,
    Is it possible to implement this feature: send private message to a Server Group or to Channel Admins only? This way I can send messages only to Server / Channel Admins for example.
    To understand this right:
    You write something to the bot like this:
    !msgchannelgroup 5 Hello channel admins, please do something...
    !msgservergroup 6 Hello server admins, please do something...
    And the bot sends a private message to clients in this group, that are currently online on the server?

  15. #60
    Join Date
    Dec 2009
    Location
    Hungary
    Posts
    428
    Quote Originally Posted by Stefan1200 View Post
    To understand this right:
    You write something to the bot like this:
    !msgchannelgroup 5 Hello channel admins, please do something...
    !msgservergroup 6 Hello server admins, please do something...
    And the bot sends a private message to clients in this group, that are currently online on the server?
    Exactly

Thread Information

Users Browsing this Thread

There are currently 4 users browsing this thread. (0 members and 4 guests)

Similar Threads

  1. [No Bug] Idle Time even thou people are not idle.
    By brewek in forum Bug Reports
    Replies: 3
    Last Post: 10-11-2011, 15:27
  2. [Resolved] JTS3ServerMod server query permission help
    By n406c in forum Permission System
    Replies: 2
    Last Post: 01-04-2011, 22:08
  3. Replies: 4
    Last Post: 09-01-2011, 02:58
  4. [Solved] Need help with JTS3ServerMod ts3_server_password
    By enyceckk in forum Server Support
    Replies: 4
    Last Post: 11-07-2010, 11:42

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •