Community Forums Today's Posts     Member List     Archive    
Page 1 of 3 123 LastLast
Results 1 to 15 of 39
  1. #1
    Join Date
    Sep 2010
    Location
    vienna
    Posts
    3

    Solved TS3 Server automagically connecting to 194.97.114.3:2010

    The server is automatically connecting to the said address. I suppose it is a measure to make sure the licence conditions are met, however the address belongs to "4Players GmbH" which is not associated with teamspeak (?)
    Is this ok or was the Server binary hacked?

    Thanks for answers.

    Edit: This is not some client that is connected because the connection even existed before i opened the necessary ports in the firewall (which was fully closed before).
    Last edited by quirx; 07-09-2010 at 12:48.

  2. #2
    Join Date
    Jun 2008
    Posts
    8,604
    This is the IP for the web server list.

  3. #3
    Join Date
    Dec 2009
    Location
    The Game!
    Posts
    236
    Port 2010 is the serverlist port, your server connects there to advertise itself on the official serverlist unless you turn it of via query (for each virtual server)

    4Players is a hoster and the weblist as well as the official downloads/updates are hosted on their servers.

  4. #4
    Join Date
    Sep 2010
    Location
    vienna
    Posts
    3

    Question

    Ok, so how exactly do i disable it? What is the query command? Also it seems there is a Webinterface but only for the Teamspeak 2 Server, not for version 3..?

    I tried to start the server with an inifile=server.ini but I don't think it gets read. (Linux)

  5. #5
    Join Date
    Sep 2010
    Location
    vienna
    Posts
    3
    Thanks for the answer!
    I'm sorry I bothered you with these questions but I could not find anything about weblist in the documentation that is shipped with the linux server binary (in the doc folder)
    Doing a
    Code:
    teamspeak3-server_linux-amd64/doc> grep -rin weblist *
    returns no results, neither does searching the pdf for weblist.
    The FAQ on the TS3 server only mentions you can turn it off but not how:
    Just by not publishing your servers IP/Port publicly (and by making sure it is not listed on the official TS3 server web list) [...]
    Maybe update the documentation?

  6. #6
    Join Date
    Dec 2010
    Location
    europe
    Posts
    7
    The command "serveredit virtualserver_weblist_enabled=0" is not disabling the udp-connection to 194.97.114.3. Could you please tell me how to disable this connection permanently?

  7. #7
    Join Date
    Jan 2011
    Posts
    1

    Any more news on this?

    I have the same problem. I have made the edit through server query, I can see that it has been recorded in the serverinfo string, and I have restarted the server. The server is still connecting to the weblist server on port 2010.

    Any help would be appreciated.

    Server version: 3.0.0-beta30 [Build: 12998] on Linux

    87

  8. #8
    Join Date
    Dec 2010
    Location
    europe
    Posts
    7
    TS3 is still connecting to 194.97.114.3:2010 even if weblist is disabled. It's not possible to block that connection with a host based firewall and thats really ugly. Well, TS3 isn't open source and if there isn't anybody who can tell me why this must happen or how to disable this, I'll stop using it.

  9. #9
    Join Date
    Jan 2011
    Posts
    14
    Quote Originally Posted by piotr View Post
    TS3 is still connecting to 194.97.114.3:2010 even if weblist is disabled. It's not possible to block that connection with a host based firewall and thats really ugly. Well, TS3 isn't open source and if there isn't anybody who can tell me why this must happen or how to disable this, I'll stop using it.
    I to am a Linux geek look to this article to help solve your issue. Since port blocking on linux gets a bit tricky I think this article should solve your issue

    http://elouai.com/hosts-linux.php

    Now mind you IP Blocking might render your Server dead keep that in mind, since it is serving updates to the product as well. TS3 might need this IP also for check in. Since I doubt that it is causing a ton of overhead on your system I would just let it be.

  10. #10
    Join Date
    Jun 2008
    Posts
    8,604
    You are right, the server should not connect to it, when all virtual servers don't use the weblist.

    I wrote a ticket for this into our bugtracker.
    TS-379

    This behavior will be changed with our next server version (Build 13600 or newer).

    Temporary fix: Please disbale all weblist settings on all virtual servers. Now start the whole instance. This should fix, that your server asks for weblist.
    Last edited by florian_fr40; 07-04-2012 at 21:50.

  11. #11
    Join Date
    Dec 2011
    Posts
    1
    Any update to this please? Looks like the problem still persists.
    If not, could you clarify on how to "disable all weblist settings". I could only find one setting in either gui or the server query documentation and neither would make any difference.

  12. #12
    Join Date
    Apr 2012
    Posts
    1
    I also have the same issue. I hade two connections:

    Code:
    # sockstat | grep 2010
    teamspeak ts3server_80251 19 udp4   [machines base IP]:45181   194.97.114.3:2010
    teamspeak ts3server_80251 26 udp4   [voice_ip]:2011            194.97.114.3:2010
    Then I set "serveredit virtualserver_weblist_enabled=0" for all of my virtual servers. Then I restarted the server and now one UDP connection remains:

    Code:
    # sockstat | grep 2010
    teamspeak ts3server_21984 19 udp4   [machines base IP]:36520   194.97.114.3:2010
    How can this be shut down?

  13. #13
    Join Date
    Jun 2008
    Posts
    8,604
    Update
    This should be fixed with the latest server release already.

    Ollil
    You have to disable, that your virtual server(s) have the weblist enabled.
    http://forum.teamspeak.com/showthrea...542#post256542
    ---------------------------------------------------------
    Please don't send me private messages with support questions as long I or someone else from Teamspeak Staff asked for it.
    Seriously > They belong into the forum and maybe other users have these questions/problems too.


    TeamSpeak FAQ || What should i report, when i open a client thread? || Report and upload your Crashdump here
    NPL License (Registration)

  14. #14
    Join Date
    May 2012
    Posts
    2
    Hi Dante,

    To not open an seperate ticket/thread for this.
    I would like to note that in version "version=3.0.5 build=1335156372 platform=Linux" this 'bug/problem/feature' is still present.

    I've tested this on the following setup.

    > Got an totally fresh server (as in, new hardware + fresh install of CentOS + updates). To rule our a auto-reply of people to check other software.
    > Downloaded a fresh TS3 server > teamspeak3-server_linux-x86-3.0.5.tar.gz
    > Copied the license setup
    > Did "./ts3server_startscript.sh start"
    > Then with the supplied info i've connected to the 10011 port with telnet
    > disabled using the command "serveredit virtualserver_weblistnabled=0" on both the instance + virtual server.

    serverlogin serveradmin blablabla
    error id=0 msg=ok

    use 0
    error id=0 msg=ok

    serverinfo
    ...
    virtualserver_weblistnabled=0
    ...
    error id=0 msg=ok

    use 1
    error id=0 msg=ok

    serverinfo
    ...
    virtualserver_weblist_enabled=0
    ....

    serverprocessstop
    error id=0 msg=ok

    > Did a netstat -nalp to see the connection actually dissapeared, it did.
    > Restarted the server, and quickly checked all the variabled, they were all disabled
    > Did a netstat -nalp, it created a new connection.
    > Waited 30 minutes
    > Did a netstat -nalp, it's still there, same session.

    udp 0 0 X.X.X.X:49944 194.97.114.3:2010 ESTABLISHED 18317/./ts3server_l

    So, are you sure it's fixed in the latest version? :-)

  15. #15
    Join Date
    Jun 2008
    Posts
    8,604
    Thank you for this report, I will retest it and paste my results here.

    And there is no other server instance or virtual server running?

    Update #2
    I can reproduce this under Linux
    Internal Ticket ID TSSERVER-55
    Last edited by dante696; 11-05-2012 at 09:51.
    ---------------------------------------------------------
    Please don't send me private messages with support questions as long I or someone else from Teamspeak Staff asked for it.
    Seriously > They belong into the forum and maybe other users have these questions/problems too.


    TeamSpeak FAQ || What should i report, when i open a client thread? || Report and upload your Crashdump here
    NPL License (Registration)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TS3 SDK3 on VS 2010 IDE
    By Tron86 in forum General Questions
    Replies: 0
    Last Post: 14-12-2011, 02:00
  2. [Resolved] TS3 Server automagically connecting to 194.97.114.3:2010
    By quirx in forum Server Support
    Replies: 12
    Last Post: 03-02-2011, 08:33
  3. [Info] Server hangs with "Panda GP-2010"
    By Jordi in forum Windows
    Replies: 2
    Last Post: 02-08-2010, 19:30
  4. [Info] Server hangs with "Panda GP-2010"
    By Jordi in forum Bug Reports
    Replies: 2
    Last Post: 02-08-2010, 19:30
  5. TS3 on Mandriva 2010.0 (32-bit)
    By Ishark in forum Linux
    Replies: 3
    Last Post: 27-04-2010, 10:24

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •