Community Forums Today's Posts     Member List     Archive    
Results 1 to 8 of 8
  1. #1
    Join Date
    Mar 2012
    Posts
    5

    Server refuses all connections

    Hi,
    I have strange problem. I've just configured my TS3 server on vServer. Everything looks fine, console returns that it is listening on port 9998 as intended. However whenever I try to connect through the query port or connect to the server, my ts client says that it failed to connect. I have no problem with other servers, all my ports are unlocked. I've tried to connect from the job and home. Other people can't join as well but server says it's running fine... Here is what netstat -an says:

    udp 0 0 **x.x.x.x:9998 0.0.0.0:*
    ** - Where x.x.x.x is my server's IP address.

    Here is my console:
    2012-03-17 09:10:58.369427|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.2 (2012-02-29 05:39:32)
    2012-03-17 09:10:58.370161|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2012-03-17 09:10:58.370230|INFO |DatabaseQuery | | dbPlugin version: 3.7.3
    2012-03-17 09:10:58.370641|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2012-03-17 09:10:58.398355|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2012-03-17 09:10:58.410718|INFO |FileManager | | listening on **x.x.x.x:30033
    2012-03-17 09:10:58.446774|INFO |VirtualServer | 1| listening on **x.x.x.x:9998
    2012-03-17 09:10:58.446947|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
    2012-03-17 09:10:58.447213|INFO |Query | | listening on **x.x.x.x:10019

    ** - Where x.x.x.x is my server's IP address.

    Hosts.allow and hosts.deny are empty. I don't know how to configurate iptables. Maybe that's the key but as I've read via internet, it allows everyone to connect by default unless you filter it by yourself. I have no clue what to do. I had no problem with configuring other server. But this one just doesn't work. By the way the error with the license doesn't matter. I have the license file but just didn't use it yet, until me or someone figure out what's going on and how to fix my problem.

    Can anyone help me with this issue? My vServer provider says that they do not filter anything in my server's network.


    P.S: By the way I'm using CentOs 6.0 and obviously my server is detached on screen in the background.

  2. #2
    Join Date
    Apr 2011
    Location
    Germany
    Posts
    1,096
    Have you checked the firewall rules defined on your vps? (check "iptables --list -n")
    Have you tried to connect to ts server query from the server itself?

    You should not run the server with a detachted screen, you should use the scripts to run the server.
    "./ts3server_startscript.sh start" is still the best way to run your server!

  3. #3
    Join Date
    Mar 2012
    Posts
    5
    I figured it out after your post. Got an idea to run setup system and turn off firewall completely. It works now. However I have to setup firewall again soon because it's too dangerous. CentOS always has it's own firewall turned as I've heard. Debian not. That's why it worked on my virtual box (debian) server but didn't on vServer (CentOS).

  4. #4
    Join Date
    Apr 2011
    Location
    Germany
    Posts
    1,096
    Ok, so turn on your firewall again... You need to at one rule for voice (udp 9998), and if you like two other rules for server query and file transfer.

    Do a "iptables --list -n" again and look out for your INPUT-Chain.

    You need to add the rules there.

    For voice you might want to add something like this:
    "iptables -I <your input chain> -p udp --dport 9998 -j ACCEPT"

    As you might have guessed server query could look like:
    "iptables -I <your input chain> -p tcp --dport 10019 -j ACCEPT"
    Last edited by Barungar; 17-03-2012 at 16:43. Reason: add ex. rule server query

  5. #5
    Join Date
    Mar 2012
    Posts
    5
    This is how it look right now:

    iptables --list -n
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    ACCEPT all -- 0.0.0.0/0 0.0.0.0/0 state RELATED,ESTABLISHED
    ACCEPT icmp -- 0.0.0.0/0 0.0.0.0/0
    ACCEPT all -- 0.0.0.0/0 0.0.0.0/0
    ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 state NEW tcp dpt:22
    REJECT all -- 0.0.0.0/0 0.0.0.0/0 reject-with icmp-host-prohibited
    ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:9998
    ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:9998
    ACCEPT udp -- 0.0.0.0/0 0.0.0.0/0 udp dpt:9998
    ACCEPT udp -- 0.0.0.0/0 0.0.0.0/0 udp dpt:9987 state NEW
    ACCEPT udp -- 0.0.0.0/0 0.0.0.0/0 udp dpt:9998 state NEW

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination
    REJECT all -- 0.0.0.0/0 0.0.0.0/0 reject-with icmp-host-prohibited

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

  6. #6
    Join Date
    Mar 2012
    Posts
    5
    Ok, here is how it looks right now:

    Code:
    iptables --list -n
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           state RELATED,ESTABLISHED
    ACCEPT     icmp --  0.0.0.0/0            0.0.0.0/0
    ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:22
    REJECT     all  --  0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:9998
    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:9998
    ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0           udp dpt:9998
    ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0           udp dpt:9987 state NEW
    ACCEPT     udp  --  0.0.0.0/0            0.0.0.0/0           udp dpt:9998 state NEW
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    REJECT     all  --  0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    I have no idea how to setup iptables unfortunately. I have read a few topics on this forum and used commands similar to that you said.

  7. #7
    Join Date
    Apr 2011
    Location
    Germany
    Posts
    1,096
    Problem is your rules must be before the deny all rule... everything after "REJECT all -- 0.0.0.0/0 0.0.0.0/0 reject-with icmp-host-prohibited" ist quite useless. you need to delete all your rules.

    ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:9998
    ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:9998
    ACCEPT udp -- 0.0.0.0/0 0.0.0.0/0 udp dpt:9998
    ACCEPT udp -- 0.0.0.0/0 0.0.0.0/0 udp dpt:9987 state NEW
    ACCEPT udp -- 0.0.0.0/0 0.0.0.0/0 udp dpt:9998 state NEW


    then delete the reject all rule... after that insert your rules again and then re-insert the reject-all rule... viola!

  8. #8
    Join Date
    Mar 2012
    Posts
    5
    Thanks. I'm gonna check that tommorow and I will update this post when I'm done.
    It work now. Thanks for advice.
    Last edited by DavidCopperhead; 19-03-2012 at 23:16.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Server connect window refuses to close
    By Amducious in forum [TeamSpeak 2] Client Support
    Replies: 2
    Last Post: 10-07-2008, 18:29
  2. Random Crashes, Refuses New Connections
    By maydax in forum [TeamSpeak 2] Server Support
    Replies: 1
    Last Post: 19-03-2005, 23:11
  3. TS2 suddenly refuses to connect to server
    By StEELhEArT in forum [TeamSpeak 2] Client Support
    Replies: 0
    Last Post: 30-06-2004, 01:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •