I have exactly same problem. Where do you get older versions of TeamSpeak client?