I have the same problem with the newest release of TS3 so that doesn't fix it. It still says Api version is not compatible : 22 ( minimum:23, current 23 )