The question is not so much about the future of XP since TS 3.0.19.4 runs well.
But why is there no compatibility between TS3 and TS3?
(ex: Server 3.1.x and Client 3.0.19.4)