Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Search:

Type: Posts; User: furicle; Keyword(s):

Search: Search took 0.01 seconds.

  1. [Not Supported] Actually, IIUC, Snow Leopard upgrades are NOT...

    Actually, IIUC, Snow Leopard upgrades are NOT free, you have to have 10.7 to qualify. And this machine won't 64bit anyway. Shame it doesn't say that on the download page...

    Thanks for confirming
  2. [Not Supported] FYI - tried 3.0.16 - it works...

    FYI - tried 3.0.16 - it works...
  3. [Not Supported] Client 3.0.17 (and newer) on OSX 10.5 /10.6 / 10.7

    Hi All

    First time trying to use TS3 on a Mac. Downloaded from download page 3.0.17
    Running 10.6.8

    Opened dmg and copied app to Applications - Try to open it and I get the Apple crash box
    ...
Results 1 to 3 of 3