I go to update my teamspeak and i get past the first update where it says updating updater then it crashes and says"Check with the developer to make sure update works with the version of mac os X....