Forum

Results 1 to 15 of 15
  1. #1
    Join Date
    February 2012
    Location
    Nuremberg, Bavaria
    Posts
    258

    Filetransfer timeout

    Hello,

    I want to set up my firewall correct and need to know, what I need to allow/forward/preroute for filetransfers.

    In your documentation is written, that the port 30033/tcp is used for uploading avatars, icons, files and all other files. But if I just preroute and allow this port, my clients reports me following message:
    Quote Originally Posted by Latest TeamSpeak 3 Client
    <17:32:24> Transfer "Plugins.png" reports: (could not open file transfer connection)
    But on the server-side, the file was created - just without content. Well... There is a problem with transfering the file content. I think this is a active filetransfer, is it? Is this filetransfer protocol of TeamSpeak using a range of ports for filetransfers or is it dynamic?

    I hope, somebody of the developer or TeamSpeak team can answer my questions. Thanks in advance!

    Oh... And yes: The permissions are set correct! I am using the default values...
    Last edited by dante696; June 20th, 2014 at 11:38 PM. Reason: thread title changed

  2. #2
    Join Date
    June 2008
    Posts
    18,396
    The empty file only means, the server was able to write the file.
    The rest comes from filetransfer port 30033 (tcp incomming).
    Please make sure, that the port is opened + check your server log for errors and for the filetransfer port.

    PLEASE ENGLISH ONLY!
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    February 2012
    Location
    Nuremberg, Bavaria
    Posts
    258
    The Filetransfer port is set to 30033 and the server is listen to it:
    $ netstat -tulpen | grep 30033
    tcp 0 0 192.168.178.240:30033 0.0.0.0:* LISTEN 1001 1327872 322/ts3server_linux
    My firewall/router reports also that the port is open and nated:
    $ iptables -L -n -v -t nat | grep 30033
    Chain PREROUTING (policy ACCEPT 2503 packets, 173K bytes)
    pkts bytes target prot opt in out source destination
    136 7652 DNAT tcp -- * * 0.0.0.0/0 194.10.20.30 multiport dports 30033 /* TeamSpeak Filetransfers */ to:192.168.178.240
    Chain POSTROUTING (policy ACCEPT 863 packets, 55164 bytes)
    pkts bytes target prot opt in out source destination
    1666 115K MASQUERADE all -- * eth0 0.0.0.0/0 0.0.0.0/0 /* Masquerade private IP addresses with WAN-IP */[/QUOTE]

    If I check the port state from another machine, nmap tells me following:
    $ nmap 194.10.20.30 -p 30033

    Starting Nmap 6.00 ( http://nmap.org ) at 2014-06-21 02:47 CEST
    Nmap scan report for 194-10-20-30.clients.de (194.10.20.30)
    Host is up (0.00064s latency).
    PORT STATE SERVICE
    30033/tcp open unknown

    Nmap done: 1 IP address (1 host up) scanned in 0.16 seconds
    My instance log file reports following:
    2014-06-20 13:10:18.379176|INFO |FileManager | | listening on 192.168.178.240:30033
    And the server log self following:
    2014-06-20 17:12:21.006195|INFO |VirtualServer | 2| file upload to (id:30), '/001_Pizza_Flyer.jpg' by client 'Sebbo'(id:8)
    2014-06-20 17:13:10.442709|INFO |VirtualServer | 2| file deleted from (id:30), 'files/virtualserver_2/channel_30//001_Pizza_Flyer.jpg' by client 'Sebbo'(id:8)
    2014-06-20 17:13:21.878352|WARNING |FileTransfer | 2| Failed to remove files/virtualserver_2/channel_30/001_Pizza_Flyer.jpg

  4. #4
    Join Date
    December 2004
    Location
    RF
    Posts
    3,007
    Why you DNAT a local port?...

  5. #5
    Join Date
    February 2012
    Location
    Nuremberg, Bavaria
    Posts
    258
    What should I do else? Between internet and TeamSpeak server is a router with firewall...

    In anyway, I have to tell my router, that the port 30033/TCP is associated with the TeamSpeak server.

    What's your suggestion?

  6. #6
    Join Date
    December 2004
    Location
    RF
    Posts
    3,007
    Though, the output from the same system.

  7. #7
    Join Date
    February 2012
    Location
    Nuremberg, Bavaria
    Posts
    258
    There are no output rules, if you mean this.

  8. #8
    Join Date
    February 2012
    Location
    Nuremberg, Bavaria
    Posts
    258
    Solved!

    Solution: Set the filetransfer_ip in the INI-File to 0.0.0.0

  9. #9
    Join Date
    December 2004
    Location
    RF
    Posts
    3,007
    LOL? It's the default setting.

  10. #10
    Join Date
    February 2012
    Location
    Nuremberg, Bavaria
    Posts
    258
    Yes, but normally you have to set the IP of your network adapter and that was not working... With the default IP is it working.

    The other IP variables are set to my adapters IP.

  11. #11
    Join Date
    April 2011
    Location
    Germany
    Posts
    1,266
    Yeah, that is afaik a quite known issue. It is not a bug to me, but it is an inconvenience.

    Problem imho is that the voice port/IP are used while connecting, so no problem here. The SQ port/IP are also normally used by users who know the port/ip and are also used at initial connection.

    But the file transfer is used by users who don't enter any ip/port, it just works. And how can that be...? The only solution is that the teamspeak server tells the user which port/IP he needs to use to initiate a file transfer. Because that could be any IP or port... it must not even be the same IP as the voice or SQ IP.

    So, if you set a private IP as file transfer IP the server is going to tell the user to connect to that IP, which of course won't work with a private IP... and so the users gets timeouts. But the server awaiting the upload of the file may have done some actions in advance like creating a file on disc or so.

    By not setting a dedicated file transfer IP (aka 0.0.0.0) the server tells the user to use the same IP as he did to connect to the voice port/IP.

    So in short only use the ini file option for file transfer if your server has a public IP and not any private or else file transfer from outside that private network will fail with timeout. I think this was discussed twice or so on this forum already.

  12. #12
    Join Date
    December 2004
    Location
    RF
    Posts
    3,007
    Quote Originally Posted by Sebi94 View Post
    Yes, but normally you have to set the IP of your network adapter
    No. Normally, you don't touch these settings at all.
    You only ever need to touch them if you absolutely need it to listen at the specific IP only. Such as binding query console to the 127.0.0.1.

  13. #13
    Join Date
    February 2012
    Location
    Nuremberg, Bavaria
    Posts
    258
    @Barungar: Ah, okay. Very good to know! Thanks.

    @ANR Daemon: I need to listen at the specific IP, that's the reason, why I use the INI-File. But also thanks for the info, that the defaults are also "perfect". It's nice to know.

    Thread can be closed.

  14. #14
    Join Date
    December 2004
    Location
    RF
    Posts
    3,007
    If you need ti to listen on specific IP, you can limit only voice servers to it. Filetransfer is largely useless withough authorisation from voice server.
    Also, it is a good question, if TS3 is actually TELL client to use specific IP for filetransfers, if it's changed, or it always assume that the IP is the same as voice server IP?
    The first would be error-prone in more cases, than I can count, I'm afraid.

  15. #15
    Join Date
    April 2011
    Location
    Germany
    Posts
    1,266
    Quote Originally Posted by Sebi94 View Post
    @Barungar: Ah, okay. Very good to know! Thanks.

    @ANR Daemon: I need to listen at the specific IP, that's the reason, why I use the INI-File. But also thanks for the info, that the defaults are also "perfect". It's nice to know.

    Thread can be closed.
    No, problem... I have actually checked it a while ago because it startled me, too. So I traced the network traffic. And if you set a value for filetransfer_ip the teamspeak client is somehow told this ip by the server and tries to connect to that IP. So if you enter here a private IP or even 127.0.0.1 the client acutally uses those IPs to open a filetransfer connection.

    Only by using the default 0.0.0.0 a filetransfer with NAT is possible. Because in that case the client actually tries to open the filetransfer on the same IP he uses for voice udp.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: July 10th, 2015, 07:35 PM
  2. [Resolved] Hot to allow filetransfer (when timeout)
    By Joosmanz in forum General Questions
    Replies: 1
    Last Post: August 29th, 2011, 11:15 AM
  3. Filetransfer timeout
    By Der_Pate in forum Windows
    Replies: 6
    Last Post: July 5th, 2010, 08:34 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •