Forum

Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Join Date
    September 2012
    Posts
    6,077

    TeamSpeak 3 Client 3.0.15.1 released

    This is a hotfix release to fix some crashes and issues with the client not responding in response to some malicious Text messages being sent to clients.

    Full changelog can be found below as usual.
    Code:
    === Client Release 3.0.15.1 14 Jul 2014
    - Fixed possible client freeze with url tags.
    - Fixed possible client freeze with huge images.
    - Images (both remote and ts3image) with width or height > 4000 px are now
      refused and no longer displayed in the channel description.
    - Magnet urls are now allowed.
    - Adjustments to TeamSpeak control plugin for better Overwolf compatibility.

  2. #2
    Join Date
    April 2013
    Posts
    42
    Patching update.exe
    Could not patch 'C:/Users/rodolfo/AppData/Local/Temp/teamspeak_temp_0/update.exe_old' to 'C:/Program Files/TeamSpeak 3 Client/update.exe'
    Could not patch 'C:/Users/rodolfo/AppData/Local/Temp/teamspeak_temp_0/ts3client_win64.exe_old' to 'C:/Program Files/TeamSpeak 3 Client/ts3client_win64.exe'
    rolling back file updates
    Update cancelled

  3. #3
    Join Date
    December 2009
    Location
    UK
    Posts
    768
    @skinhead, what version were you updating from? My update went through without any issues

  4. #4
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,335
    I don't know where that other post went/was that I read yesterday, but I too have problems with missing images now, which are - of course - much smaller than 4000px.

  5. #5
    Join Date
    June 2008
    Posts
    17,857
    Here -> http://forum.teamspeak.com/showthrea...666#post385666

    But it is solved already.
    Image 1 was broken in his cache and image 2 isn't available for download.


    What is your file / url ?
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  6. #6
    Join Date
    May 2007
    Location
    Eastern NC
    Posts
    1,793
    Quote Originally Posted by numma_cway View Post
    I don't know where that other post went/was that I read yesterday, but I too have problems with missing images now, which are - of course - much smaller than 4000px.
    Quote Originally Posted by dante696 View Post
    Here -> http://forum.teamspeak.com/showthrea...666#post385666

    But it is solved already.
    Image 1 was broken in his cache and image 2 isn't available for download.


    What is your file / url ?
    Right, I was testing with 3.0.15 on one system and 3.0.15.1 on another. The 3.0.15 is an install I've been running for about 4 years, and it had the images cached and displayed them, even though one of them is not longer available while the 3.0.15.1 is on a new system I've only been using about 30 days, I just didn't notice the broken images until I was actually looking. The other ended up with a 0 byte image in the cache and it appeared to fail to load. I deleted the 0 byte images and it would re-fetch from the server and display correctly. Hopefully the 0 byte cached image issue will be addressed in a future update.

  7. #7
    Join Date
    April 2013
    Posts
    42
    Im updating from 3.0.15 still can't update

  8. #8
    Join Date
    May 2010
    Location
    Germany
    Posts
    7
    Quote Originally Posted by skinhead View Post
    Im updating from 3.0.15 still can't update
    Have had the same issue. I have to download the client again :/

  9. #9
    Join Date
    June 2008
    Posts
    17,857
    What operation system do you both use Win Xp/Win7/Vista etc?
    What are your UAC settings in Windows?
    Where is your config file ( settings.db ) stored at?
    Code:
    %appdata%\TS3Client
    or C:\Program Files\TeamSpeak 3 Client\config
    What kind of windows user do you use? Are you an Administrator or do you use a guest account? Or are multiple accounts active on your system?

    We think there is a problem overwriting the files, because permissions for the updater are missing.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  10. #10
    Join Date
    April 2013
    Posts
    42
    Win7
    ???
    %appdata%\TS3Client
    1 Account and i have administrator

    PS: I tried to update again and it seems like i cant run teamspeak now lol

    -------merged-------

    Got it working had to do with permissions

    -------merged-------

    Quote Originally Posted by Kekskind1992 View Post
    I use Windows 7 as Administrator, the lowest level of UAC "not notify" and the settings.db is stored at "appdata\TS3Client"
    edit the update.exe and in propreties run as administrator
    Last edited by dante696; July 15th, 2014 at 09:18 PM.

  11. #11
    Join Date
    May 2010
    Location
    Germany
    Posts
    7
    I use Windows 7 as Administrator, the lowest level of UAC "not notify" and the settings.db is stored at "appdata\TS3Client"

  12. #12
    Join Date
    July 2013
    Posts
    6
    Most members experiencing lag and voice garbled periods after today's update, not constant. All have tried restarting and reconnecting more than once, no improvement. Bug? Will there be a fix?

  13. #13
    Join Date
    August 2013
    Posts
    56
    I have noticed that the query clients "Online Since" time is displayed incorrectly.

    The time displayed is the same for every query client.

    I am using version 3.0.15.1

    Name:  161kgaq.jpg
Views: 2866
Size:  405.2 KB
    Last edited by H3LLFIRE; July 15th, 2014 at 11:08 PM.

  14. #14
    Join Date
    June 2008
    Posts
    17,857
    Quote Originally Posted by H3LLFIRE View Post
    I have noticed that query the query clients "Online Since" time is displayed incorrectly.
    It's the time that has passed by from 1970-01-01 (Unix time).
    The Query has no timestamp in the database, when it was created. It's no client problem and currently known.
    But thank you for the report.


    Quote Originally Posted by DrGoaT46 View Post
    Most members experiencing lag and voice garbled periods after today's update, not constant. All have tried restarting and reconnecting more than once, no improvement. Bug? Will there be a fix?
    We do not think, that this is related to todays release.

    Please check the connection of these users.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  15. #15
    Join Date
    April 2013
    Posts
    42
    Quote Originally Posted by DrGoaT46 View Post
    Most members experiencing lag and voice garbled periods after today's update, not constant. All have tried restarting and reconnecting more than once, no improvement. Bug? Will there be a fix?
    Funny that this is happening here too i thought it was just another DDoS but i din't receive any email about ddos and i dstat the server and it was normal

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TeamSpeak 3 Client 3.0.16 released
    By PeterS in forum Archive
    Replies: 14
    Last Post: November 4th, 2016, 07:21 AM
  2. TeamSpeak 3 Client 3.0.13 released
    By Chris in forum Archive
    Replies: 9
    Last Post: October 23rd, 2013, 12:21 AM
  3. TeamSpeak 3 Client 3.0.12 released
    By dante696 in forum Archive
    Replies: 7
    Last Post: September 20th, 2013, 02:58 PM
  4. TeamSpeak 3 Client 3.0.11.1 released
    By Chris in forum Archive
    Replies: 3
    Last Post: August 12th, 2013, 07:12 AM
  5. TeamSpeak Client 3.0.10.1 released
    By Chris in forum Archive
    Replies: 2
    Last Post: April 11th, 2013, 09:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •