Forum

Results 1 to 7 of 7
  1. #1
    Join Date
    July 2014
    Posts
    4

    Exclamation Failed to connect to server....

    Hello, new to trying to set up a server and i followed a pretty in-depth guide but i still cant connect....
    i've....
    1. forwarded my ports.
    2. installed the server.
    3. set my PC to have a static local ip and dns.
    4. disabled firewalls
    5. tried connecting on "localhost" "127.0.0.1" "192.168.*.*" and even my external ip (also static its the same everytime i check)
    6. tried to retrieve WAN ip and failed over and over.

    im not using a license ive looked everywhere for a solution maybe im not looking hard enough or im not searching for the right thing. but i could really use help and if there is a thread that solves this issue im sorry i didnt see it.
    Last edited by ChronicLord; July 21st, 2014 at 09:13 PM. Reason: forgot a detail

  2. #2
    Join Date
    December 2009
    Location
    UK
    Posts
    768
    Post your complete server & client logs

  3. #3
    Join Date
    December 2004
    Location
    RF
    Posts
    3,004
    Quote Originally Posted by ChronicLord View Post
    Hello, new to trying to set up a server and i followed a pretty in-depth guide but i still cant connect....
    i've....
    1. forwarded my ports.
    2. installed the server.
    3. set my PC to have a static local ip and dns.
    4. disabled firewalls
    5. tried connecting on "localhost" "127.0.0.1" "192.168.*.*" and even my external ip (also static its the same everytime i check)
    6. tried to retrieve WAN ip and failed over and over.

    im not using a license ive looked everywhere for a solution maybe im not looking hard enough or im not searching for the right thing. but i could really use help and if there is a thread that solves this issue im sorry i didnt see it.
    You forgot to tell, what is your problem...
    Also, #6 is irrelevant to anything at all.

  4. #4
    Join Date
    July 2014
    Posts
    4
    first server log:

    2014-07-21 09:41:02.982621|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.10.3 (2014-01-01 16:28:39)
    2014-07-21 09:41:02.983621|INFO |ServerLibPriv | | SystemInformation: Windows 7 SP1 (7601) x64 (AMD or Intel) Binary: 64bit
    2014-07-21 09:41:02.983621|INFO |ServerLibPriv | | Using hardware aes
    2014-07-21 09:41:02.983621|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2014-07-21 09:41:02.983621|INFO |DatabaseQuery | | dbPlugin version: 3.7.3
    2014-07-21 09:41:02.984621|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2014-07-21 09:41:03.012622|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2014-07-21 09:41:04.191690|INFO | | | Puzzle precompute time: 1169
    2014-07-21 09:41:04.193690|INFO |FileManager | | listening on 0.0.0.0:30033
    2014-07-21 09:41:04.237692|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
    2014-07-21 09:41:04.239693|INFO |Query | | listening on 0.0.0.0:10011

    Second server log:

    2014-07-21 09:41:04.237692|INFO |VirtualServer | 1| listening on 0.0.0.0:9988
    2014-07-21 09:42:02.732038|INFO |VirtualServerBase| 1| stopped


    Third server log:

    2014-07-21 09:43:23.888680|INFO |VirtualServer | 1| listening on 0.0.0.0:9988


    Fourth Server log:

    2014-07-21 09:43:22.446598|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.10.3 (2014-01-01 16:28:39)
    2014-07-21 09:43:22.446598|INFO |ServerLibPriv | | SystemInformation: Windows 7 SP1 (7601) x64 (AMD or Intel) Binary: 64bit
    2014-07-21 09:43:22.446598|INFO |ServerLibPriv | | Using hardware aes
    2014-07-21 09:43:22.447598|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2014-07-21 09:43:22.447598|INFO |DatabaseQuery | | dbPlugin version: 3.7.3
    2014-07-21 09:43:22.447598|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2014-07-21 09:43:22.472599|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2014-07-21 09:43:23.847678|INFO | | | Puzzle precompute time: 1365
    2014-07-21 09:43:23.849678|INFO |FileManager | | listening on 0.0.0.0:30033
    2014-07-21 09:43:23.888680|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
    2014-07-21 09:43:23.890680|INFO |Query | | listening on 0.0.0.0:10011
    2014-07-21 09:43:56.320535|ERROR |GetWanIP | | failed to retrieve WAN ip
    2014-07-21 09:55:56.043701|ERROR |GetWanIP | | failed to retrieve WAN ip
    2014-07-21 18:07:53.623007|ERROR | | | TS3ANetwork::ResolveHostName failed error: 11001 (No such host is known. ) 11001
    2014-07-21 18:07:57.714241|ERROR | | | TS3ANetwork::Connect failed error: 10051
    2014-07-21 18:07:57.714241|DEVELOP | | | UDPConnection::send failed to update target ip
    2014-07-21 18:18:28.930344|ERROR |GetWanIP | | failed to retrieve WAN ip
    2014-07-21 19:03:03.673331|ERROR |GetWanIP | | failed to retrieve WAN ip


    client log:

    7/21/2014 15:54:13 Info TeamSpeak 3 Client 3.0.15.1 (2014-07-14 12:31:32)
    7/21/2014 15:54:13 Info SystemInformation: Windows 7 SP1 (7601) x64 (AMD or Intel) Binary: 32bit
    7/21/2014 15:54:13 Info Using hardware aes
    7/21/2014 15:54:13 Direct Sound Debug setting timer resolution to 1ms
    7/21/2014 15:54:13 Info Loading plugin: appscanner_plugin
    7/21/2014 15:54:13 Info Loading plugin: clientquery_plugin
    7/21/2014 15:54:13 Info Loading plugin: lua_plugin
    7/21/2014 15:54:13 Info Loading plugin: teamspeak_control_plugin
    7/21/2014 15:54:13 Info Loading plugin: test_plugin
    7/21/2014 15:54:13 Info Loading plugin: ts3g15
    7/21/2014 15:54:13 Query Info listening on 127.0.0.1:25639
    7/21/2014 15:54:13 Windows Audio Session Devel DeviceDeleteList::waitForDeletes - enter
    7/21/2014 15:54:13 Windows Audio Session Devel DeviceDeleteList::waitForDeletes - leave
    7/21/2014 15:54:13 Input Info Default monitoring enabled
    7/21/2014 15:54:13 Info *** Time [MAINWINDOW]: 208
    7/21/2014 15:54:13 Info *** Time [INIT]: 208
    7/21/2014 15:54:13 ClientUI Info Qt version: 5.2.1
    7/21/2014 15:54:13 ClientUI Info Using configuration location: C:\Users\The Beast\AppData\Roaming\TS3Client\settings.db
    7/21/2014 15:54:14 ClientUI Info Last update check was: Mon Jul 21 03:52:46 2014
    7/21/2014 15:54:27 ClientUI Info Connect to server: 127.0.0.1
    7/21/2014 15:54:27 ClientUI Info Blacklist check ok
    7/21/2014 15:54:27 ClientUI Info Initiating connection: 127.0.0.1:9987 127.0.0.1
    7/21/2014 15:54:27 Windows Audio Session Devel DeviceDeleteList::waitForDeletes - enter
    7/21/2014 15:54:27 Windows Audio Session Devel DeviceDeleteList::waitForDeletes - leave
    7/21/2014 15:54:27 Windows Audio Session Debug WAS:penDevice-enter
    7/21/2014 15:54:27 Windows Audio Session Debug WAS Buffer size: 896
    7/21/2014 15:54:27 Windows Audio Session Debug WAS:penDevice-leave
    7/21/2014 15:54:27 Windows Audio Session Debug WAS::startDevice-enter
    7/21/2014 15:54:27 Windows Audio Session Debug WAS::startDevice-leave
    7/21/2014 15:54:27 Windows Audio Session Devel DeviceDeleteList::waitForDeletes - enter
    7/21/2014 15:54:27 Windows Audio Session Devel DeviceDeleteList::waitForDeletes - leave
    7/21/2014 15:54:27 Windows Audio Session Debug WAS:penDevice-enter
    7/21/2014 15:54:27 Windows Audio Session Debug WAS Buffer size: 1920
    7/21/2014 15:54:27 Windows Audio Session Debug WAS:penDevice-leave
    7/21/2014 15:54:27 PreProSpeex Info Speex version: speex-1.2beta3
    7/21/2014 15:54:27 Windows Audio Session Debug WAS::startDevice-enter
    7/21/2014 15:54:27 Windows Audio Session Debug WAS::startDevice-leave
    7/21/2014 15:54:27 Windows Audio Session Debug WAS::associateAECDevice-enter
    7/21/2014 15:54:27 Windows Audio Session Debug WAS Buffer size: 896
    7/21/2014 15:54:27 Windows Audio Session Debug WAS::associateAECDevice-leave
    7/21/2014 15:54:27 ClientUI Info Connect status: Connecting
    7/21/2014 15:54:32 ClientUI Info Connect status: Disconnected
    7/21/2014 15:54:32 ClientUI Info Failed to connect to server, want autoreconnect = 0
    7/21/2014 15:54:47 ClientUI Info Connect to server: localhost
    7/21/2014 15:54:47 ClientUI Info Trying to resolve localhost
    7/21/2014 15:54:47 TSDNS Info DNS resolve successful, "localhost"=127.0.0.1
    7/21/2014 15:54:47 TSDNS Info SRV DNS resolve unsuccessful for "_ts3._udp.localhost"
    7/21/2014 15:54:48 ClientUI Info Lookup finished: 127.0.0.1 9987 localhost 0 0
    7/21/2014 15:54:48 ClientUI Info Resolve successful: 127.0.0.1:9987
    7/21/2014 15:54:48 ClientUI Info Blacklist check ok
    7/21/2014 15:54:48 ClientUI Info Initiating connection: 127.0.0.1:9987 localhost
    7/21/2014 15:54:48 ClientUI Info Connect status: Connecting
    7/21/2014 15:54:53 ClientUI Info Connect status: Disconnected
    7/21/2014 15:54:53 ClientUI Info Failed to connect to server, want autoreconnect = 0
    Last edited by ChronicLord; July 21st, 2014 at 10:55 PM. Reason: wrong client log info sorry

  5. #5
    Join Date
    May 2011
    Location
    Boston, MA
    Posts
    89
    Your client log indicates that you are trying to connect on 127.0.0.1:9987, but the server logs indicate that it is listening on 9988, try connecting to that port instead.

  6. #6
    Join Date
    July 2014
    Posts
    4
    Quote Originally Posted by Col_Crunch View Post
    Your client log indicates that you are trying to connect on 127.0.0.1:9987, but the server logs indicate that it is listening on 9988, try connecting to that port instead.
    so does that mean that i would have to open up the 9988 port to let other people get on my server (btw that worked thanks for local but i cant connect to my external ip.. im assuming that will fix it though thank you very very much for your help!)

  7. #7
    Join Date
    May 2011
    Location
    Boston, MA
    Posts
    89
    Yes, the port that the server is listening needs to be open for people to connect to it from outside your network.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: November 1st, 2015, 11:06 AM
  2. Replies: 1
    Last Post: September 20th, 2015, 11:09 AM
  3. Replies: 0
    Last Post: August 6th, 2015, 01:16 AM
  4. Replies: 0
    Last Post: January 3rd, 2015, 07:41 PM
  5. Replies: 12
    Last Post: September 1st, 2014, 05:20 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •