Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    August 2014
    Posts
    2

    Angry General high CPU usage compared to other programs

    Hello! I'm usually talking with 4 people on a Teamspeak server which is hosted by one of these by himself. My CPU isn't a high end CPU (but not bad too), that's why I dislike unnecessary CPU usage, especially while gaming this is important. I have noticed that the Teamspeak 3 client usually uses 4 - 12% of the CPU with 4 cores, and this has bothered me a lot. I have told my administrator friend if something changes if he removes the banner or disables encryption, but a restart hasn't really changed this. I have googled a lot regarding CPU usage of the Teamspeak client, but haven't found anything useful. Only some old threads from 2010 or 2011.

    A few days ago my friend has made the switch to Mumble, and the difference is really huge. The CPU usage is mostly between 1 - 6%, and even lower when the client is minimized. And it's even more lower when nobody is talking. This isn't the case with Teamspeak. What's going on? I don't believe that I'm the only one affected by this because my friend has seen the same, so I would like to kindly ask you: Can you please improve (>lower<) the CPU usage?

    I'm not able to understand why the voice quality is very near to same with both programs, but Teamspeak requires a lot more CPU. I would like to keep Teamspeak because of things like file browser or volume setting per user or the Soundboard plugin, but I won't be able to persuade my friend again if this will not change, because he shares my opinion.

    Thanks for reading!

    Edit: My system:

    Windows 7 64 Bit
    AMD Phenom II X4 955
    Last edited by Testbenutzer; August 2nd, 2014 at 02:23 AM. Reason: Added small system info

  2. #2
    Join Date
    December 2009
    Location
    Germany
    Posts
    2,360
    I have a similar system to yours: Windows 7 64 Bit and an AMD Phenom II X4 965.
    Just connected to a TS3 server without other people on it is around 1-3 % CPU load, while speaking 2-4% (Speex codec, without encryption), while changing channels up to 6% for a short time.

    Maybe my values are different, if I'm on a server with more people on it. If I don't forget it, I do a retest someday on a bigger server.

  3. #3
    Join Date
    August 2014
    Posts
    2
    Thanks for your reply! I need to say, I have set a max of 70% for "maximum processor state" (in German "maximaler Leistungszustand") in energy options to avoid too much heat, so my values are a little higher. I will talk again somewhere in the future with my administrator friend to test much more settings, but I guess it's sadly not going to be as systemfriendly as Mumble. Hopefully it will change in the future Teamspeak versions, thanks a lot in advance!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. High Cpu Usage
    By DardaNNN in forum Windows
    Replies: 37
    Last Post: December 30th, 2013, 09:26 PM
  2. [ts3] high cpu usage
    By taylor.flavio in forum Windows
    Replies: 2
    Last Post: December 13th, 2013, 03:55 PM
  3. TS3 3.0.7.2 high CPU usage
    By joshua2504 in forum Suggestions and Feedback
    Replies: 3
    Last Post: June 3rd, 2013, 10:26 AM
  4. Beta15 "trippled" Memory usage compared to beta12 ?!?
    By Sibul in forum Linux / FreeBSD
    Replies: 3
    Last Post: January 19th, 2010, 02:37 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •