Forum

Results 1 to 5 of 5
  1. #1
    Join Date
    August 2014
    Posts
    3

    MySQL error whan I launch the server

    Hello guys!
    I downloaded a teamspeak server on my Linux Virtual Private Server (VPS), but when I launch it, I got a MySQL error.
    Here is it:
    Assertion "error == ERROR_ok" failed at server/serverlib/database/db_database.cpp:113;

    So, nobody can join my server..

    I launch the server with:

    Code:
    [email protected]*username*:~# su ts3
    $ /etc/init.d/teamspeak start
    ts3server.pid found, but no server running. Possibly your previously started server crashed
    Please view the logfile for details.
    Starting the TeamSpeak 3 server
    TeamSpeak 3 server started, for details please view the log file
    There is one week, it worked..

    The logs files are empty.
    I've a logs file for any server launch, but there are all empty.

    Please, help me !

    Have a nice day.
    Sincerely.


    Damien.

    Sorry for my bad english, i'm French !

  2. #2
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,335
    Can't believe all logs are empty. Even the one with the 0 at the end? How do you know it was MySQL error?

    Did you update TS3 to 3.0.11 and did not read the changelog? There is no MySQL support in 3.0.11. It got replaced by MariaDB.
    Why are you even using MySQL? It is not advisable to use MySQL for small servers (e.g. those people run on VPS). It might not even be advisable for big ones.

  3. #3
    Join Date
    August 2014
    Posts
    3
    The error I got make me think it's MySQL error..

    "server/serverlib/database/db_database.cpp:113;"

    I use MySQL only for apache. It don't be linked with Teamspeak server

    I don't know what version of server I use, but I use 3.0.16 client version.

    My logs has been create, but there are all empty.
    Screenshot: https://www.dropbox.com/s/gu4fq7dwf8...53.51.png?dl=0

  4. #4
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,335
    Go to the folder and run TeamSpeak directly from the folder and without the start script so the log if printed to the screen.

  5. #5
    Join Date
    August 2014
    Posts
    3
    Idem :l

    Thanks for replies

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] TS3 Launch Error(s)
    By Gedalya in forum Server Support
    Replies: 4
    Last Post: April 28th, 2014, 08:47 PM
  2. Win7 Launch error
    By CnZippo in forum Windows
    Replies: 1
    Last Post: February 3rd, 2014, 09:53 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •