Forum

Results 1 to 7 of 7
  1. #1
    Join Date
    July 2009
    Posts
    38

    Error in parsing domains on white/blacklist?

    2014-08-26 11:25:00.393721|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.11 (2014-08-22 08:00:33)
    2014-08-26 11:25:00.393916|INFO |ServerLibPriv | | SystemInformation: Linux 3.2.0-4-amd64 #1 SMP Debian 3.2.60-1+deb7u3 x86_64 Binary: 64bit
    2014-08-26 11:25:00.396283|INFO |DatabaseQuery | | dbPlugin name: MySQL plugin, (c)TeamSpeak Systems GmbH
    2014-08-26 11:25:00.396378|INFO |DatabaseQuery | | dbPlugin version: 1
    2014-08-26 11:25:00.521921|INFO |Accounting | | Licensing Information
    2014-08-26 11:25:00.522006|INFO |Accounting | | licensed to : DeltaNet Production
    2014-08-26 11:25:00.522050|INFO |Accounting | | type : Hoster
    2014-08-26 11:25:00.522106|INFO |Accounting | | starting date : Tue Aug 19 00:00:00 2014
    2014-08-26 11:25:00.522148|INFO |Accounting | | ending date : Sun Aug 30 00:00:00 2015
    2014-08-26 11:25:00.522188|INFO |Accounting | | max virtualservers: 2500
    2014-08-26 11:25:00.522228|INFO |Accounting | | max slots : 25000
    2014-08-26 11:25:01.310456|INFO | | | Puzzle precompute time: 750
    2014-08-26 11:25:01.311436|INFO |FileManager | | listening on 0.0.0.0:12500
    2014-08-26 11:25:02.129601|ERROR |CIDRManager | | Error in query_ip_whitelist invalid rule ts3.deltanet-production.de
    2014-08-26 11:25:02.129655|ERROR |CIDRManager | | Error in query_ip_whitelist invalid rule www.deltanet-production.de
    2014-08-26 11:25:02.129700|ERROR |CIDRManager | | Error in query_ip_whitelist invalid rule deltanet-production.de
    2014-08-26 11:25:02.129743|ERROR |CIDRManager | | Error in query_ip_whitelist invalid rule ts3.wow-deal.de
    2014-08-26 11:25:02.129787|CRITICAL|Query | | Error during loading of white/blacklist. For security reasons, this server will be shut down

    As first test of running the new beta version of ts3 without useing mariaDB or his .so file this is shown and I think this occours also under mariaDB and I think now, that there is an error in the main binary because before the update it doesn't matter if there was an IP or an Domain listed on it but I didn't read anything about such changes for the white/blacklist.

    I removed them to start my ts3 again but I hope that this will be fixed as soon as possible.

    EDIT: I'll not use mariaDB because there are to many other scripts/shops/etc. useing MySql and so I've choosen to delete the SO-File from mariaDB and continue to use the MySQL-SO-File and I also don't setup directly mariaDB Server/Client because TS3 will be the first one who support this.

    I suggest to support only mysql and sqlite an not more, but if so, then you should support all of them (mysql, sqlite, maria, etc.)

  2. #2
    Join Date
    December 2004
    Location
    RF
    Posts
    3,002
    IP access lists never had official support for domain names.

    MySQL, MariaDB and Percona clients use compatible protocol.

  3. #3
    Join Date
    September 2012
    Posts
    6,076
    Previous server versions never supported DNS names in white / blacklist. There just was no error about it and it was semi-ignored, which however caused other issues. As such there is now an error being thrown and the server is shutting down instead of allowing such malformed input, which could result in problems and security issues.

    This will not be changed.


    As for MySQL you can continue to use your existing MySQL Server and database, you just need to update the database manually (not related to the MariaDB change but a general issue with the database structure / setup in previous versions). For more details see doc/update_mysql_to_mariadb.txt.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  4. #4
    Join Date
    July 2009
    Posts
    38
    Hello Chris,

    even if I do this manually update from updat_mysql_to_mariadb.txt over 90% of all channel are gone away an in addition the specialcahrs in the servername are also gone so at least I only added the new table (as utf8_general_ci) to say teamspeak that my mysql server/client has the requiered version running and I don't use the new mariadb plugin, I use the mysql plugin instand because utf8mb4 string is not needed because all works fine for me with normal utf8_general_ci and in addition mysql is the best databaseserver ever such as mariadb because no other company is using this db ... they all using mysql, sqlite 3, oracle db and so on.

    You should think about a backward compatibality without utf8mb4 because this update will disrupt 90% of the mysql database.

  5. #5
    Join Date
    December 2004
    Location
    RF
    Posts
    3,002
    Quote Originally Posted by Chaos234 View Post
    Hello Chris,

    even if I do this manually update from updat_mysql_to_mariadb.txt
    You, of course, know, that this conversion script have embedded bomb which nuke everything that is not latin1, right?

  6. #6
    Join Date
    September 2012
    Posts
    6,076
    Quote Originally Posted by Chaos234 View Post
    I use the mysql plugin instand because utf8mb4 string is not needed because all works fine for me with normal utf8_general_ci
    Not with 3.0.11 server... you won't use it.
    It's either use 3.0.11 and use utf8mb4 or you use 3.0.10.3 and the mysql plugin.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  7. #7
    Join Date
    July 2009
    Posts
    38
    Tell me what you want to tell me but my TS 3 is running 3.0.11 (22.08.2014 10:00:33) on Linux with the mysql plugin an utf8_general_ci tables - also there are nothing stored into latin1 - so I definitly WILL use it with the mysql plugin because I don't need utf8mb4 string because it kills 90% of all channel-/servernames specialy those with specialchars so mariadb and utf8mb4 string to bad for this to read it out correctly!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] Error during loading of white/blacklist.
    By Nico92 in forum Server Support
    Replies: 10
    Last Post: January 27th, 2017, 08:28 AM
  2. [bug?]Theme Parsing Error?
    By willy_sunny in forum Client Support
    Replies: 0
    Last Post: August 20th, 2012, 02:43 AM
  3. [bug?]Theme Parsing Error?
    By willy_sunny in forum Bug Reports [EN/DE]
    Replies: 0
    Last Post: August 20th, 2012, 02:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •