Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 7 of 7
  1. #1
    Join Date
    August 2014

    insufficient permission modify power with Server Admin group

    I'm trying to help out the owner of my teamspeak by setting up some permissions for him, all was going well until I tried to enable b_virtualserver_modify_hostmessage. I can't grant that on the server group (not the master admin) and I can't seem to add grant power to it either. Of course the group that I am using (Master Admin) has the ability to modify the group that I am trying to edit (75).

    I have gone through about 6 different posts on this issue and they either don't have results or the results that people are getting aren't fixing it for me. I did see that the grant power is 100 for the Master Admin on b_virtualserver_modify_hostmessage but I can't seem to change that either. I'm not entirely sure what to do and I won't be able to have this tag forever to mess around with it, I also don't want to break anything.

    I hope someone can give me a hand with this!

  2. #2
    Join Date
    June 2011
    What the hell is "Master Admin"? There is no such group.

  3. #3
    Join Date
    January 2010
    Secret Base in Arctic Region
    Maybe a custom group they created?
    Just a wild guess

    @Gauner: What value for "i_permission_modify_power" has your Master-Group?

  4. #4
    Join Date
    August 2014
    I was merely using "Master Admin" as just a name for Owner or something I suppose, I don't know what you would call it since it has been renamed on this server to something relevant to the community, it was about 3am when I posted this.

    The value is set at 75 as well as the Grant.

  5. #5
    Join Date
    January 2010
    Secret Base in Arctic Region
    So, you've searched and found no answer? There should be one.
    Else, did you or the "owner" looked into the documentation that comes with the server?
    (in case you dont host yourself -> )

    To perform an action, your "power" must be >= the "needed_power".
    In case of editing permissions:
    Quote Originally Posted by permissiondoc
    Adding, Removing and Editing Permissions
    All of the following questions need to be answered with “Yes” when adding, removing or editing a permission on any layer:
    1. Does the editing client have a Grant-Power for the concerened permission with a value that is not zero?
    2. Is the editing clients i_permission_modify_power greater or equal to the Grant-Power for the concerned permission of the editing client?
    3. When editing i_group_modify_power, is the new value smaller or equal to the i_group_modify_power of the editing client?

    4. When editing i_permission_modify_power, is the new value smaller or equal to the i_permission_modify_power of the editing client?
    5. When editing a i_needed_modify_power_* permission (also called Grant-Permission), is the new value smaller or equal to the editing clients
    Grant-Power of the permission in question?
    So, since your "Mastergroup" has only 75 modify power and the GRANT is 100 you cant set this permission you want.
    Also you cant change the GRANT value itself.
    You have to contact your hoster and ask if he can enable it.

  6. #6
    Join Date
    August 2014
    Another issue that I'm having, in the meantime, is that I'm trying to make two of the groups only accessible by the "mastergroup". I figured this would be easy enough, make the needed to add power higher than all the powers of the other groups, say keep it at 75 and make all the others 70 (for the server admins) and keep the rest at 60 (I think that's standard adding powers). But apparently that doesn't work, because I tried it out and the person wasn't able to assign any other the server admin groups even though the add power and needed add power were both 70.

  7. #7
    Join Date
    October 2015
    Czech Republic

    Permissions problem "Insufficient group modify power"

    Hello, I have a problem that when I want to set for a group "This group will be set as .." So it writes: Insufficient group modify power. Iam in a group of Server Admin (generated by server i used key to get to it). I do not understand it..

    Can you help me? I will be very happy
    Last edited by dante696; October 14th, 2015 at 10:32 AM. Reason: merged (no perm overview of those groups)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. insufficient permission modify power server admin
    By John_55 in forum Permission System
    Replies: 3
    Last Post: September 14th, 2015, 11:24 PM
  2. Insufficient Permission Modify Power - Despite Server Admin
    By Prime55 in forum Permission System
    Replies: 3
    Last Post: December 23rd, 2013, 04:12 PM
  3. [Resolved] Insufficient Permission Modify Power as Server Admin
    By Sebi94 in forum Permission System
    Replies: 23
    Last Post: March 2nd, 2012, 12:06 PM
  4. Server Admin - Yet 'insufficient permission modify power'
    By guitar112993 in forum Permission System
    Replies: 3
    Last Post: September 3rd, 2011, 10:40 PM
  5. insufficient permission modify power As Server Admin
    By Lt-Fighter in forum General Questions
    Replies: 2
    Last Post: August 6th, 2011, 09:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts