Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    June 2011
    Posts
    3

    Confusing error message when license/BL server unavailable

    From time to time I have unexplained connection issues to some teamspeak.com server.
    Currently, for example, I can neither perform updates, nor does the blacklist server respond.

    One of the servers I commonly use, has an NPL license. Whenever I try to connect to this server under these conditions, I get told, that the server has been blacklisted. Then, I proceed to harass the admin, only to be told that the server works fine.

    It's already quite unfortunate that I am unable to connect to the server under these circumstances, but more aggravating that the error message is simply false - the server in question is not blacklisted at all. It simply isn't whitelisted (to my client) with a license allowing its configuration.

    Fixing that error message would make trouble shooting the connection issues easier.


    I'm still not sure why my client can not connect to either the update or blacklist server, so if anyone has any input what could be wrong (it worked yesterday evening, but must have broken over night), I'd be glad for that as well.

    Maybe it's just server maintenance? DNS issues (all attempts to resolve blacklist.teamspeak.com from different machines with different DNS sources had the same result - 176.9.148.78) I'm not sure if the server doesn't respond to pings because that's the way its firewall has been set up, or if it's an actual indicator of not accepting connections.

    I'm not sure who actually maintains those servers, but since it's under the teamspeak.com domain, I'll assume these are the correct forums (exepting the subforum) to get any information regarding what's going on.


    Addendum: so while krul.finf.uni-hannover.de appears as blacklisted (I assume it's using an NPL), other servers that should also require some kind of license verification (ts1.teamstarbattle.com, a very large clan server) are available. This makes the entire issue even more confusing. Also, I can connect to the "blacklisted" server using the Android client from within my network (same gateway, same DNS). This actually may point towards an actual client issue, rather than a network issue. Unless there's yet another verification approach for the mobile client.
    Is there a local cache of the blacklist, that I could try to reset, or something like that?
    Last edited by Rick'; August 31st, 2014 at 05:00 PM.

  2. #2
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,367
    Blacklist server is down for weeks now. However, that should not cause your client to refuse connecting... I'd say bug.

  3. #3
    Join Date
    June 2011
    Posts
    3
    Quote Originally Posted by numma_cway View Post
    Blacklist server is down for weeks now. However, that should not cause your client to refuse connecting... I'd say bug.
    01.09.2014 20:35:22 ClientUI Info Connect to server: krul.finf.uni-hannover.de
    01.09.2014 20:35:22 ClientUI Info Trying to resolve krul.finf.uni-hannover.de
    01.09.2014 20:35:22 TSDNS Info DNS resolve successful, "krul.finf.uni-hannover.de"=130.75.178.36
    01.09.2014 20:35:22 TSDNS Info SRV DNS resolve unsuccessful for "_ts3._udp.krul.finf.uni-hannover.de"
    01.09.2014 20:35:23 ClientUI Info Lookup finished: 130.75.178.36 9987 krul.finf.uni-hannover.de 0 0
    01.09.2014 20:35:23 ClientUI Info Resolve successful: 130.75.178.36:9987
    01.09.2014 20:35:23 ClientUI Info Server blacklisted: krul.finf.uni-hannover.de 130.75.178.36
    01.09.2014 20:35:28 ClientUI Info Blacklist check timeout

    Looks buggy indeed, since the blacklist check apparently returns something even before the timeout is reached.
    I still don't know where that blacklist info might come from, but it must originate from somewhere local.
    Anyone has any ideas?
    Last edited by Chris; September 2nd, 2014 at 08:54 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [NL] confusing translation error
    By Sheriffnl in forum Client Support
    Replies: 3
    Last Post: May 13th, 2014, 09:11 AM
  2. npl license - very confusing
    By renamed in forum General Questions
    Replies: 4
    Last Post: January 11th, 2013, 10:32 AM
  3. Replies: 6
    Last Post: December 11th, 2012, 02:20 AM
  4. Server Query Group perms unavailable
    By Heliguy in forum Permission System
    Replies: 0
    Last Post: November 24th, 2010, 11:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •