Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    March 2012

    Right Click does not work

    Just within the last day or two here, I haven't been able to right click on anything in TeamSpeak. I was running version 3.0.14 when I first noticed the problem, and promptly updated to 3.0.16. No dice. I also tried a full re-install of TeamSpeak.

    My right-click works everywhere else (Chrome, desktop, other various programs) and I can't think of anything new that I've installed recently.

    Left click does work correctly, and middle mouse click works correctly. I don't have any bindings set to my right mouse button either. If I use the Menu key on my keyboard I can access the context menu, so the context menu isn't broken, TS is just not recognizing my mouse click for some reason.

    Any ideas on how to fix the issue?

    Windows 7 x64
    Teamspeak 3.0.16

    Anything else just ask, thank you for any help.
    Last edited by vv211; September 2nd, 2014 at 10:57 PM.

  2. #2
    Join Date
    November 2014
    Having excactly this problem, no idea what to do

    Had a background process running called handyande, i quit that and right click worked again
    Last edited by dante696; November 17th, 2014 at 10:38 AM.

  3. #3
    Join Date
    March 2012
    This problem has since gone away, if I remember correctly a computer reboot solved it. I didn't have Andy the Android Emulator (which is the source an exe called handyandy.exe) installed at the time I was having these issues, but i did install it later and didn't notice any issues

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I can't click on anything
    By Yoku651 in forum Client Support
    Replies: 1
    Last Post: December 13th, 2013, 11:49 PM
  2. Left Click Does not work
    By cam22222 in forum Windows
    Replies: 2
    Last Post: November 10th, 2013, 06:38 AM
  3. [Problem] One Click Install (package_inst.exe On Vista does not work
    By sgtrwe in forum Suggestions and Feedback
    Replies: 10
    Last Post: June 14th, 2011, 03:28 PM
  4. Can Not Click on ANYTHING
    By husqi in forum Client Support
    Replies: 0
    Last Post: June 30th, 2010, 05:36 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts