Results 1 to 4 of 4
  1. #1
    Join Date
    September 2014

    "Could not open capture device" Error - Only when connected

    Hi TS Community,

    thank you for your interest in this inquiry.

    First, The Specs.
    Mobo: Asus Crosshair Formula V
    CPU: AMD FX 8320
    GFX: MSI R280X
    RAM: 16GB 1866GhZ Corsair Vengeance
    Disk: PCI Revodrive 128GB used for OS and programs, Seagate 2GB SSHD used for storage and games.
    OS: Windows 8.1 x64

    Soundcard: TC Electronic Konnekt 24D, installed via TI PCI Firewire card
    Mic: AKG C214 connected to the the 24D through XLR to Jack cable (Preamped by a GA Project Pre-73 MK II)

    Second, The problem

    - When I start TeamSpeak 3 and clicks Settings --> Options --> Capture
    TS3 recognizes my Konnekt 24D. It also lets me test if the input works. It does.

    - In ---> Playback it also works.


    - When I connect to a server, the mic goes dead while the Audio (Speach from others) is still working.
    - As you can see in the picture below, TS3 shows the error "Error, could not open Capture Device"
    - It also shows me an inactive micsymbol in front of my nick

    Third, Tried solutions
    - Create and set new profile in Self menu
    - Setting Capture Mode as Direct sound
    - Setting Capture Mode as Automatic
    - Upgrading TS3 to newest version
    - Ensured Konnekt 24D has the latest driver (August 2014)
    - Searched the internet for various answers. Lots of threads - No solutions.

    Fourth, Created a user on this forum and hope for a solutions.

    Name:  TS3 - Error.jpg
Views: 19214
Size:  496.8 KB

    Thank you for reading, Ferns

  2. #2
    Join Date
    September 2014
    Still struggling with this issue - Can it really be that there is no solution?

  3. #3
    Join Date
    September 2014
    Did a quick search on the forums but i guess you already tried this:

    I just unplugged everything and re-plugged one-by-one and windows solved the problem alone lol

    Now, evertything works fine

    Apparently there was some conflicts between the USB devices and the Jack plugs.

  4. #4
    Join Date
    September 2014
    Hi Stumble,

    Thank you for answering. Unfortunately the procedure doesn't work.
    There is no difference when reconnecting the firewire plug or use another port.
    Nor is there any difference when moving the internal firewire card to another slot.

    It was a good simple and unexplainable solution though - And often these are the, mysterious, ways for Windows.

    I'll keep trying by myself - and hope that another good reply will appear here

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: April 14th, 2014, 01:46 PM
  2. Replies: 7
    Last Post: November 10th, 2013, 11:25 AM
  3. "Error, could not open Capture Device"
    By Totto in forum Windows
    Replies: 5
    Last Post: August 26th, 2011, 03:17 PM
  4. Replies: 1
    Last Post: January 27th, 2011, 02:54 PM
  5. Replies: 2
    Last Post: October 25th, 2010, 02:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts