Forum

Page 3 of 6 FirstFirst 12345 ... LastLast
Results 31 to 45 of 84
  1. #31
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,351
    Add a link to Autostart in start menu. Works the same as on XP.

  2. #32
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,351
    You need your ts3server.sqlite file as well.

  3. #33
    Join Date
    September 2010
    Location
    uk
    Posts
    64
    Thank's, i have created a scheduled task for it, but if that don't work, i'll do the start menu

    Ok i downloaded, extracted the 64bit server ,started it up, shut it down (didn't connect as it uses the default port and log in credentials it creates first time its ran) and my TS client ain't set up to connect to it so times out without connecting

    here is the output from the servers log

    2016-10-04 19:11:02.394497|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.0.13.4 (2016-08-29 12:39:04)
    2016-10-04 19:11:02.394497|INFO |ServerLibPriv | |SystemInformation: Windows 7 SP1 (7601) x64 (AMD or Intel) Binary: 64bit
    2016-10-04 19:11:02.394497|INFO |ServerLibPriv | |Using hardware aes
    2016-10-04 19:11:02.394497|CRITICAL|DatabaseQuery | |unable to load database plugin library "ts3db_sqlite3.dll", halting!
    I copied all the files apart from the ts 3 server exe file from the 32bit folder to the 64 folder, and when i start it it closes after only a few seconds with the above error in the log file Apart from the obvious TS3 Server.exe file are there any files in the ts3 32bit folder that shouldn't be copied into the 64bit server folder as doing this causes the 64bit server.exe unable to run and give the above error in the server log

    Name:  Capture.JPG
Views: 396
Size:  70.0 KB the files i'm copying from 32 bit, (server is running so there are a few more files visible )
    Last edited by tommy45; October 4th, 2016 at 08:40 PM.

  4. #34
    Join Date
    September 2016
    Posts
    2
    Running teamspeak on Windows 7 without any extra stuff and would like to move it to Linux , try it now dear

  5. #35
    Join Date
    June 2008
    Posts
    18,151
    @Tommy45

    Install a fresh server, then only copy all mentioned files from post #2.
    Do not do/copy anything else.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  6. #36
    Join Date
    September 2010
    Location
    uk
    Posts
    64
    Quote Originally Posted by dante696 View Post
    @Tommy45

    Install a fresh server, then only copy all mentioned files from post #2.
    Do not do/copy anything else.
    I did this first and it failed was listening on default voice port and using it's own login credential's for some reason, I had changed both and also made other changes in the permission system

  7. #37
    Join Date
    September 2010
    Location
    uk
    Posts
    64
    Quote Originally Posted by tommy45 View Post
    I did this first and it failed was listening on default voice port and using it's own login credential's for some reason, I had changed both and also made other changes in the permission system
    UPDATE:

    Repeated the steps and it now works as intended, So thanks to those that replied for their input, As to what or why it didn't work when i first followed the guide in #2???? maybe something didn't copy or i missed a file??

  8. #38
    Join Date
    June 2008
    Posts
    18,151
    I think you inserted a 32bit DLL from your old server into the 64bit server.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  9. #39
    Join Date
    November 2015
    Posts
    106

    Backing up TS3

    I am running linux version 3.0.16 and I'd like to know which files I should be backing up? And if I don't have ftp is there another way to get the files?
    Last edited by dante696; June 12th, 2017 at 10:00 AM. Reason: merged

  10. #40
    Join Date
    September 2012
    Posts
    6,079
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  11. #41
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,351
    There is no 3.0.16 server.

  12. #42
    Join Date
    June 2008
    Posts
    18,151
    Quote Originally Posted by numma_cway View Post
    There is no 3.0.16 server.
    I think he knows it and just made a typo.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  13. #43
    Join Date
    July 2017
    Posts
    3
    I have a bit of a problem.

    I have previously installed/migrated from centos 5 to 6.5.
    I have updated the current server to the latest version 13.7 and made a backup of it. I copied that over to the new server with centos 7.

    Created the same user, same directory structure, firewall rules and so on. Unpacked the backup, changed the server.ini file with the new IP address. We use only one virtual server. No fancy configs.

    When I connect, a new virtual server is created and I got presented with a new admin key.

    I looked with sqlite3 in the database, but cannot find anything weird. Anyone any suggestions?

    PS. I tried also to create new server, copy the files from the first post. Same situation.

    Cheers

  14. #44
    Join Date
    February 2012
    Location
    Germany
    Posts
    575
    You probably messed with the file system permissions, so the server isn't able to read from or write to its database. Or you extracted the database to a location where the server isn't looking for it.

    The first step to see what's happening is to look at the server log files and see what the server is logging.

  15. #45
    Join Date
    July 2017
    Posts
    3
    This is what the logs say, and virtualserver_2 is created instead of re-using the virtualserver_1.

    # cat ts3server_2017-07-17*
    2017-07-17 18:25:02.224869|INFO |ServerLibPriv | |TeamSpeak 3 Server 3.0.13.7 (2017-06-27 07:11:20)
    2017-07-17 18:25:02.225106|INFO |ServerLibPriv | |SystemInformation: Linux 3.10.0-*************
    2017-07-17 18:25:02.225170|INFO |ServerLibPriv | |Using hardware aes
    2017-07-17 18:25:02.226242|INFO |DatabaseQuery | |dbPlugin name: SQLite3 plugin, Version 3, (c)Tea
    2017-07-17 18:25:02.226322|INFO |DatabaseQuery | |dbPlugin version: 3.11.1
    2017-07-17 18:25:02.226774|INFO |DatabaseQuery | |checking database integrity (may take a while)
    2017-07-17 18:25:02.276242|WARNING |Accounting | |Unable to find valid license key, falling back to l
    2017-07-17 18:25:05.219453|INFO | | |Puzzle precompute time: 2403
    2017-07-17 18:25:05.219819|INFO |FileManager | |listening on <host ip address>:30033
    2017-07-17 18:25:05.238222|INFO |CIDRManager | |updated query_ip_blacklist ips: 108.61.78.147/32, 1
    2017-07-17 18:25:05.238793|INFO |CIDRManager | |updated query_ip_whitelist ips: 127.0.0.1/32, 81.20 147/32, 108.61.78.148/32, 108.61.78.149/32, 108.61.78.150/32, 85.25.120.233/32, 94.23.235.222/32, 149.210.
    2017-07-17 18:25:05.238960|INFO |Query | |listening on <host ip address>:10011
    2017-07-17 18:25:05.235701|INFO |VirtualServer |2 |listening on <host ip address>:9987
    2017-07-17 18:25:05.236587|WARNING |VirtualServer |2 |---------------------------------------------------
    2017-07-17 18:25:05.236620|WARNING |VirtualServer |2 |ServerAdmin privilege key created, please use the l
    2017-07-17 18:25:05.236640|WARNING |VirtualServer |2 |token=<not readable for you>
    2017-07-17 18:25:05.236657|WARNING |VirtualServer |2 |---------------------------------------------------

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hard drive failure resulting in corrupt DB file
    By OhYou_ in forum Server Support
    Replies: 1
    Last Post: April 13th, 2017, 11:25 AM
  2. How to get ts unique id of recoverd hard drive
    By nick2031 in forum General Questions
    Replies: 2
    Last Post: July 20th, 2013, 04:24 AM
  3. Move Teamspeak-Server to another machine?
    By c0bra in forum Linux / FreeBSD
    Replies: 3
    Last Post: June 21st, 2012, 06:26 AM
  4. Hard drive crashed - Accessing TS3 servers again
    By subrand0m in forum Client Support
    Replies: 2
    Last Post: January 23rd, 2011, 06:01 AM
  5. Help:- How can I backup all my hard work Please ?
    By MagicBytes in forum Windows
    Replies: 4
    Last Post: February 16th, 2010, 12:24 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •