Forum

Page 3 of 3 FirstFirst 123
Results 31 to 38 of 38
  1. #31
    Join Date
    June 2008
    Posts
    18,151
    Exactly. The channeledit command was never supposed to work when you set an icon.
    The icon must be set with the channeladdperm command.

    The icon on channel was always a permission and even the clients sets a permission when you set the icon in the channel edit/create dialog.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  2. #32
    Join Date
    February 2014
    Posts
    219
    Quote Originally Posted by numma_cway View Post
    Using channeledit to set icons never worked properly, so you shouldn't have done it before. That's why this thread was created. And TeamSpeak now removed a feature that never worked. So I don't see the issue.

    dante said that 3.9.0 accepts signed and unsigned integers.
    Quote Originally Posted by dante696 View Post
    Exactly. The channeledit command was never supposed to work when you set an icon.
    The icon must be set with the channeladdperm command.

    The icon on channel was always a permission and even the clients sets a permission when you set the icon in the channel edit/create dialog.

    Yeah, neither of you are really answering in a helpful fucking way. Nor did I ever say their change was an issue, just that I didn't understand how it will work now.

    I asked a question, STATING THAT I DO NOT UNDERSTAND THE NEW CHANGE. I'm trying to learn and understand how it will work, but the sarcastic and shit replies don't really help me learn from the change.

    CAN YOU SET channeladdperm i_icon_id ON A CHANNEL THAT ALREADY HAS i_icon_id!?!?!? OR DO YOU HAVE TO channeldelperm.


    READ ScP'S REPLY TO ME DANTE:
    https://forum.teamspeak.com/threads/...393#post470393


  3. #33
    Join Date
    June 2008
    Posts
    18,151
    But i answered that already when you asked the same question again in post #25?
    Quote Originally Posted by dante696 View Post
    There is no fix to set an icon with that command when a icon is set already.
    That worked before and still works.
    You don't have to delete the icon before you set a new one (SCP answered in post #20).
    Why didn't you try it out when our replies do not help you?

    Nobody's posts except the post above mine was sarcastic?

  4. #34
    Join Date
    February 2014
    Posts
    219
    Quote Originally Posted by dante696 View Post
    But i answered that already when you asked the same question again in post #25?


    You don't have to delete the icon before you set a new one (SCP answered in post #20).
    Why didn't you try it out when our replies do not help you?

    Nobody's posts except the post above mine was sarcastic?

    I have tried it and I just get the error: error id=1540 msg=convert\serror and ScP said this will be fixed.

    I asked if this was fixed and haven't been told.

    I simply want a Yes or No answer.

    Your reply wasn't sarcastic but nor was it helpful, I just wanted a clear cut answer. Clearly this forum fucking hates people trying to understand something.

  5. #35
    Join Date
    June 2008
    Posts
    18,151
    An again i answered this twice with.

    Quote Originally Posted by dante696 View Post
    ....
    New is that you can use 2524640421 (Unsigned Int) or -1770326875 (Signed Int) to set an icon via permission commands.
    Quote Originally Posted by dante696 View Post
    .....
    Yes this was changed (not fixed) for server 3.9.0 Beta1
    3.9.0 Beta 1 is available and it was changed (not fixed).


    Yeah it's the forum....
    Last edited by dante696; June 17th, 2019 at 09:48 AM. Reason: replaced there with available
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  6. #36
    Join Date
    February 2014
    Posts
    219
    Quote Originally Posted by dante696 View Post
    Yeah it's the forum....
    Yeah, it's totally not you...

  7. #37
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,350
    Quote Originally Posted by Patrick1164 View Post
    CAN YOU SET channeladdperm i_icon_id ON A CHANNEL THAT ALREADY HAS i_icon_id!?!?!? OR DO YOU HAVE TO channeldelperm.
    Changing a permission using "...permadd" does not require your to delete it before.

  8. #38
    Join Date
    February 2014
    Posts
    219
    Quote Originally Posted by numma_cway View Post
    Changing a permission using "...permadd" does not require your to delete it before.
    That's all I wanted to know.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] setChannelVariable CHANNEL_ICON_ID impossible to change ID
    By MiguelSnake in forum Client Plugins / Lua Scripts
    Replies: 4
    Last Post: November 29th, 2016, 12:18 PM
  2. Is there an possibility to make channeledit silent?
    By globalcookie in forum Server Support
    Replies: 1
    Last Post: May 17th, 2016, 11:28 AM
  3. channel_icon_id problem (out of range)
    By filimonic in forum Linux / FreeBSD
    Replies: 1
    Last Post: June 19th, 2012, 11:07 AM
  4. [Resolved] ServerQuery channel_icon_id problem
    By devour in forum Linux / FreeBSD
    Replies: 1
    Last Post: January 26th, 2012, 09:02 AM
  5. Query channeledit and codec encrypted
    By florian_fr40 in forum Bug Reports [EN/DE]
    Replies: 5
    Last Post: October 13th, 2010, 11:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •