Forum

Page 1 of 3 123 LastLast
Results 1 to 15 of 38
  1. #1
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,350

    channeledit channel_icon_id=x not saved

    The title says it:
    If I run channeledit channel_icon_id=x, this is not saved, and therefore isn't restored after restarting the server. One must use channeladdperm i_icon_id=x. However, the query documentation tells me to use channeledit channel_icon_id=x.

  2. #2
    Join Date
    June 2008
    Posts
    18,151
    It's reproducable and I will create a bugticket for this.

    Thank you for reporting this.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    November 2011
    Location
    Belarus
    Posts
    141

    [On Todo][Duplicate] Server loses i_icon_id permission value on restart

    Server: Ubuntu 16.04.2 LTS x64, TSServer version is 3.0.13.6 x64
    Using MariaDB plugin and MariaDB server.
    Click image for larger version. 

Name:	Снимок.PNG 
Views:	102 
Size:	4.1 KB 
ID:	14993
    Client versions are 3.1.0.1 and 3.1.1 latest beta. Tested on both
    YaTQA versions are 1.3.3.7 old and latest 3.7.

    How to reproduce:
    1. Open your teamspeak client
    2. Change the icon of any channel
    3. Restart your server
    4. Everything is fine.

    1. Open YaTQA (any version, i think)
    2. Select multiple channels (more - better)
    3. Edit the icon to these channels, pick the existing one
    4. Now finally change the icons
    5. Everything is fine...
    6. Reboot your server...
    7. Boom. i_icon_id values on these channels are 0, icons are still there existing on the server.

    Thanks to numma_cway!
    This bug report is duplicate of this report
    Last edited by dante696; February 20th, 2017 at 09:42 AM. Reason: merged

  4. #4
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,350

  5. #5
    Join Date
    November 2011
    Location
    Belarus
    Posts
    141
    Oh my... This is old. No idea why that bug is still not fixed and forgotten...
    I only use YaTQA to manage icons on channels because of the reasons... You know... Built-in ''''icon management system''''...

  6. #6
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,350
    This was fixed in YaTQA 3.0-gamma back then. It therefore shouldn't be bugged in 3.7 either.

  7. #7
    Join Date
    November 2011
    Location
    Belarus
    Posts
    141
    Well... It is bugged \_(ツ)_/

    Also since 3-4 versions this window looks buggy... And i can't move that at all (Windows 10 x64 AU)
    Click image for larger version. 

Name:	Снимок.PNG 
Views:	291 
Size:	28.0 KB 
ID:	14994

  8. #8
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,350
    Then I don't get it. I can change the icon with YaTQA and restart the server just fine.
    Do you mean with
    3. Edit the icon to these channels, pick the existing one
    4. Now finally change the icons
    ?

    OT: The window thingy was fixed with a workaround in current dev build.
    /Edit: Seems to be a localization problem. Bug only existed in English version. Need to fix that and remove the workaround.

  9. #9
    Join Date
    November 2011
    Location
    Belarus
    Posts
    141
    I mean, you already have the needed icon on the server - uploaded and ready to set
    Then you change the icon using YaTQA, reboot the server, boom.
    Do you tried to use that on >10 channels like i did?
    Click image for larger version. 

Name:	Снимок.PNG 
Views:	92 
Size:	46.1 KB 
ID:	14995

  10. #10
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,350
    Works for me. However, I use SQLite for better performance, so that might be the reason.
    My original thread is therefore unrelated, it's about channeledit. This thread is about channeladdperm.

  11. #11
    Join Date
    November 2011
    Location
    Belarus
    Posts
    141
    Tried on 5 channels - icons are still there after reboot...

  12. #12
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,350
    I used 19 I think. x86 server running on Windows x64 with SQLite.

  13. #13
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,350
    I see that those threads got merged. They are different issues. My issue was related to simply a bug the TeamSpeak server, KIDINK's issue is related to the MariaDB connection causing desync.

  14. #14
    Join Date
    June 2008
    Posts
    18,151
    With next server version 3.9.0 we decided to deny when a user tries to set a channel icon with the channeledit command.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  15. #15
    Join Date
    September 2016
    Posts
    76
    Quote Originally Posted by dante696 View Post
    With next server version 3.9.0 we decided to deny when a user tries to set a channel icon with the channeledit command.
    That doesn't really solve the problem though does it? What a great fix, well done guys! (hope you can sense the sarcasm).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Resolved] setChannelVariable CHANNEL_ICON_ID impossible to change ID
    By MiguelSnake in forum Client Plugins / Lua Scripts
    Replies: 4
    Last Post: November 29th, 2016, 12:18 PM
  2. Is there an possibility to make channeledit silent?
    By globalcookie in forum Server Support
    Replies: 1
    Last Post: May 17th, 2016, 11:28 AM
  3. channel_icon_id problem (out of range)
    By filimonic in forum Linux / FreeBSD
    Replies: 1
    Last Post: June 19th, 2012, 11:07 AM
  4. [Resolved] ServerQuery channel_icon_id problem
    By devour in forum Linux / FreeBSD
    Replies: 1
    Last Post: January 26th, 2012, 09:02 AM
  5. Query channeledit and codec encrypted
    By florian_fr40 in forum Bug Reports [EN/DE]
    Replies: 5
    Last Post: October 13th, 2010, 11:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •