Forum

Results 1 to 4 of 4
  1. #1
    Join Date
    April 2008
    Location
    Australia
    Posts
    7

    Server shuts down and creates a new server on startup on same port

    Hi
    I am having problems keeping my server from crashing. Brand new server, old 'Non Profit' license.
    When I do a restart from in putty (SSH) it doesn't always restart straight away and a few times it has created a new server on the same port which then my client software connects to and asks for me to put a new token in for admin purposes.
    I am also monitoring it from YaTQA, it shows there are 2 servers on that port. See attachment 1
    Status command shows the server is running but I cant connect via TS3 Client.
    .........................
    [~/teamspeak3-server_linux-amd64]# ./ts3server_startscript.sh status
    Server is running
    .........................

    Click image for larger version. 

Name:	YaTQA.PNG 
Views:	69 
Size:	9.6 KB 
ID:	11391

    I then Delete the new server and restart the Original server and I can then connect.
    It then brings up a dialog box (See attachment 2) that tells me that it has a new identity and I can either agree to stay on the server or disagree.

    Click image for larger version. 

Name:	YaTQA2.PNG 
Views:	74 
Size:	17.5 KB 
ID:	11392

    Please help, let me know what else you need to know.
    TonyE

  2. #2
    Join Date
    September 2012
    Posts
    6,076
    You seem to have created one of the servers with a machine id, whereas the other doesn't have one. Now when you restart and don't specify the machine id then the server doesn't use any, doesn't find any server with one and thus creates a new server, which you're then connecting to.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

  3. #3
    Join Date
    April 2008
    Location
    Australia
    Posts
    7
    You are right! Thanks, but it doesn't explain why the server is shutting down all the time.
    I thought Machine ID was purely for naming reasons for my list of where the server was.

    Ok so now to the question of why its crashing.

    TonyE

  4. #4
    Join Date
    September 2012
    Posts
    6,076
    It's (most likely) not crashing, it is simply shutting down.
    Without logs and more info nobody can tell.
    When sending PMs please make sure to include a reference link to the thread in question in the body of your message.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Server to Startup on Windows Startup.
    By jujaimoh in forum Windows
    Replies: 3
    Last Post: September 26th, 2010, 06:06 PM
  2. [solved] Server closes voice port on startup
    By Beaverkilla in forum Server Support
    Replies: 5
    Last Post: June 21st, 2010, 08:39 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •