Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 7 of 7
  1. #1
    Join Date
    December 2009
    Location
    Vancouver, BC
    Posts
    89

    [SOLVED] Unable To Load Database Plugin Library "ts3db_mariadb.dll", halting!

    I just upgraded my TS3 server to the newest version, 3.0.11.1. I upgraded from 3.0.10.3. I backed up all my files, including my MySQL database prior to attempting the update.

    Server Environment:
    • Windows 8 Pro 64-bit
    • MySQL 5.6.17


    I followed the instructions in the "update_mysql_to_mariadb.txt" file. Used MySQL Workbench to process the SQL scripts. The scripts ran fine.

    Copied the updated files from the ZIP download and over-wrote the existing files.

    Modified the ini files per the instructions in the TXT file.

    When I try to start my server I get the following error:
    Code:
    2014-10-16 17:18:55.798953|INFO    |ServerLibPriv |   | TeamSpeak 3 Server 3.0.11.1 (2014-10-15 07:06:31)
    2014-10-16 17:18:55.798953|INFO    |ServerLibPriv |   | SystemInformation: Windows 8 (9200) x64 (AMD or Intel) Binary: 64bit
    2014-10-16 17:18:55.798953|INFO    |ServerLibPriv |   | Using hardware aes
    2014-10-16 17:18:55.798953|CRITICAL|DatabaseQuery |   | unable to load database plugin library "ts3db_mariadb.dll", halting!
    Here's my ts3server.ini:
    Code:
    machine_id=
    default_voice_port=9987
    voice_ip=64.46.9.98
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=64.46.9.98
    query_port=10011
    query_ip=64.46.9.98
    dbplugin=ts3db_mariadb
    dbpluginparameter=ts3db_mariadb.ini
    dbsqlpath=sql/
    dbsqlcreatepath=create_mariadb/
    logpath=logs
    logquerycommands=1
    Here's my ts3db_mariadb.ini:
    Code:
    [config]
    host=localhost
    port=3306
    username=ts3
    password=****************
    database=teamspeak3
    socket=
    Any help would be appreciated.
    Last edited by Arterio; October 17th, 2014 at 03:34 AM.

  2. #2
    Join Date
    December 2004
    Location
    RF
    Posts
    3,008
    1. Absolute paths in config files.
    2. Use search. this has been discussed to death and back already.

  3. #3
    Join Date
    December 2009
    Location
    Vancouver, BC
    Posts
    89
    Quote Originally Posted by ANR Daemon View Post
    1. Absolute paths in config files.
    2. Use search. this has been discussed to death and back already.
    I did use search, even read through the whole pre-release thread, and found nothing for "ts3db_mariadb" or my problem, other than one other post which mentioned nothing about absolute paths. This is the only other thread I found. If you look in that thread, Dante even gives examples of how the configs should look for mariadb, which is exactly how my configs are set up. None of the documentation mentions anything about absolute paths either. Not sure how something only released 2 weeks ago could have been discussed to death and back already.

    Regardless... I tried absolute paths, still didn't work. Exact same error message.
    Last edited by Arterio; October 16th, 2014 at 08:40 PM.

  4. #4
    Join Date
    December 2004
    Location
    RF
    Posts
    3,008
    And the mentioned plugin is present in the expected location?

  5. #5
    Join Date
    December 2009
    Location
    Vancouver, BC
    Posts
    89
    Here's a screenshot of my server folder, and file contents. You can see the ts3db_mariadb.dll file in there.

    Name:  folder-contents.png
Views: 1709
Size:  72.7 KB

  6. #6
    Join Date
    December 2004
    Location
    RF
    Posts
    3,008
    You can safely delete ts3db_mysql.dll
    Then check in redist directory for protocol library, copy it to the server folder.

  7. #7
    Join Date
    December 2009
    Location
    Vancouver, BC
    Posts
    89
    Quote Originally Posted by ANR Daemon View Post
    You can safely delete ts3db_mysql.dll
    Then check in redist directory for protocol library, copy it to the server folder.
    Moving that other DLL into the main folder worked. Thank you.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: November 11th, 2013, 06:04 PM
  2. Replies: 15
    Last Post: June 20th, 2012, 01:51 PM
  3. [Resolved] unable to load database plugin library "libts3db_mysql.so", halting!
    By PoL4K in forum Linux / FreeBSD
    Replies: 10
    Last Post: March 15th, 2012, 07:29 PM
  4. Replies: 4
    Last Post: January 26th, 2012, 08:26 AM
  5. Replies: 1
    Last Post: November 22nd, 2010, 05:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •