Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 9 of 9
  1. #1
    Join Date
    October 2014
    Posts
    5

    Can't connect even to localhost

    Hi, I have been running a TS3 server on my main PC at home for a year now. Works fine, people from around the world can join and leave as they please. But this afternoon, my server suddenly stopped working. I checked all my settings and configurations to find the problem but I couldn't find anything.

    I have:
    • Checked Ports
    • Reinstalled both the TS3 Client and Server


    So in conclusion, I have tried everything I can think of and it all seems fine to me but my ports are apparently closed and I can't even connect using localhost or my IPV4. If anyone has any suggestions on how I could go about fixing this problem please post. This has eaten up my entire free afternoon and I am extremely annoyed. Also, if you need any additional information just ask.

  2. #2
    Join Date
    June 2008
    Posts
    18,513
    Logs logs logs logs

    No help without logs.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    October 2014
    Posts
    5
    What I see when connecting:
    <18:45:19> Trying to resolve hostname localhost
    <18:45:20> Trying to connect to server on localhost
    <18:45:25> Failed to connect to server

    If you are wanting to know what the server sees, I don't know where to find the logs for it. Unless you want the ones from when I first started the server.

  4. #4
    Join Date
    June 2008
    Posts
    18,513
    The server does not seem to be running for a reason, if you can not reach it over localhost.


    Yes for sure we want to see server logs. They are stored in the log folder.
    We want to see the last log, when you try to start the server.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #5
    Join Date
    October 2014
    Posts
    5
    This was the latest one in there:
    2014-10-20 06:24:46.621985|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.11.1 (2014-10-15 07:06:31)
    2014-10-20 06:24:46.622986|INFO |ServerLibPriv | | SystemInformation: Windows 8 (9200) x64 (AMD or Intel) Binary: 64bit
    2014-10-20 06:24:46.622986|INFO |ServerLibPriv | | Using hardware aes
    2014-10-20 06:24:46.623988|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2014-10-20 06:24:46.623988|INFO |DatabaseQuery | | dbPlugin version: 3.8.0.2
    2014-10-20 06:24:46.623988|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2014-10-20 06:24:46.751153|INFO |SQL | | db_CreateTables() tables created
    2014-10-20 06:24:48.831743|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2014-10-20 06:24:49.799957|INFO | | | Puzzle precompute time: 959
    2014-10-20 06:24:49.806964|INFO |FileManager | | listening on 0.0.0.0:30033
    2014-10-20 06:24:49.846010|INFO |VirtualSvrMgr | | executing monthly interval
    2014-10-20 06:24:49.847012|INFO |VirtualSvrMgr | | reset virtualserver traffic statistics
    2014-10-20 06:24:51.337088|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
    2014-10-20 06:24:51.337088|INFO |Query | | listening on 0.0.0.0:10011

  6. #6
    Join Date
    June 2008
    Posts
    18,513
    This log file looks ok.

    - There shut be a second log file with _1.log at the end
    This entry should be in it, to make sure ,that a virtual server was started.
    2014-10-20 08:30:24.395396|INFO |VirtualServer | 1| listening on 0.0.0.0:9987

    - You may try the ip 127.0.0.1 instead of localhost.

    - Maybe a firewall update did block the conenction? Try to deactivate it for testing.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  7. #7
    Join Date
    October 2014
    Posts
    5
    Yep, it was there.
    2014-10-20 06:24:51.234962|INFO |VirtualServer | 1| listening on 0.0.0.0:9987

    No, the IP address 127.0.0.1 did not work.
    <19:53:30> Trying to connect to server on 127.0.0.1
    <19:53:36> Failed to connect to server

    Turning off the firewall did not help.
    <19:55:30> Trying to resolve hostname localhost
    <19:55:31> Trying to connect to server on localhost
    <19:55:36> Failed to connect to server
    <19:56:33> Trying to connect to server on 127.0.0.1
    <19:56:38> Failed to connect to server

    Any more suggestions? I would really like to get my teamspeak server back up and running.

  8. #8
    Join Date
    October 2014
    Posts
    2
    Aside from using the client to connect to it, are you able to telnet to the server query interface? If you aren't familiar with telnet, especially using CMD, your life will be easier using Putty or TeraTerm to do so.

    In order to log in through the server query, you will need the serverquery username and serverquery password that was generated when you created in the server, and can be found in one of the first set of log files made when first starting the server. (Which I would suggest not sharing any username/password/token info on here, unless you want to outright give out admin rights to you TS server)

    I wouldn't go monkeying around too deep in serverquery yet, until you get familiar with it, just see if you can connect and then back out if you can. Once we confirm that, you can query the status of the virtual server you have running, among other things.

    If you can connect via server query, but not via client software, I'd maybe start looking in to server admin token issues used when connecting from the localhost using the client software. I'm just taking SWAGs here, but these are some things I stumbled on when learning how to use my first server.

    Also, just curious, are you or were you using any sort of license before it quit working (Non-Profit or paid)?

    And, did you by chance, update the server version when it quit working?

  9. #9
    Join Date
    October 2014
    Posts
    5
    I was not using a licence. Just a single server running off my home PC for myself and a group of friends/colleagues to talk to each other.

    After it stopped working I tried a few more times and after that I reinstalled the software. I am not 100% sure, but I think I was running the latest version of the TS3 server.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cannot connect to my server via localhost
    By DaLucky7 in forum Server Support
    Replies: 2
    Last Post: October 23rd, 2014, 05:16 PM
  2. can not connect to localhost or IP
    By danieltm13 in forum Server Support
    Replies: 9
    Last Post: March 22nd, 2014, 02:27 PM
  3. New, cannot connect to localhost
    By CrusaderOutland in forum Server Support
    Replies: 11
    Last Post: March 26th, 2013, 10:00 AM
  4. Can only connect through localHost
    By UndeadMyth in forum Server Support
    Replies: 5
    Last Post: June 14th, 2011, 12:34 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •