Forum

Results 1 to 5 of 5

Hybrid View

  1. #1
    Join Date
    November 2014
    Posts
    2

    Exclamation Issues setting up server on CentOS 7 VPS

    I have a centos 7 vps and was going to install TeamSpeak 3 Server on it.

    I installed it and have it running using ts3server_startscript.sh start

    I did not configure anything within teamspeak.
    i opened up some ports using the following:
    sudo firewall-cmd --zone=dmz --add-port=9987/udp --permanent
    sudo firewall-cmd --zone=dmz --add-port=30033/tcp --permanent
    sudo firewall-cmd --zone=dmz --add-port=10011/tcp --permanent


    Note: I have an application running on port 80 on the same machine. I don't know if that matters.

    On first try i got
    loginname="serveradmin", password="dummyPassword"
    and token=dummyToken

    I then open up my Teamspeak 3 client (windows)
    Connections -> Connect
    ServerAddress: The IP Address (I tried using port 30033 but the same result)
    Nickname: serveradmin (same as in loginname)
    Server Password: Tried empty or dummyPassword, or the password for the user that teamspeak is running on.
    I however get "Failed to connect to server"

    Am I missing anything?

    Thanks

  2. #2
    Join Date
    June 2011
    Location
    Baghdad, Iraq
    Posts
    367
    check/post server logs ? (in server directory /logs )

  3. #3
    Join Date
    November 2014
    Posts
    2
    2014-11-13 21:31:39.023418|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.10.3 (2014-01-01 16:28:39)
    2014-11-13 21:31:39.023564|INFO |ServerLibPriv | | SystemInformation: Linux 3.10.0-123.9.3.el7.x86_64 #1 SMP Thu Nov 6 15:06:03 UTC 2014 x86_64 Binary: 64bit
    2014-11-13 21:31:39.024668|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2014-11-13 21:31:39.024713|INFO |DatabaseQuery | | dbPlugin version: 3.7.3
    2014-11-13 21:31:39.025104|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2014-11-13 21:31:39.053055|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2014-11-13 21:31:41.348911|INFO | | | Puzzle precompute time: 2284
    2014-11-13 21:31:41.349412|INFO |FileManager | | listening on 0.0.0.0:30033
    2014-11-13 21:31:41.389134|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
    2014-11-13 21:31:41.389697|INFO |Query | | listening on 0.0.0.0:10011


    2014-11-13 21:31:41.388938|INFO |VirtualServer | 1| listening on 0.0.0.0:9987


    I am probably entering some information wrong from the client?

  4. #4
    Join Date
    November 2014
    Posts
    2
    I'm also experiencing a similar issue on CENTOS, it's not a VPS in my case, but otherwise identical situation. my logs don't indicate an issue but the server service isn't initializing.

    2014-11-16 04:05:21.121018|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.11.1 (2014-10-15 07:06:31)
    2014-11-16 04:05:21.121092|INFO |ServerLibPriv | | SystemInformation: Linux 2.6.32-431.29.2.el6.x86_64 #1 SMP Tue Sep 9 21:36:05 UTC 2014 x86_64 Binary: 64bit
    2014-11-16 04:05:21.121116|INFO |ServerLibPriv | | Using hardware aes
    2014-11-16 04:05:21.121704|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2014-11-16 04:05:21.121733|INFO |DatabaseQuery | | dbPlugin version: 3.6.21
    2014-11-16 04:05:21.121971|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2014-11-16 04:05:21.133053|WARNING |Accounting | | Unable to find valid license key, falling back to limited functionality
    2014-11-16 04:05:21.576889|INFO | | | Puzzle precompute time: 434
    2014-11-16 04:05:21.577114|ERROR |FileManager | | bind() failed: 98
    2014-11-16 04:05:21.577145|ERROR |FileManager | | bind failed on 0.0.0.0:30033
    2014-11-16 04:05:21.597345|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
    2014-11-16 04:05:21.597804|ERROR |Query | | bind failed on 0.0.0.0:10011
    2014-11-16 04:05:21.597245|INFO |VirtualServer | 1| listening on 0.0.0.0:9988
    2014-11-16 04:05:21.648164|INFO |VirtualServerBase| 1| stopped

  5. #5
    Join Date
    November 2014
    Posts
    2
    my ini file.

    machine_id=
    default_voice_port=9987
    voice_ip=184.95.43.74
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=0.0.0.0
    query_port=10011
    query_ip=184.95.43.74
    query_ip_whitelist=query_ip_whitelist.txt
    query_ip_blacklist=query_ip_blacklist.txt
    dbplugin=ts3db_sqlite3
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    dbconnections=10
    logpath=logs
    logquerycommands=0
    dbclientkeepdays=30
    logappend=0
    query_skipbruteforcecheck=0

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TS3 on CentOS Setup Issues
    By GvnrRickPerry in forum Linux / FreeBSD
    Replies: 8
    Last Post: September 10th, 2015, 12:47 AM
  2. Issues in setting server groups
    By Bobisdown in forum Server Support
    Replies: 1
    Last Post: April 26th, 2014, 10:21 PM
  3. Trouble setting it up in CentOS
    By Malibuz0r in forum Linux / FreeBSD
    Replies: 5
    Last Post: January 29th, 2014, 08:29 PM
  4. CentOS Linux & VPS Issues
    By andytlim in forum Linux / FreeBSD
    Replies: 1
    Last Post: May 17th, 2013, 09:40 AM
  5. [Resolved] Issues connecting to a running server. CentOS
    By Morthawt in forum Linux / FreeBSD
    Replies: 9
    Last Post: July 25th, 2012, 11:53 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •