Forum

Page 1 of 2 12 LastLast
Results 1 to 15 of 30
  1. #1
    Join Date
    November 2014
    Posts
    2

    Mac OS X - GUI freezes after minimizing

    Teamspeak freezes on every Mac I use it on. It'll be running in the background and then I'll need to send a link to someone, and I'm unable to because the program has completely frozen. I'm still able to use it, and even click where the buttons are and hear responses, but the window itself is totally frozen. I also don't know where the client log files are to post them.

    Any help would be appreciated so I don't have to keep restarting the client. Thanks!
    Last edited by dante696; March 13th, 2015 at 09:43 AM. Reason: merged

  2. #2
    Join Date
    November 2014
    Posts
    2
    Found the log. Just in case there's anyone around.

    2014-11-09 18:03:14.600096|INFO | | | TeamSpeak 3 Client 3.0.16 (2014-08-04 13:42:43)
    2014-11-09 18:03:14.600176|INFO | | | SystemInformation: Darwin 14.0.0 Darwin Kernel Version 14.0.0: Fri Sep 19 00:26:44 PDT 2014; root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64 Binary: 64bit
    2014-11-09 18:03:14.673635|INFO | | | Loading plugin: libappscanner_plugin
    2014-11-09 18:03:14.673720|INFO | | | Loading plugin: libclientquery_plugin
    2014-11-09 18:03:14.673751|INFO | | | Loading plugin: liblua_plugin
    2014-11-09 18:03:14.673777|INFO | | | Loading plugin: libtest_plugin
    2014-11-09 18:03:14.693890|INFO |Query | | listening on 127.0.0.1:25639
    2014-11-09 18:03:15.975868|INFO | | | *** Time [MAINWINDOW]: 713
    2014-11-09 18:03:15.975922|INFO | | | *** Time [INIT]: 713
    2014-11-09 18:03:16.027776|INFO |ClientUI | | Qt version: 5.2.1
    2014-11-09 18:03:16.027834|INFO |ClientUI | | Using configuration location: /Users/[private]/Library/Application Support/TeamSpeak 3/settings.db
    2014-11-09 18:03:16.478649|INFO |ClientUI | | Last update check was: Sun Nov 9 16:00:47 2014
    2014-11-09 18:03:22.382989|INFO |ClientUI | 1| Connect to server: [private]
    2014-11-09 18:03:22.384249|INFO |ClientUI | 1| Blacklist check ok
    2014-11-09 18:03:22.384298|INFO |ClientUI | 1| Initiating connection: [private]
    2014-11-09 18:03:22.403545|INFO |Core Audio | | No speakers assigned to channels. Please do this in AUDIO MIDI SETUP of osx. Defaulting to stereo for now failure: (0) noErr

    2014-11-09 18:03:22.403862|INFO |Core Audio | | Opened playback device with 2 channels at 44100 Hz
    2014-11-09 18:03:22.404220|DEBUG |Core Audio | | BufferFrameSizeRange = 14, 4096
    2014-11-09 18:03:22.411063|INFO |Core Audio | | Opened capture device with 2 channels at 44100 Hz
    2014-11-09 18:03:22.411279|DEBUG |Core Audio | | BufferFrameSizeRange = 14, 4096
    2014-11-09 18:03:22.412088|INFO |PreProSpeex | 1| Speex version: 1.2rc1
    2014-11-09 18:03:22.413893|INFO |ClientUI | 1| Connect status: Connecting
    2014-11-09 18:03:22.647536|DEVELOP |PktHandler | | Puzzle solve time: 9
    2014-11-09 18:03:23.007598|INFO |ClientUI | 1| Connect status: Connected
    2014-11-09 18:03:23.028448|INFO |ClientUI | 1| Connect status: Establishing connection
    2014-11-09 18:03:23.130896|INFO |ClientUI | 1| Connect status: Connection established
    2014-11-09 18:03:23.140522|INFO |PermManager | | Loading permissions from cache

  3. #3
    Join Date
    November 2014
    Posts
    1
    I have the same problem since OS X 10.10 Beta and now in the final 10.10 version.
    I have the problem with my iMac and Macbook pro

  4. #4
    Join Date
    July 2014
    Posts
    5

    Mac OS X - GUI freezes after minimizing

    TS3 GUI freezes after it was minimized.

    I am not the only one with that kind of problem. Some friends of mine do have the very same issue!

    Also tested it on different OS X Versions (10.9 and 10.10), but I end up with freezed GUIs.
    You can try to reproduce the problem, if you minimize TS3, switch the focus to another application and maximize TS3 again. Freeze! (see video)

    I am facing this problem since the last 3 or 4 releases of TS3.

    Please fix it because it is very annoying!

    My current setup:
    OS X 10.10 (fresh installation)
    TS3 Client: 3.0.16
    TS3 Server: 3.0.10.3 on Linux

    Video: https://www.youtube.com/watch?v=z5WQW-ZWU24

    Thank you!

  5. #5
    Join Date
    October 2003
    Location
    Germany
    Posts
    2,528
    I'm unable to reproduce this issue on any of my Macs... what kind of machine are you using?

  6. #6
    Join Date
    July 2014
    Posts
    5
    I'm using a MacBook Pro Retina bought in 2013. Same issue on a MacBook Air bought in 2014.

    It's important to switch the focus to another application, otherwise you can not reproduce the bug (as I do in the video).

    Maybe this bug report is related to this topic: http://forum.teamspeak.com/showthrea...ut-still-works

    UPDATE: It only happens if you have the following option enabled: System Preferences -> Dock -> Minimize windows into application icon

    Are these information enough to get an idea how to fix this bug?

    Cheers
    Airwaver

  7. #7
    Join Date
    June 2008
    Posts
    18,406
    The video looks like the same issue we can not fix.

    But I can't reproduce it after your first and second how to.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  8. #8
    Join Date
    July 2014
    Posts
    5
    What do you mean with 'we can not fix it'? Is there any reason why?

    In the thread mentioned above you wrote:
    We found out, that this is a QT5 problem in relation with OSX 10.6.X.
    It's not reproducable with newer OSX versions.
    But for me it is reproducable on newer OS X versions. As I said, I am not the only one who has this problem.

    Are there any other OS X users on this forum, who can reproduce that issue?

    Cheers
    Airwaver

    Edit: Maybe related: https://bugreports.qt-project.org/browse/QTBUG-39348

  9. #9
    Join Date
    November 2014
    Posts
    1
    This happens to me too. This only occurred when I updated to Yosemite (10.10). This was on an early 2011 17" MacBook Pro and on a Mid 2014 15" MacBook Pro with Retina Display.Click image for larger version. 

Name:	Screen Shot 2014-11-19 at 4.56.16 PM.png 
Views:	103 
Size:	211.9 KB 
ID:	11616Click image for larger version. 

Name:	Screen Shot 2014-11-19 at 4.56.58 PM.png 
Views:	94 
Size:	69.5 KB 
ID:	11617

  10. #10
    Join Date
    October 2003
    Location
    Germany
    Posts
    2,528
    Quote Originally Posted by Airwaver View Post
    What do you mean with 'we can not fix it'? Is there any reason why?
    Just forget about that.



    Anyway... I've tested this on three different installations:

    • 13" MacBook Pro Retina (late 2013) running OS X 10.10.1
    • 13" MacBook Pro Retina (late 2012) running OS X 10.10
    • 13" MacBook Pro Retina (late 2012) running OS X 10.9.5

    However, I'm still unable to reproduce this problem on any of my machines. I setup the dock as you did and switched focus to another app (used Sublime as you did). No luck...

    I'm aware of an issue where hiding the client using the red X could cause a broken UI or a freeze. This problem is related to Qt 5. AFAIK, that's why the devs disabled the close button. Guess that's what dante696 is babbling about.

    Can you guys try to start the client with a fresh config and see if the problem still occurs? Just do a temporary rename of the following dir:

    ~/Library/Application Support/TeamSpeak 3

    I'm guessing there might be an old setting in your configs that was removed from the UI but is still used somehow. In addition, I've created a plugin here that re-enables the close button, fixes some bugs and changes some of the clients behaviour when showing/hiding windows:

    http://forum.teamspeak.com/showthread.php/95041

    The only other difference between your clients and mine is the lack of HiDPI support. While the upcoming 3.0.17 client will add support for Retina displays, you can enable partial HiDPI support using the Retinizer app:

    http://retinizer.mikelpr.com

    But as this also happens for you on a non-retina MacBook, it should not be related to the problem. I hope this helps...
    Last edited by ScP; November 20th, 2014 at 09:30 AM.

  11. #11
    Join Date
    July 2014
    Posts
    5
    Changing ~/Library/Application Support/TeamSpeak 3 to a random one didn't change anything. As I mentioned in a previous post, it was a complete new installation.

    Your plugin doesn't fix the bug, but if I click the close button instead of the minimize button, there is no freezing after maximising at all!

    So for now, I will stick with your plugin, which is not bad, because I like the OS X notifications!

    Danke ScP

    Greetz from Switzerland

  12. #12
    Join Date
    October 2003
    Location
    Germany
    Posts
    2,528
    Quote Originally Posted by Airwaver View Post
    Your plugin doesn't fix the bug, but if I click the close button instead of the minimize button, there is no freezing after maximising at all!

    So for now, I will stick with your plugin, which is not bad, because I like the OS X notifications!
    Well... at least my posting has been of some use.



    I still wonder what's causing this. It's not a config thing and it's obviously not related to the hardware. So I wonder why I cannot reproduce it no matter what I do. You said you also experienced this issue on Mavericks before?

  13. #13
    Join Date
    July 2014
    Posts
    5
    Yes it happened to me on 10.9 and 10.10.
    I have no clue why you can't reproduce it while I can reproduce it on a newly installed machine.

  14. #14
    Join Date
    December 2014
    Posts
    1
    Same problem multiple macs.

    Any update?


    Quote Originally Posted by k1nglui View Post
    I have the same problem since OS X 10.10 Beta and now in the final 10.10 version.
    I have the problem with my iMac and Macbook pro

  15. #15
    Join Date
    July 2012
    Posts
    11
    Same shit happens to me

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: August 10th, 2015, 12:05 PM
  2. Minimizing Channel Lists
    By SylenThunder in forum General Questions
    Replies: 2
    Last Post: October 24th, 2013, 01:56 AM
  3. Pokes minimizing games
    By metlamechanic in forum General Questions
    Replies: 0
    Last Post: December 12th, 2011, 09:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •