Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Page 1 of 2 12 LastLast
Results 1 to 15 of 20
  1. #1
    Join Date
    December 2014
    Posts
    12

    Server shutting down Repeatedly after applying NPL

    My server has been running splendidly on my Hostmonster cloud server for a couple of months now, but right after I applied my NPL yesterday and upped my slots to 512 it has been crashing repeatedly. It will stay online for maybe a couple of hours before I have to restart it because it's died. I know it isn't a load issue as I've only had maybe 5 or 6 people in TS in the past 24 hours. I checked the logs and I'll include what I found below. I'm wondering if maybe there is something wrong with the license file or if perhaps something else needed to be updated along with it.

    text/x-generic ts3server_2014-12-09__03_40_19.771700_0.log
    ASCII text
    2014-12-09 03:40:19.771904|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.11.1 (2014-10-15 07:06:31)
    2014-12-09 03:40:19.785987|INFO |ServerLibPriv | | SystemInformation: Linux 3.4.91-20140518.1.ul6.x86_64 #1 SMP Sun May 18 16:21:38 EDT 2014 x86_64 Binary: 64bit
    2014-12-09 03:40:19.805266|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2014-12-09 03:40:19.805394|INFO |DatabaseQuery | | dbPlugin version: 3.6.21
    2014-12-09 03:40:19.808093|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2014-12-09 03:41:22.974239|ERROR | | | TS3ANetwork::Connect failed error: 110
    2014-12-09 03:41:22.974379|ERROR | | | Unable to connect to primary address, trying secondary
    2014-12-09 03:42:26.142845|ERROR | | | TS3ANetwork::Connect failed error: 110
    2014-12-09 03:42:26.146398|ERROR |Accounting | | Unable to connect to accounting server
    2014-12-09 03:42:26.146450|INFO |Accounting | | Licensing Information
    2014-12-09 03:42:26.146496|INFO |Accounting | | type : Non-profit
    2014-12-09 03:42:26.146576|INFO |Accounting | | starting date : Mon Dec 8 00:00:00 2014
    2014-12-09 03:42:26.146623|INFO |Accounting | | ending date : Mon Jun 8 00:00:00 2015
    2014-12-09 03:42:26.146667|INFO |Accounting | | max virtualservers: 2
    2014-12-09 03:42:26.146709|INFO |Accounting | | max slots : 512
    2014-12-09 03:42:27.445164|INFO | | | Puzzle precompute time: 1263
    2014-12-09 03:42:27.445778|INFO |FileManager | | listening on 0.0.0.0:30033
    2014-12-09 03:42:27.554294|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
    2014-12-09 03:42:27.555180|INFO |Query | | listening on 0.0.0.0:10011
    2014-12-09 03:43:30.782277|ERROR | | | TS3ANetwork::Connect failed error: 110
    2014-12-09 03:43:30.782434|ERROR | | | Unable to connect to primary address, trying secondary
    2014-12-09 03:44:33.886253|ERROR | | | TS3ANetwork::Connect failed error: 110
    2014-12-09 03:47:27.561979|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 03:47:27.562100|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 03:47:29.063928|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 03:47:29.064069|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 03:47:31.066320|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 03:47:31.066434|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 03:57:27.642078|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 03:57:27.642205|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 03:57:29.044026|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 03:57:29.044202|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 03:57:31.046750|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 03:57:31.046885|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:07:27.712210|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:07:27.723100|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:07:29.024820|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:07:29.024951|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:07:31.029195|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:07:31.029331|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:17:27.713409|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:17:27.713522|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:17:29.015138|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:17:29.015240|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:17:31.017761|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:17:31.017874|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:27:27.704407|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:27:27.704522|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:27:29.006078|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:27:29.006198|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:27:31.008508|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:27:31.008610|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:37:27.711195|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:37:27.711317|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:37:29.012851|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:37:29.012960|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:37:31.015682|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:37:31.015807|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:45:38.462265|ERROR | | | TS3ANetwork::Connect failed error: 110
    2014-12-09 04:45:38.462390|ERROR | | | Unable to connect to primary address, trying secondary
    2014-12-09 04:46:41.630240|ERROR | | | TS3ANetwork::Connect failed error: 110
    2014-12-09 04:47:27.827620|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:47:27.827717|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:47:29.029389|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:47:29.029513|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:47:31.031878|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:47:31.031996|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:57:27.801715|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:57:27.801830|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:57:29.003283|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:57:29.003397|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:57:31.006451|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 04:57:31.006575|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:07:27.908309|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:07:27.922375|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:07:29.023797|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:07:29.023928|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:07:31.026438|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:07:31.026571|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:17:27.921668|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:17:27.921787|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:17:29.023054|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:17:29.023152|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:17:31.025452|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:17:31.025567|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:27:28.059625|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:27:28.059728|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:27:30.065749|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:27:30.065862|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:27:32.073891|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:27:32.074008|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:37:28.068084|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:37:28.079122|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:37:30.082392|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:37:30.082507|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:37:32.084925|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:37:32.085032|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:47:28.150070|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:47:28.150193|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:47:30.054026|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:47:30.054140|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:47:32.057375|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:47:32.057496|ERROR | | | TS3ANetwork::Send failed error: 1
    2014-12-09 05:47:47.871238|ERROR | | | TS3ANetwork::Connect failed error: 110
    2014-12-09 05:47:47.871354|ERROR | | | Unable to connect to primary address, trying secondary
    2014-12-09 05:48:51.038238|ERROR | | | TS3ANetwork::Connect failed error: 110
    2014-12-09 05:48:51.038385|ERROR |Accounting | | Could not connect to accounting server after multiple attempts, shutting down server

  2. #2
    Join Date
    December 2009
    Location
    UK
    Posts
    769
    If you actually read the logs you posted you'll see it wasn't crashing but was being shut down because it can't contact the accounting server. Your server needs to be able to contact accounting.teamspeak.com (don't test with ping or traceroute, these won't work)

  3. #3
    Join Date
    December 2014
    Posts
    12
    Quote Originally Posted by Air SeaTac View Post
    If you actually read the logs you posted you'll see it wasn't crashing but was being shut down because it can't contact the accounting server. Your server needs to be able to contact accounting.teamspeak.com (don't test with ping or traceroute, these won't work)
    Ok, so how do I go about troubleshooting/fixing that?

  4. #4
    Join Date
    December 2004
    Location
    RF
    Posts
    3,008
    Stop blocking thraffic you are not supposed to block, to begin with.

  5. #5
    Join Date
    December 2014
    Posts
    12
    Quote Originally Posted by ANR Daemon View Post
    Stop blocking thraffic you are not supposed to block, to begin with.
    I don't have any traffic blocked as far as I know... how would I check that? I'm not very knowledgeable with networking, sorry. My area of knowledge is more hardware and HTML/PhP.

  6. #6
    Join Date
    December 2014
    Posts
    12
    Not sure if this helps, but here is my .ini file. Are my settings on here correct?

    machine_id=
    default_voice_port=9987
    voice_ip=173.254.47.78
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=173.254.47.78
    query_port=10011
    query_ip=173.254.47.78
    query_ip_whitelist=query_ip_whitelist.txt
    query_ip_blacklist=query_ip_blacklist.txt
    dbplugin=ts3db_sqlite3
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    dbconnections=10
    logpath=logs
    logquerycommands=0
    dbclientkeepdays=30
    logappend=0
    query_skipbruteforcecheck=0

  7. #7
    Join Date
    December 2009
    Location
    UK
    Posts
    769
    Nothing to do with your Teamspeak configuration. The network settings on your server (or something on your hosts network) are blocking access to accounting.teamspeak.com

  8. #8
    Join Date
    December 2014
    Posts
    12
    OK, I talked to my hosting provider and they said everything is open on their end, that the connection is failing at the Teamspeak.com end. So... since TS doesn't have any real support stuff am I just screwed then?

  9. #9
    Join Date
    April 2011
    Location
    Germany
    Posts
    1,266
    Quote Originally Posted by Ravyns View Post
    OK, I talked to my hosting provider and they said everything is open on their end, that the connection is failing at the Teamspeak.com end. So... since TS doesn't have any real support stuff am I just screwed then?
    If it would be problem on teamspeaks end tausends of users would be wailing. So screw that incompetent hosting support of yours. My server is absolutly able to contact account as many, many other servers.

    The problem is on your end. Your server, your connecting, your hoster... start checking there. And be asured teamspeak's accouting is fine.

  10. #10
    Join Date
    January 2010
    Location
    El Prat de Llobregat (Barcelona, Spain)
    Posts
    2,698
    Quote Originally Posted by Ravyns View Post
    OK, I talked to my hosting provider and they said everything is open on their end, that the connection is failing at the Teamspeak.com end. So... since TS doesn't have any real support stuff am I just screwed then?
    Remember to your host that ping accounting.teamspeak.com doesn't give answer but this doesn't meant the accounting have problems only that doesn't answer to ping.

    Note added: Also, important, no ping so no tracert.

  11. #11
    Join Date
    December 2014
    Posts
    12
    I'm talking to my host again now. They've made sure all three ports are open (voice port= 9987, file transfer port = 30033, and query port= 10011) and no domains or IPs are blocked. He was able to open up port 2008 and 2010 and was able to telenet with accounting.teamspeak.com on port 2008.

    Something else I noticed, though, is in the logs it's showing "listening on 0.0.0.0:9987". Every IP it lists is always 0.0.0.0 in the logs. Shouldn't that be my actual IP address like it is listed in the server.ini file? This all started after I put in the NPL license file so is there possible a step I'm missing here? My host has triple checked all ports are open and nothing is blocked.

  12. #12
    Join Date
    December 2014
    Posts
    12
    I also can't connect to my server at all now. Even when it says it's running I can't connect via the client.

  13. #13
    Join Date
    December 2014
    Posts
    12
    I've now completely reinstalled both the server and my client. I've talked to my host company 5 times and they've made sure all ports are open. I can ping my dedicated IP address just fine, my TS server is running, but now I cannot connect at all. I'm beyond frustrated at this point and I KNOW it's not an issue on my hosts's end now. So, I could use some help figuring out what the heck is going on. Here's my .ini settings
    machine_id=
    default_voice_port=9987
    voice_ip=173.254.47.78
    licensepath=
    filetransfer_port=30033
    filetransfer_ip=173.254.47.78
    query_port=10011
    query_ip=173.254.47.78
    query_ip_whitelist=query_ip_whitelist.txt
    query_ip_blacklist=query_ip_blacklist.txt
    dbplugin=ts3db_sqlite3
    dbpluginparameter=
    dbsqlpath=sql/
    dbsqlcreatepath=create_sqlite/
    dbconnections=10
    logpath=logs
    logquerycommands=0
    dbclientkeepdays=30
    logappend=0
    query_skipbruteforcecheck=0
    However in the logs it still shows that the server is trying to listen on the default 0.0.0.0 IP address, NOT the IP i've repeatedly put in here.

    I tried to enter it in manually using:
    ./ts3server_minimal_runscript.sh query_ip=173.254.47.78 voice_ip=173.254.47.78 filetransfer_ip=173.254.47.78
    But it comes back with this:
    2014-12-11 07:31:31.386174|INFO |ServerLibPriv | | TeamSpeak 3 Server 3.0.11.1 (2014-10-15 07:06:31)
    2014-12-11 07:31:31.405716|INFO |ServerLibPriv | | SystemInformation: Linux 3.12.32.1415814620 #1 SMP Wed Nov 12 11:53:28 CST 2014 x86_64 Binary: 64bit
    2014-12-11 07:31:31.406822|INFO |DatabaseQuery | | dbPlugin name: SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH
    2014-12-11 07:31:31.406892|INFO |DatabaseQuery | | dbPlugin version: 3.6.21
    2014-12-11 07:31:31.407402|INFO |DatabaseQuery | | checking database integrity (may take a while)
    2014-12-11 07:31:32.258642|INFO |Accounting | | Licensing Information
    2014-12-11 07:31:32.258744|INFO |Accounting | | type : Non-profit
    2014-12-11 07:31:32.258821|INFO |Accounting | | starting date : Mon Dec 8 00:00:00 2014
    2014-12-11 07:31:32.258880|INFO |Accounting | | ending date : Mon Jun 8 00:00:00 2015
    2014-12-11 07:31:32.258935|INFO |Accounting | | max virtualservers: 2
    2014-12-11 07:31:32.258982|INFO |Accounting | | max slots : 512
    2014-12-11 07:31:33.200592|INFO | | | Puzzle precompute time: 923
    2014-12-11 07:31:33.200846|ERROR |FileManager | | bind() failed: 98
    2014-12-11 07:31:33.200911|ERROR |FileManager | | bind failed on 173.254.47.78:30033
    2014-12-11 07:31:33.237228|ERROR |VirtualServer | 1| bind failed on 173.254.47.78:9988
    2014-12-11 07:31:33.237441|ERROR |VirtualSvrMgr | | loading VirtualServer(1) failed to start, error: unable to bind network port
    2014-12-11 07:31:33.237832|INFO |VirtualServerBase| 1| stopped
    2014-12-11 07:31:33.237996|INFO |CIDRManager | | updated query_ip_whitelist ips: 127.0.0.1,
    2014-12-11 07:31:33.238562|ERROR |Query | | bind failed on 173.254.47.78:10011

  14. #14
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,368
    Could you stop spamming the forum and start reading? All that stuff has been answered millions of times on the forums and in the server quickstart guide. You really should not host a server if you neither know server basics nor are able to read documentation.

  15. #15
    Join Date
    December 2014
    Posts
    12
    Quote Originally Posted by numma_cway View Post
    Could you stop spamming the forum and start reading? All that stuff has been answered millions of times on the forums and in the server quickstart guide. You really should not host a server if you neither know server basics nor are able to read documentation.
    Oh, I'm sorry, I didn't realize this was the networking forum for the elite teamspeak users. Here I was thinking it was a community forum for people to help each other out since Teamspeak has no formal support unless you're paying a lot of money for a commercial license. I'm terribly sorry for inconveniencing you by making you read my request for help on a support forum and then making you take time out of your day to make a condescending and snide remark at my expense. I know that must take up a terrible amount of your day deciding who is and is not deserving of learning and running their own TS server so I am deeply sorry for adding to that burden.

    For those who aren't being condescending jerks, I've followed the tutorials and guides on how to start the server from scratch, doing exactly what I did the first time I set my server up (which worked until I added the licensekey file) but I'm still running into issues. It looks as if the IP addresses are not being bound, even though in the .ini file I have them set. When I try to set them manually, as seen above, it says bind failed. Now, since I'm not doing anything differently than how I set my last server up with the exception of including the licensekey file, can anyone see what is going wrong?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: September 5th, 2014, 09:52 AM
  2. Replies: 2
    Last Post: October 8th, 2013, 03:26 PM
  3. [Resolved] Can't increase server slots after applying the NPL
    By Rowlf DK in forum Windows
    Replies: 0
    Last Post: April 5th, 2012, 07:34 AM
  4. Connection to server lost, repeatedly and randomly.
    By Hyperstrike in forum Server Support
    Replies: 0
    Last Post: March 28th, 2010, 06:34 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •