Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 4 of 4
  1. #1
    Join Date
    December 2010

    Problem with SRV record, IDN domain


    after I got TSDNS running and working with IDN domains (the ones with umlauts), I tried to setup my SRV records. It seems like the TS client can't resolve the SRV records correctly. I tried with the encoded domain and the record worked, so the SRV record is correct. Are the DNS calls maybe done with the decoded domain?

    Client Version 3.0.16 on Windows.

    Client Log Entry:
    26.01.2015 23:26:11 TSDNS Info SRV DNS resolve unsuccessful for "_ts3._udp.mü****.de"

    Domains without umlauts are working perfectly fine.

    edit: This report is not about the TSDNS delivered with the server, this is working fine with umlauts. It's about SRV records of the domain DNS.
    Last edited by CalibeR.50; January 27th, 2015 at 12:23 AM.

  2. #2
    Join Date
    June 2008
    There is a known problem with TSDNS and with the client when Umlaute are written in Lower or Uppercase

    I guess it's the same problem. Your Domain or TSDNS server is entered in Uppercase?
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    June 2011
    Make sure TSDNS configuration is in UTF-8. According to YaTQA source code, the client seems to keep the case of non-ASCII characters, so you need to have records for all sort of case mixes.
    IDN SRV doesn't work at all, as described by me in the thread that dante linked.

  4. #4
    Join Date
    December 2010
    Everything is lowercase. TSDNS is working (the tool delivered with the server), only the SRV records are failing.

    Edit: Is there any scheduled fix for this issue?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help me with A record for linking my domain to teamspeak
    By Borgqueenx in forum General Questions
    Replies: 1
    Last Post: August 29th, 2015, 03:59 PM
  2. SRV record for dedicated domain port is not working
    By Rewtie in forum Server Support
    Replies: 2
    Last Post: August 25th, 2015, 02:31 AM
  3. Problem with sub domain and SRV record
    By omvwtfbbq in forum Server Support
    Replies: 2
    Last Post: November 30th, 2013, 05:24 PM
  4. Replies: 0
    Last Post: September 16th, 2013, 04:47 AM
  5. [Resolved] Seting server accessible @ sub.domain but inaccessible @ domain ?
    By PotHEdd in forum Server Support
    Replies: 2
    Last Post: March 17th, 2011, 10:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts