Forum

Results 1 to 3 of 3
  1. #1
    Join Date
    February 2015
    Posts
    2

    Speakers/Headphones Disabled When Switching Speakers/Headphones

    Ever since I got my Soundblaster Z, I've noticed an issue with Teamspeak whenever I switch between my speakers and my headphones in the Creative Soundblaster Z-Series Control Panel. 9 times out of 10, when I switch between my speakers and headphones, I lose all sound in Teamspeak and a Teamspeak says "Speakers/Headphones Disabled". If I open my playback options and switch the toggle between "default" and "speakers", then my sound comes back and the error goes away. The next time it happens I have to toggle it again from "speakers" back to "default". I can also just restart Teamspeak to fix the issue.

    I've tried a lot of work-arounds I have thought of but so far none of them have worked without other issues. I thought I had found a workable solution when I realized that if I have Teamspeak set to Direct Sudio into of Windows Audio Session the speakers don't get disabled. Unfortunately, I have noticed that after having Teamspeak open for a few hours with Direct Sound, I start getting reports of people telling me that my mic is cutting out and cuts off the end of what I'm saying. I have also tried to go into the control panel and change my sound settings to not allow programs to take exclusive control of the device but that has not made a difference.

    Here is as much information as I can supply.

    TeamSpeak version including build number: 3.0.16
    Operating System including Service Packs or Kernel Version/Patchset: Windows 8.1 64-bit
    Soundcard & Driver version: Creative Soundblaster Z driver version v13.1.00.28
    DirectX version: DirectX 11
    Error message (information out of your client or server logfiles can be very useful): Logfile posted below.
    How often does the error appear? 90% of the time when switching between speakers and headphones
    What did you try to fix the problem? see above

    Here is a log of me joining a Teamspeak server, switching from speakers to headphones (it did not disable my speakers this time) then switching back to speakers (it did disable the speakers/headphones). It seems completely random when it decides to disable the speakers.

    Code:
    2/3/2015 09:38:45		Info	TeamSpeak 3 Client 3.0.16 (2014-08-04 13:42:43)	
    2/3/2015 09:38:45		Info	SystemInformation: Windows 8 (9200) x64 (AMD or Intel) Binary: 64bit	
    2/3/2015 09:38:45		Info	Using hardware aes	
    2/3/2015 09:38:45	Direct Sound	Debug	setting timer resolution to 1ms	
    2/3/2015 09:38:45		Info	Loading plugin: appscanner_plugin	
    2/3/2015 09:38:45		Info	Loading plugin: chatlogs_win64	
    2/3/2015 09:38:45		Info	Loading plugin: clientquery_plugin	
    2/3/2015 09:38:45		Info	Loading plugin: g-key_win64	
    2/3/2015 09:38:45		Info	Loading plugin: lua_plugin	
    2/3/2015 09:38:45		Info	Loading plugin: playclaw4-x64	
    2/3/2015 09:38:45		Info	Loading plugin: teamspeak_control_plugin	
    2/3/2015 09:38:45		Info	Loading plugin: test_plugin	
    2/3/2015 09:38:45		Info	Loading plugin: ts3g15	
    2/3/2015 09:38:45		Info	Skipping Qt4 dependant overlay plugin	
    2/3/2015 09:38:45	Query	Info	listening on 127.0.0.1:25639	
    2/3/2015 09:38:45		Info	Api version is not compatible for plugin: Z:\Program Files\TeamSpeak 3 Client\plugins\g-key_win64.dll	
    2/3/2015 09:38:45		Info	Api version is not compatible for plugin: Z:\Program Files\TeamSpeak 3 Client\plugins\playclaw4-x64.dll	
    2/3/2015 09:38:45	Windows Audio Session	Devel	DeviceDeleteList::waitForDeletes - enter	
    2/3/2015 09:38:45	Windows Audio Session	Devel	DeviceDeleteList::waitForDeletes - leave	
    2/3/2015 09:38:45	InputDevices	Info	Input device name: Logitech, Inc. G25 Racing Wheel	
    2/3/2015 09:38:45	InputDevices	Info	Input device name: unknown Vendor ACT LABS Performance Pedals / Shifter	
    2/3/2015 09:38:45	Input	Info	Keyboard & mouse monitoring enabled	
    2/3/2015 09:38:45		Info	*** Time [MAINWINDOW]: 198	
    2/3/2015 09:38:45		Info	*** Time [INIT]: 198	
    2/3/2015 09:38:45	ClientUI	Info	Qt version: 5.2.1	
    2/3/2015 09:38:45	ClientUI	Info	Using configuration location: C:\Users\Tyler\AppData\Roaming\TS3Client\settings.db	
    2/3/2015 09:38:46	ClientUI	Info	Last update check was: Mon Feb 2 12:58:30 2015	
    2/3/2015 09:38:46		Info	Checking for updates...	
    2/3/2015 09:38:46	TSDNS	Info	DNS resolve successful, "update.teamspeak.com"=46.105.112.65	
    2/3/2015 09:38:46		Info	Update check, my version: 1407159763, latest version: 1407159763	
    2/3/2015 09:38:47	ClientUI	Info	Connect to server: ts.21cw.net	
    2/3/2015 09:38:47	ClientUI	Info	Trying to resolve ts.21cw.net	
    2/3/2015 09:38:48	TSDNS	Info	SRV DNS resolve unsuccessful for "_ts3._udp.ts.21cw.net"	
    2/3/2015 09:38:48	TSDNS	Info	DNS resolve successful, "ts.21cw.net"=192.223.27.231	
    2/3/2015 09:38:48	ClientUI	Info	Lookup finished: 192.223.27.231 9987 ts.21cw.net 0 0	
    2/3/2015 09:38:48	ClientUI	Info	Resolve successful: 192.223.27.231:9987	
    2/3/2015 09:38:48	ClientUI	Info	Blacklist check ok	
    2/3/2015 09:38:48	ClientUI	Info	Initiating connection: 192.223.27.231:9987 ts.21cw.net	
    2/3/2015 09:38:48	Windows Audio Session	Devel	DeviceDeleteList::waitForDeletes - enter	
    2/3/2015 09:38:48	Windows Audio Session	Devel	DeviceDeleteList::waitForDeletes - leave	
    2/3/2015 09:38:48	Windows Audio Session	Debug	WAS::openDevice-enter	
    2/3/2015 09:38:48	Windows Audio Session	Debug	WAS Buffer size: 960	
    2/3/2015 09:38:48	Windows Audio Session	Debug	WAS::openDevice-leave	
    2/3/2015 09:38:48	Windows Audio Session	Debug	WAS::startDevice-enter	
    2/3/2015 09:38:48	Windows Audio Session	Debug	WAS::startDevice-leave	
    2/3/2015 09:38:48	Windows Audio Session	Devel	DeviceDeleteList::waitForDeletes - enter	
    2/3/2015 09:38:48	Windows Audio Session	Devel	DeviceDeleteList::waitForDeletes - leave	
    2/3/2015 09:38:48	Windows Audio Session	Debug	WAS::openDevice-enter	
    2/3/2015 09:38:48	Windows Audio Session	Debug	WAS Buffer size: 960	
    2/3/2015 09:38:48	Windows Audio Session	Debug	WAS::openDevice-leave	
    2/3/2015 09:38:48	PreProSpeex	Info	Speex version: speex-1.2beta3	
    2/3/2015 09:38:48	Windows Audio Session	Debug	WAS::startDevice-enter	
    2/3/2015 09:38:48	Windows Audio Session	Debug	WAS::startDevice-leave	
    2/3/2015 09:38:48	Windows Audio Session	Debug	WAS::associateAECDevice-enter	
    2/3/2015 09:38:48	Windows Audio Session	Debug	WAS Buffer size: 960	
    2/3/2015 09:38:48	Windows Audio Session	Debug	WAS::associateAECDevice-leave	
    2/3/2015 09:38:48	ClientUI	Info	Connect status: Connecting	
    2/3/2015 09:38:48	PktHandler	Devel	Puzzle solve time: 5	
    2/3/2015 09:38:48	ClientUI	Info	Connect status: Connected	
    2/3/2015 09:38:48	ClientUI	Info	Connect status: Establishing connection	
    2/3/2015 09:38:48	ClientUI	Info	Connect status: Connection established	
    2/3/2015 09:38:48	PermManager	Info	Loading permissions from cache	
    2/3/2015 09:38:51	SoundDevManager	Info	Device needs reopening	
    2/3/2015 09:38:51	Windows Audio Session	Debug	WAS::stopDevice-enter	
    2/3/2015 09:38:51	Windows Audio Session	Debug	WAS::stopDevice-leave	
    2/3/2015 09:38:51	Windows Audio Session	Debug	WAS::closeDevice-enter	
    2/3/2015 09:38:51	Windows Audio Session	Devel	DeviceDeleteList::queueDeviceDelete - enter	
    2/3/2015 09:38:51	Windows Audio Session	Devel	DeviceDeleteList::queueDeviceDelete - leave	
    2/3/2015 09:38:51	Windows Audio Session	Devel	DeviceDeleteList::clearQueue - enter	
    2/3/2015 09:38:51	Windows Audio Session	Debug	WAS::closeDevice-leave	
    2/3/2015 09:38:51	Windows Audio Session	Devel	DeviceDeleteList::waitForDeletes - enter	
    2/3/2015 09:38:51	Windows Audio Session	Devel	Waiting for device to close 	
    2/3/2015 09:38:51	Windows Audio Session	Devel	DeviceDeleteList::clearQueue - leave 	
    2/3/2015 09:38:51	Windows Audio Session	Devel	DeviceDeleteList::waitForDeletes - leave	
    2/3/2015 09:38:51	Windows Audio Session	Debug	WAS::openDevice-enter	
    2/3/2015 09:38:51	Windows Audio Session	Debug	WAS Buffer size: 960	
    2/3/2015 09:38:51	Windows Audio Session	Debug	WAS::openDevice-leave	
    2/3/2015 09:38:51	Windows Audio Session	Debug	WAS::associateAECDevice-enter	
    2/3/2015 09:38:51	Windows Audio Session	Devel	DeviceDeleteList::queueDeviceDelete - enter	
    2/3/2015 09:38:51	Windows Audio Session	Devel	DeviceDeleteList::queueDeviceDelete - leave	
    2/3/2015 09:38:51	Windows Audio Session	Devel	DeviceDeleteList::clearQueue - enter	
    2/3/2015 09:38:51	Windows Audio Session	Devel	DeviceDeleteList::clearQueue - leave 	
    2/3/2015 09:38:51	Windows Audio Session	Debug	WAS Buffer size: 960	
    2/3/2015 09:38:51	Windows Audio Session	Debug	WAS::associateAECDevice-leave	
    2/3/2015 09:38:51	Windows Audio Session	Debug	WAS::startDevice-enter	
    2/3/2015 09:38:51	Windows Audio Session	Debug	WAS::startDevice-leave	
    2/3/2015 09:39:01	SoundDevManager	Info	Device needs reopening	
    2/3/2015 09:39:01	Windows Audio Session	Debug	WAS::stopDevice-enter	
    2/3/2015 09:39:01	Windows Audio Session	Debug	WAS::stopDevice-leave	
    2/3/2015 09:39:01	Windows Audio Session	Debug	WAS::closeDevice-enter	
    2/3/2015 09:39:01	Windows Audio Session	Devel	DeviceDeleteList::queueDeviceDelete - enter	
    2/3/2015 09:39:01	Windows Audio Session	Devel	DeviceDeleteList::queueDeviceDelete - leave	
    2/3/2015 09:39:01	Windows Audio Session	Devel	DeviceDeleteList::clearQueue - enter	
    2/3/2015 09:39:01	Windows Audio Session	Debug	WAS::closeDevice-leave	
    2/3/2015 09:39:01	Windows Audio Session	Devel	DeviceDeleteList::waitForDeletes - enter	
    2/3/2015 09:39:01	Windows Audio Session	Devel	Waiting for device to close 	
    2/3/2015 09:39:01	Windows Audio Session	Devel	DeviceDeleteList::clearQueue - leave 	
    2/3/2015 09:39:01	Windows Audio Session	Devel	DeviceDeleteList::waitForDeletes - leave	
    2/3/2015 09:39:01	Windows Audio Session	Debug	WAS::openDevice-enter	
    2/3/2015 09:39:01	Windows Audio Session	Debug	WAS Buffer size: 960	
    2/3/2015 09:39:01	Windows Audio Session	Error	ERROR (-129 -2004287484): AUDCLNT_E_DEVICE_INVALIDATED	
    2/3/2015 09:39:06	Windows Audio Session	Error	EchoDeviceContext callbackWaits2 wait exceeded 5 secs 258	
    2/3/2015 09:39:06	SoundBckndIntf	Error	Z:/Program Files/TeamSpeak 3 Client/soundbackends/windowsaudiosession_win64.dll error: GET_RENDERCLIENT	
    2/3/2015 09:39:06	SoundDevManager	Info	Device needs reopening	
    2/3/2015 09:39:06	Windows Audio Session	Error	ERROR (-141 -2004287484): AUDCLNT_E_DEVICE_INVALIDATED

  2. #2
    Join Date
    February 2015
    Posts
    2
    It's been a week with no reply, I gave all the information asked, can anyone help?

  3. #3
    Join Date
    October 2013
    Location
    Pennsylvania
    Posts
    27
    This is actually quite common. About the only work around that I encounter is to relaunch TeamSpeak. Occasionally I can get it rectified by disabling the audio device in windows audio and then enabling it. Sometimes it resets. I personally have found some luck with running TeamSpeak with admin permissions but even that acts crazy sometimes. I don't believe its a TeamSpeak issue specifically, I believe its more of an issue regarding Windows based on what I've seen.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to fix my headphones/speakers being disabled?
    By klempn23 in forum General Questions
    Replies: 0
    Last Post: September 20th, 2014, 06:43 PM
  2. Speakers/Headphones Disabled? Help please :(
    By demarchi13 in forum General Questions
    Replies: 4
    Last Post: October 18th, 2011, 09:19 PM
  3. Speakers/Headphones Disabled
    By Jadibanez in forum Client Support
    Replies: 9
    Last Post: October 11th, 2011, 03:57 PM
  4. Speakers/Headphones Disabled
    By Jadibanez in forum General Questions
    Replies: 0
    Last Post: August 20th, 2011, 07:45 PM
  5. Speakers/headphones disabled
    By Veldhuijzen in forum General Questions
    Replies: 0
    Last Post: May 28th, 2011, 01:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •