Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 4 of 4
  1. #1
    Join Date
    February 2015
    Toronto, Ontario

    Teamspeak goes "robotic" after approx 2.5 hours

    So I've built myself a new PC (Win7) and have TeamSpeak3 installed. My server is hosted on TServerHQ. I log into TS and use it while raiding in World Of Warcraft and always, after about 2.5 to 3 hours, the client goes absolutely nuts. I've looked and I'm not losing any packets, and it seems to ONLY happen to me.

    I am currently using Fatal1ty Headset via USB connection directly into the mobo. I've also tried the USB jacks at the front. Currently my only solution is to quit TS for about a minute at least and then reconnect.

    Driver installed is their latest: Creative Gaming Headsets Driver 1.01.0004
    X-Fi items are toggled OFF as they supposedly have issues.

    Attempted the following:
    TS 3.16 x64 installed into default location
    TS 3.16 x64 installed into a different location (settings into default, shouldn't matter)
    TS 3.16 x32 installed into a different location
    * All have the same result above *

    Is there any solution to this possible "memory" leak or something (not sure what to call it). I will be trying a new headset in the next few days (buying one that lists Win7 as an operating system) but not sure if that will fix my issue.

    Any help would be appreciated.

  2. #2
    Join Date
    October 2013
    I'd try the alternative headset first. If you're not losing packets and not choking then its not network related. After two hours of raiding are you running out of memory on your machine? Any audio will get choppy and robotic when either your cpu or ram is nearing its physical limitations. Alternatively, I've had this specifically happen when my machine is getting too hot, but that usually results in a shut down if I'm getting it that hot.

  3. #3
    Join Date
    February 2015
    Toronto, Ontario
    Thank you for your response Chris... This is the current update..

    New headset (green-pink connectors) -- directly plugged in is a bit of a workout to make it so that I don't hear game sound along with the voice.. Bought a SoundBlaster Play!2 unit (green-pink to usb) and it works like a charm... Good, so a working "backup"

    The first headset I still cannot seem to keep running past 2.25 / 2.5 hours without disconnecting between.

    Losing packets (no)
    Out of memory (seriously hope not. 16gb ram here)
    CPU hitting limit (doubt it. I'm overclocked to 4.5Ghz stable and its only TS that acts up, nothing else (not even WoW which is being run with sound at the same time))
    Tower Heat (doubt it. H110i watercooler (dual 120 fan out) + 2 120 fans in and 1 90 fan out)

    Still to try is to unhook a cheap headset that is hooked up via a splitter at the back (doubt it will change anything)
    or see if there is a USB to Pink-Green outputs that I can then connect to the SoundBlaster Play!2 unit and maybe have it work that way, since that little unit is its own portable soundcard..

  4. #4
    Join Date
    May 2006
    Europe/Czech Rep.
    If it is windows, I would request teamspeak3 client log when you use problematic headset. Why didn't you include that?

    Additionally next time before you play start taskmgr and switch to Performance tab.
    When you get to the choppy time, alt+tab to it, make screenshot, or if you have more screens just look at it.
    What those graphs look like?
    CPU? RAM?
    You can repeat that process for Networking tab.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: July 8th, 2015, 10:39 AM
  2. [Evaluation] Add: Right-click users from "List All Clients" to view the "Server Groups Dialogue"
    By Morthawt in forum Suggestions and Feedback
    Replies: 1
    Last Post: February 22nd, 2014, 08:18 PM
  3. [Resolved] Add "Channel" Text Location to "Sent poke" and back to "Received poke"
    By PatPeter in forum Suggestions and Feedback
    Replies: 2
    Last Post: May 9th, 2013, 06:09 AM
  4. Can I use "whisper" to enable a "Public" and "Private" channel?
    By DadisAjax in forum General Questions
    Replies: 2
    Last Post: June 28th, 2012, 11:59 PM
  5. Replies: 15
    Last Post: June 20th, 2012, 12:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts