Forum

Page 2 of 2 FirstFirst 12
Results 16 to 27 of 27
  1. #16
    Join Date
    September 2015
    Posts
    5

    Voice in channel with opus codec only coming out of one ear

    I have a professional audio interface with a left and right microphone input. I have my microphone plugged into the left port on my interface, which shows up as stereo left on the computer. When I speak in a channel with the Opus audio codec, everyone only hears my voice through their left ear.

    Surely there's an option to mix your input to mono before you transmit it?
    Last edited by dante696; September 8th, 2015 at 11:10 PM. Reason: merged

  2. #17
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,365
    Opus Music is stereo if the sender is using a computer. Some headsets report stereo but aren't. Either remove Opus Music or contact your sound card and/or headset manufacturer.

  3. #18
    Join Date
    September 2015
    Posts
    5
    Quote Originally Posted by numma_cway View Post
    Opus Music is stereo if the sender is using a computer. Some headsets report stereo but aren't. Either remove Opus Music or contact your sound card and/or headset manufacturer.
    My sound card is functioning perfectly, this is intended functionality.

    I find it ridiculous that Teamspeak doesn't have an option to only send mono audio or to mix stereo to mono.

  4. #19
    Join Date
    June 2008
    Posts
    18,241
    Quote Originally Posted by JamEngulfer View Post
    I find it ridiculous that Teamspeak doesn't have an option to only send mono audio or to mix stereo to mono.
    This codec is just not made for Talking. And we do not have control about the codec settings that happen in background.
    You do not have a stereo mic connected = you do not talk in stereo.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #20
    Join Date
    September 2015
    Posts
    5
    Quote Originally Posted by dante696 View Post
    This codec is just not made for Talking. And we do not have control about the codec settings that happen in background.
    You do not have a stereo mic connected = you do not talk in stereo.
    I'm in a teamspeak channel for musicians, we both play music and talk in the same channel. Also, if I want to play music into the channel, it comes out of everyone's right ear. Pre-mixing to mono is just such a basic feature that it boggles my mind that it's not a part of the client.

  6. #21
    Join Date
    June 2008
    Posts
    18,241
    Just setup your hardware/software that it does not play sounds only one speaker?
    We only send what we get from your hardware and let the codec do the rest.

    We will not investigate any men power for that.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  7. #22
    Join Date
    September 2015
    Posts
    2

    People only hear me on their left earphone

    I'm already tired of searching this on forum, I don't have a logitech g35 neither ventrilo.
    This started when I installed Razer Surround that emulates 7.1 virtual surround in a normal stereo headset(yes that are the headphones I use),but I already unnistalled it and didn't fix anything.
    It's not 3D sound option from my friends, I have mono to stereo option in settings and when I test my microphone inside TS I can hear in both earphones.
    On game voice chat they hear me on both earphones, on skype they hear me on both earphones, so I assume it's TS3 fault.
    And yes I tried reinstall it deleting all the files and even use Windows Restore Points and neither worked.

    Any fix?
    Last edited by dante696; September 20th, 2015 at 10:19 PM. Reason: merged

  8. #23
    Join Date
    June 2008
    Posts
    18,241
    Why is this TeamSpeak's fault?
    When TS works fine and Skype works fine for you, but the game dosn't?

    Maybe your game does not support Stereo Microphones at all.
    If you have the same problem in TeamSpeak, then please do not use Opus Music for talking.
    Last edited by dante696; September 20th, 2015 at 10:17 PM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  9. #24
    Join Date
    September 2015
    Posts
    2
    PD: I mean the microphone is only working on my friends left earphone, but in-game and skype they hear me on both earphone (left and right).

    I'm not meaning it's headphones fault, I'm saying it's teamspeak microphone configuration bug. It's not 3D and its mono to stereo option on.

  10. #25
    Join Date
    June 2008
    Posts
    18,241
    Quote Originally Posted by VampDarkX View Post
    PD: I mean the microphone is only working on my friends left earphone, but in-game and skype they hear me on both earphone (left and right).

    I'm not meaning it's headphones fault, I'm saying it's teamspeak microphone configuration bug. It's not 3D and its mono to stereo option on.
    Quote Originally Posted by dante696 View Post
    If you have the same problem in TeamSpeak, then please do not use Opus Music for talking.
    Important part now in bold. Threads merged
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  11. #26
    Join Date
    April 2016
    Posts
    1

    Capture problem (audio only left or right side)

    So yesterday everyone could hear my voice in stereo but overnight something changed. I didn't change any settings or anything that would matter but today when I joined a server people told me they could only hear me from the left side. My soundcard has two inputs and my microphone is attached to the left one labeled as "1" so I tried to change it to the right input ("2") and then people could only hear me from the right side. When I go to the noise gate options in ts3 and test my mic I can hear myself in stereo and everything seems fine. When I test my mic in any digital audio workstation like Ableton there is a option whether I'd like to use my soundcards input 1, 2 or 1+2 but ts3 doesn't have that option so how do I fix this? Apparently my ts3's capture input changed from 1 to 1+2 overnight without me doing anything(?)

    Equipment:
    -Rode NT-1 microphone (microphone)
    -Focusrite Saffire 6 USB (soundcard)
    -Windows 7
    Last edited by dante696; April 13th, 2016 at 10:01 AM. Reason: Merged, please change the codec

  12. #27
    Join Date
    October 2012
    Location
    Germany
    Posts
    553
    What you're experiencing is the expected behaviour for this kinda setup (for now).
    What probably mysteriously has changed overnight should be one of the capture processing settings.
    I don't recall which one right now, probably echo cancelation, triggers a downmix to mono as side effect. So one of those dsps was activated yesterday.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Help?] Opus Voice > Opus Music!?
    By Vinni_ in forum Client Support
    Replies: 2
    Last Post: December 14th, 2014, 12:57 AM
  2. Opus Music Icon
    By OnkelTerror in forum Windows
    Replies: 2
    Last Post: January 4th, 2014, 04:34 PM
  3. How to play music through Teamspeak server using Opus Music
    By BusinessPony in forum General Questions
    Replies: 2
    Last Post: March 5th, 2013, 03:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •