Forum

Page 1 of 2 12 LastLast
Results 1 to 15 of 27
  1. #1
    Join Date
    February 2015
    Posts
    5

    Using Opus music (or celt) to talk

    Hello Com.

    Yesterday i joined a public and enter a channel with setting Opus music quality 10.
    In these channel i have alwasy sound bugs like a squealing while others speaks.
    I have update all sounddrivers but the problem is still there ;(

    maybe someone can helps me?

    Sorry for bad english

  2. #2
    Join Date
    June 2008
    Posts
    18,144
    We discussed this several times.

    Do not use this codec to talk in it! It's a codec for music
    There are missing filters and they use different EQ settings.

    edit
    Also causes, that users only hear you talking from one side only.
    Last edited by dante696; March 25th, 2015 at 08:04 AM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    February 2015
    Posts
    5
    The problem is; This Teamspeak is not my. Its an public World vs world 500slot ts for a game.
    Don't know why others are not interessted in changing the sound setting ;(
    I will ask the Serveradmin to change the settings.

    Thanks for your reply

  4. #4
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,350
    Another reason why you shouldn't use Opus Music for voice, is that it is stereo and some headsets only use one channel for mono sound.

  5. #5
    Join Date
    February 2015
    Posts
    5
    I am using a stero Headset but i am wondering that noone other complain on these Teamspeak o.O

  6. #6
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,350
    Stereo microphone headsets to be more specific. And it only happens with some.

  7. #7
    Join Date
    February 2015
    Posts
    5
    I am using these on at the moment http://www.amazon.com/ROCCAT-Stereo-...at+kulo+stereo

  8. #8
    Join Date
    August 2013
    Location
    Germany
    Posts
    540
    Quote Originally Posted by numma_cway View Post
    Stereo microphone headsets to be more specific. And it only happens with some.
    WTF? I didn't even know such bullshit exists

  9. #9
    Join Date
    October 2012
    Location
    Germany
    Posts
    553
    Sometimes that second channel is used to filter out noise, if both are directional - however that shouldn't arrive at TS as stereo in that case. Other than that, well... ;D

    Truth is, from my pov at least, given that there is no server side mixing, it would have had made a lot more sense to have such implemented as client setting. I mean, a whole channel is transmitting in stereo just to have one music bot just doesn't "sound" (hehe) right.
    Generally, if I would use music bots currently, I'd probably investigate putting them bots into an own channel and have them whisper, which should preserve their channel codec. If that's a feature of currently existing music bots, that is xD

  10. #10
    Join Date
    February 2015
    Posts
    5
    Okay the Problem is my headset ... i tested it with my speakers and no squealing. But what can i do? Only way to buy new Headset?

  11. #11
    Join Date
    June 2008
    Posts
    18,144
    Quote Originally Posted by FroxIV View Post
    Only way to buy new Headset?
    No?! Do not use the codec for talking.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  12. #12
    Join Date
    March 2015
    Posts
    1

    Microphone only works on left or right channel

    Hello I have an issue with my microphone when I use teamspeak with the opus music codec. What happens is sound only comes out of the channel I have the microphone plugged into... My setup is an XLR microphone into a USB audio interface with two mic inputs. Any help to resolve this would be greatly appreciated. It's driving me crazy!
    Last edited by dante696; March 25th, 2015 at 08:02 AM. Reason: merged

  13. #13
    Join Date
    June 2008
    Posts
    18,144
    Do not use the music codec for talking. It's not made and implemented for this.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  14. #14
    Join Date
    August 2015
    Posts
    4

    TS3 Opus Music Codec Microphone sound left

    Hi, some days ago a bought a new microphone, the Samson G-Track.

    But if i talk now in a channel with the opus music codec the sound of the microphone is only on the left speaker.
    Is there a way to fix this problem?

    ~MrJoki007
    Last edited by dante696; September 8th, 2015 at 10:11 PM. Reason: merged

  15. #15
    Join Date
    March 2009
    Location
    Germany
    Posts
    40
    Well you have to configure your microphone correctly.
    I myself have a microphone with a similar problem.
    Further investigation brought me closure on that topic. It seems that many use a simple and cheap chipset for conversion of the signal to a usb audio device. These chipsets are recognized by all major operating systems without additional drivers. Since these are generic devices, they can convert mono and stereo signals. Your microphone is most likely a mono device soldered to the left input on that device.

    If you're using Windows. Change the Input to Mono on the Advanced Settings Panel for Audio Devices.
    On Linux, if you're using Pulseaudio use pavucontrol to change the device to Analog Mono Input.
    Last edited by dante696; September 8th, 2015 at 10:11 PM. Reason: merged

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Help?] Opus Voice > Opus Music!?
    By Vinni_ in forum Client Support
    Replies: 2
    Last Post: December 13th, 2014, 11:57 PM
  2. Opus Music Icon
    By OnkelTerror in forum Windows
    Replies: 2
    Last Post: January 4th, 2014, 03:34 PM
  3. How to play music through Teamspeak server using Opus Music
    By BusinessPony in forum General Questions
    Replies: 2
    Last Post: March 5th, 2013, 02:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •