Forum

Results 1 to 3 of 3
  1. #1
    Join Date
    February 2015
    Posts
    2

    Debian GNU/Linux: Teamspeak is crashing while trying to connect to Pulseaudio

    Hi,

    ive got sometimes the following problem:

    Code:
    $ ./ts3client_runscript.sh
    2015-02-26 12:38:47.119540|INFO    |              |   | TeamSpeak 3 Client 3.0.16 (2014-08-04 13:42:43)
    2015-02-26 12:38:47.119699|INFO    |              |   | SystemInformation: Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt4-3 (2015-02-03) x86_64 Binary: 64bit
    2015-02-26 12:38:47.138185|DEBUG   |PulseAudio    |   | connected to pulse audio server
    2015-02-26 12:38:47.216686|INFO    |              |   | Loading plugin: libappscanner_plugin
    2015-02-26 12:38:47.216806|INFO    |              |   | Loading plugin: libclientquery_plugin
    2015-02-26 12:38:47.216863|INFO    |              |   | Loading plugin: liblua_plugin
    2015-02-26 12:38:47.216917|INFO    |              |   | Loading plugin: libtest_plugin
    2015-02-26 12:38:47.799253|INFO    |              |   | *** Time [MAINWINDOW]: 248
    2015-02-26 12:38:47.799452|INFO    |              |   | *** Time [INIT]: 248
    2015-02-26 12:38:47.814432|INFO    |ClientUI      |   | Failed to init text to speech engine
    2015-02-26 12:38:47.814620|INFO    |ClientUI      |   | Qt version: 5.2.1
    2015-02-26 12:38:47.814680|INFO    |ClientUI      |   | Using configuration location: /home/treaki/.ts3client/settings.db
    2015-02-26 12:38:48.300393|INFO    |ClientUI      |   | Last update check was: Thu Feb 26 12:33:40 2015
    2015-02-26 12:38:57.201992|INFO    |PreProSpeex   |  2| Speex version: 1.2rc1
    warning: The VAD has been replaced by a hack pending a complete rewrite
    /home/treaki/bin/ts/TeamSpeak3-Client-linux_amd64/ts3client_runscript.sh: line 17: 31761 Segmentation fault      ./ts3client_linux_amd64 [email protected]
    $
    it is working until i click the test button at sound settings and ts is trying to connect to my pulseaudio. After a relog it is working again for some time but than it happens again. Please fix that bug so Teamspeak dosnt crash anymore.

    thanks

  2. #2
    Join Date
    February 2015
    Posts
    2
    i dont have any clue about debugging but maybe this contains some more information about the problem.

    Code:
    [email protected]:~/TeamSpeak3-Client-linux_amd64$ less ./ts3client_runscript.sh 
    [email protected]:~/TeamSpeak3-Client-linux_amd64$ export KDEDIRS=
    [email protected]:~/TeamSpeak3-Client-linux_amd64$ export KDEDIR=
    [email protected]:~/TeamSpeak3-Client-linux_amd64$ export QTDIR=.
    [email protected]:~/TeamSpeak3-Client-linux_amd64$ export QT_PLUGIN_PATH=.
    [email protected]:~/TeamSpeak3-Client-linux_amd64$ export LD_LIBRARY_PATH=".:$LD_LIBRARY_PATH"
    [email protected]:~/TeamSpeak3-Client-linux_amd64$ 
    [email protected]:~/TeamSpeak3-Client-linux_amd64$ D1=$(readlink -f "$0")
    [email protected]:~/TeamSpeak3-Client-linux_amd64$ D2=$(dirname "${D1}")
    [email protected]:~/TeamSpeak3-Client-linux_amd64$ cd "${D2}"
    [email protected]:~/TeamSpeak3-Client-linux_amd64$ gdb ./ts3client_linux_amd64 
    GNU gdb (Debian 7.7.1+dfsg-5) 7.7.1
    Copyright (C) 2014 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
    and "show warranty" for details.
    This GDB was configured as "x86_64-linux-gnu".
    Type "show configuration" for configuration details.
    For bug reporting instructions, please see:
    <http://www.gnu.org/software/gdb/bugs/>.
    Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.
    For help, type "help".
    Type "apropos word" to search for commands related to "word"...
    Reading symbols from ./ts3client_linux_amd64...(no debugging symbols found)...done.
    (gdb) run
    Starting program: /home/treaki/bin/ts/TeamSpeak3-Client-linux_amd64/ts3client_linux_amd64 
    [Thread debugging using libthread_db enabled]
    Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
    [New Thread 0x7ffff2210700 (LWP 32009)]
    [New Thread 0x7ffff113e700 (LWP 32010)]
    2015-02-26 12:47:56.469815|INFO    |              |   | TeamSpeak 3 Client 3.0.16 (2014-08-04 13:42:43)
    2015-02-26 12:47:56.469987|INFO    |              |   | SystemInformation: Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt4-3 (2015-02-03) x86_64 Binary: 64bit
    [New Thread 0x7ffff7fb5700 (LWP 32011)]
    [New Thread 0x7ffff093d700 (LWP 32012)]
    [New Thread 0x7fffe5624700 (LWP 32013)]
    [New Thread 0x7fffe4e23700 (LWP 32014)]
    2015-02-26 12:47:56.645396|DEBUG   |PulseAudio    |   | connected to pulse audio server
    [New Thread 0x7fffdffff700 (LWP 32015)]
    [New Thread 0x7fffdf7fe700 (LWP 32016)]
    2015-02-26 12:47:56.815839|INFO    |              |   | Loading plugin: libappscanner_plugin
    2015-02-26 12:47:56.815957|INFO    |              |   | Loading plugin: libclientquery_plugin
    2015-02-26 12:47:56.816013|INFO    |              |   | Loading plugin: liblua_plugin
    2015-02-26 12:47:56.816067|INFO    |              |   | Loading plugin: libtest_plugin
    [New Thread 0x7fffdf215700 (LWP 32017)]
    [New Thread 0x7fffdf114700 (LWP 32018)]
    [New Thread 0x7fffdf013700 (LWP 32019)]
    [New Thread 0x7fffdee72700 (LWP 32020)]
    2015-02-26 12:47:57.490330|INFO    |              |   | *** Time [MAINWINDOW]: 254
    2015-02-26 12:47:57.496156|INFO    |              |   | *** Time [INIT]: 255
    2015-02-26 12:47:57.511342|INFO    |ClientUI      |   | Failed to init text to speech engine
    2015-02-26 12:47:57.511535|INFO    |ClientUI      |   | Qt version: 5.2.1
    2015-02-26 12:47:57.511592|INFO    |ClientUI      |   | Using configuration location: /home/treaki/.ts3client/settings.db
    2015-02-26 12:47:57.991680|INFO    |ClientUI      |   | Last update check was: Thu Feb 26 12:33:40 2015
    2015-02-26 12:48:03.857014|INFO    |PreProSpeex   |  2| Speex version: 1.2rc1
    warning: The VAD has been replaced by a hack pending a complete rewrite
    [New Thread 0x7fffde120700 (LWP 32025)]
    
    Program received signal SIGSEGV, Segmentation fault.
    [Switching to Thread 0x7fffe5624700 (LWP 32013)]
    __memmove_ssse3 () at ../sysdeps/x86_64/multiarch/memcpy-ssse3.S:1510
    1510	../sysdeps/x86_64/multiarch/memcpy-ssse3.S: No such file or directory.
    (gdb) quit
    A debugging session is active.
    
    	Inferior 1 [process 32005] will be killed.
    
    Quit anyway? (y or n) y
    [email protected]:~/TeamSpeak3-Client-linux_amd64$

  3. #3
    Join Date
    May 2006
    Location
    Europe/Czech Rep.
    Posts
    1,616
    Your kernel appears to be recent, still I'll ask what is the version?
    cat /etc/debian_version

    also please do:
    ldd teamspeakbinaryhere

    With little luck I will try run ts3 with pulseaudio during weekend myself.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Install Teamspeak on Linux / Debian
    By jsvenancio in forum Linux
    Replies: 5
    Last Post: May 27th, 2014, 12:54 PM
  2. Linux PulseAudio popping sounds
    By AWTom in forum Linux
    Replies: 0
    Last Post: October 8th, 2013, 04:00 AM
  3. Replies: 1
    Last Post: June 20th, 2011, 10:06 AM
  4. [On Todo] Client Keeps Pulseaudio Under Heavy Load - Linux
    By paulseverance in forum Bug Reports [EN/DE]
    Replies: 2
    Last Post: July 6th, 2010, 08:47 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •