Forum

Results 1 to 6 of 6
  1. #1
    Join Date
    May 2013
    Location
    Austria
    Posts
    2

    TS Server refuses and dumps connections after android private chat

    Heya,

    when someone on a Mobile Phone (Android APK) opens a Private Chat (opening is enough, no message needed) the TeamSpeak Server will crash instantly and stay down.

    terminate called after throwing an instance of 'std::runtime_error'
    what(): locale::facet::_S_create_c_locale name not valid


    I've read on several similiar Issues its because the locale language variables are wrong (eg en_UK which does not exist), but as I've checked only one's I run are en_GB in UTF8.

    To mention, I have not installed locales on this Debian 6 machine since it seems to not be compatible;
    Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.



    Kind Regards
    Last edited by neoWTFneo; March 10th, 2015 at 11:34 PM. Reason: typo

  2. #2
    Join Date
    June 2015
    Posts
    3
    I confirm this is happening with my server too

    Server:3.0.11.3

    Client: Android 3.0.18.1

    When opening a private chat window on the android device the server crashes with no logging.

    If a user using the windows client opens a chat with an android user and sends a message this has the same effect.

    Maybe this needs moving to bugs?
    Last edited by dante696; June 26th, 2015 at 08:54 AM. Reason: quote removed

  3. #3
    Join Date
    June 2008
    Posts
    18,279
    We will investigate this problem.

    Please do not double post, because all threads and posts get moderated by default*

    Edit
    -Please show us the output of "locale" and "locale -a"
    -And tell us the full name of the path where teamspeak server is running
    Last edited by dante696; July 3rd, 2015 at 10:14 AM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  4. #4
    Join Date
    June 2015
    Posts
    3
    # locale
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=



    # locale -a
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_COLLATE to default locale: No such file or directory
    C
    POSIX

    Path:
    /opt/ts3/

  5. #5
    Join Date
    June 2015
    Posts
    3
    Okay so being a windows guy normally I went into fixing the locale issue...

    I run CentOS so I rebuilt the local-archive by doing this command:-
    Code:
    localedef -v -c -i en_US -f UTF-8 en_US.utf8
    Reset TS and bam works correctly

    Don't see how it was only crashing on android though...

  6. #6
    Join Date
    June 2008
    Posts
    18,279
    We also did discuss about that issue.
    Thank you for giving us these details to analyze the problem.

    Your operation system is broken in case of
    Code:
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    The Android client needs this for an internal function in the server. This causes the server to crash.

    Edit
    The crash will be fixed with server 3.0.12, but we will inform users on server start and anytime when locale is needed and not availbale.
    This stays a problem from the operation system and should be fixed user itself to avoid these problems.
    Last edited by dante696; July 1st, 2015 at 01:36 PM.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: January 9th, 2015, 05:29 PM
  2. Server refuses all connections
    By DavidCopperhead in forum Server Support
    Replies: 7
    Last Post: March 18th, 2012, 11:45 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •