Forum

Results 1 to 8 of 8
  1. #1
    Join Date
    March 2015
    Posts
    2

    TS3 client 3.0.16 (Mac OS X) crashes on connect

    Dear Ladies and Gents,

    The OS X version of the TS3 client (3.0.16) crashes on connect to almost every server I like to use.

    The logfile shows a segfault, whereas the system crash report shows a crashed Thread 0 of the Qt5 libs.
    I paste you the relevant parts of both logfile and system crash report:


    logfile:
    Code:
    2015-03-26 01:49:50.240376|INFO    |              |   | TeamSpeak 3 Client 3.0.16 (2014-08-04 13:42:43)
    2015-03-26 01:49:50.240476|INFO    |              |   | SystemInformation: Darwin 11.4.2 Darwin Kernel Version 11.4.2: Thu Aug 23 16:25:48 PDT 2012; root:xnu-1699.32.7~1/RELEASE_X86_64 x86_64 Binary: 64bit
    2015-03-26 01:49:50.298834|INFO    |              |   | Loading plugin: libappscanner_plugin
    2015-03-26 01:49:50.298918|INFO    |              |   | Loading plugin: libclientquery_plugin
    2015-03-26 01:49:50.298952|INFO    |              |   | Loading plugin: liblua_plugin
    2015-03-26 01:49:50.298986|INFO    |              |   | Loading plugin: libtest_plugin
    2015-03-26 01:49:52.278130|INFO    |              |   | *** Time [MAINWINDOW]: 755
    2015-03-26 01:49:52.278210|INFO    |              |   | *** Time [INIT]: 755
    2015-03-26 01:49:52.415387|INFO    |              |   | *** Time [NOTIFICATIONS]: 130
    2015-03-26 01:49:52.415675|INFO    |ClientUI      |   | Qt version: 5.2.1
    2015-03-26 01:49:52.415759|INFO    |ClientUI      |   | Using configuration location: /Users/mk/Library/Application Support/TeamSpeak 3/settings.db
    2015-03-26 01:49:52.839386|INFO    |ClientUI      |   | Last update check was: Thu Mar 26 01:39:46 2015
    2015-03-26 01:49:58.451048|INFO    |ClientUI      |  1| Connect to server: xxx.yyy.zzz.vvv
    2015-03-26 01:49:58.452459|INFO    |ClientUI      |  1| Blacklist check ok
    2015-03-26 01:49:58.452515|INFO    |ClientUI      |  1| Initiating connection: xxx.yyy.zzz.vvv:5032 xxx.yyy.zzz.vvv
    2015-03-26 01:49:58.479410|INFO    |Core Audio    |   | No speakers assigned to channels. Please do this in AUDIO MIDI SETUP of osx. Defaulting to stereo for now failure: (0) noErr
                                                            
    2015-03-26 01:49:58.479713|INFO    |Core Audio    |   | Opened playback device with 2 channels at 48000 Hz
    2015-03-26 01:49:58.480009|DEBUG   |Core Audio    |   | BufferFrameSizeRange = 15,  4608
    2015-03-26 01:49:58.498918|INFO    |Core Audio    |   | Opened capture device with 2 channels at 44100 Hz
    2015-03-26 01:49:58.499110|DEBUG   |Core Audio    |   | BufferFrameSizeRange = 14,  2304
    2015-03-26 01:49:58.499550|INFO    |PreProSpeex   |  1| Speex version: 1.2rc1
    warning: The VAD has been replaced by a hack pending a complete rewrite
    2015-03-26 01:49:58.516695|INFO    |ClientUI      |  1| Connect status: Connecting
    Segmentation fault: 11
    crash report:
    Code:
    Process:         ts3client_mac [9798]
    Path:            /Users/USER/*/TeamSpeak 3 Client.app/Contents/MacOS/ts3client_mac
    Identifier:      com.teamspeak.TeamSpeak3
    Version:         ??? (???)
    Code Type:       X86-64 (Native)
    Parent Process:  bash [9795]
    
    Date/Time:       2015-03-26 01:49:58.551 +0100
    OS Version:      Mac OS X 10.7.5 (11G63)
    Report Version:  9
    
    Interval Since Last Report:          73939292 sec
    Crashes Since Last Report:           212
    Per-App Interval Since Last Report:  47177829 sec
    Per-App Crashes Since Last Report:   121
    
    Crashed Thread:  0  Dispatch queue: com.apple.main-thread
    
    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000070
    
    VM Regions Near 0x70:
    --> 
        __TEXT                 0000000100000000-0000000100d49000 [ 13.3M] r-x/rwx SM=COW  /Users/USER/*/TeamSpeak 3 Client.app/Contents/MacOS/ts3client_mac
    
    Application Specific Information:
    objc[9798]: garbage collection is OFF
    
    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0   libQt5Widgets.5.2.1.dylib     	0x00000001019020a1 QWidget::mapFromGlobal(QPoint const&) const + 49
    1   libQt5Widgets.5.2.1.dylib     	0x0000000101906bc6 QWidgetWindow::handleTabletEvent(QTabletEvent*) + 598
    2   libQt5Widgets.5.2.1.dylib     	0x00000001019044a1 QWidgetWindow::event(QEvent*) + 561
    3   libQt5Widgets.5.2.1.dylib     	0x00000001018aef2c QApplicationPrivate::notify_helper(QObject*, QEvent*) + 300
    4   libQt5Widgets.5.2.1.dylib     	0x00000001018b1a1d QApplication::notify(QObject*, QEvent*) + 6157
    5   libQt5Core.5.2.1.dylib        	0x00000001010210e2 QCoreApplication::notifyInternal(QObject*, QEvent*) + 114
    6   libQt5Gui.5.2.1.dylib         	0x000000010141984f QGuiApplicationPrivate::processTabletEvent(QWindowSystemInterfacePrivate::TabletEvent*) + 911
    7   libQt5Gui.5.2.1.dylib         	0x0000000101415620 QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) + 944
    8   libQt5Gui.5.2.1.dylib         	0x0000000101405328 QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 136
    9   libqcocoa.dylib               	0x0000000104a484c7 QCocoaEventDispatcherPrivate::processPostedEvents() + 295
    10  libqcocoa.dylib               	0x0000000104a48fd8 QCocoaEventDispatcherPrivate::postedEventsSourceCallback(void*) + 40
    11  com.apple.CoreFoundation      	0x00007fff942fa4f1 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
    12  com.apple.CoreFoundation      	0x00007fff942f9d5d __CFRunLoopDoSources0 + 253
    13  com.apple.CoreFoundation      	0x00007fff94320b49 __CFRunLoopRun + 905
    14  com.apple.CoreFoundation      	0x00007fff94320486 CFRunLoopRunSpecific + 230
    15  com.apple.HIToolbox           	0x00007fff8ff102bf RunCurrentEventLoopInMode + 277
    16  com.apple.HIToolbox           	0x00007fff8ff174bf ReceiveNextEventCommon + 181
    17  com.apple.HIToolbox           	0x00007fff8ff173fa BlockUntilNextEventMatchingListInMode + 62
    18  com.apple.AppKit              	0x00007fff93122779 _DPSNextEvent + 659
    19  com.apple.AppKit              	0x00007fff9312207d -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135
    20  com.apple.AppKit              	0x00007fff9311e9b9 -[NSApplication run] + 470
    21  libqcocoa.dylib               	0x0000000104a47d44 QCocoaEventDispatcher::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 2404
    22  libQt5Core.5.2.1.dylib        	0x000000010101e69d QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) + 397
    23  libQt5Core.5.2.1.dylib        	0x0000000101021682 QCoreApplication::exec() + 354
    24  com.teamspeak.TeamSpeak3      	0x000000010047a9df 0x100000000 + 4696543
    25  com.teamspeak.TeamSpeak3      	0x0000000100005674 0x100000000 + 22132
    
    Thread 0 crashed with X86 Thread State (64-bit):
      rax: 0x0000000000000000  rbx: 0x0000000109c083b0  rcx: 0x00000000000003b8  rdx: 0x0000027f000003b8
      rdi: 0x0000000109c083b0  rsi: 0x00007fff5fbfd1f0  rbp: 0x00007fff5fbfd120  rsp: 0x00007fff5fbfd0f0
       r8: 0x000008029b807089   r9: 0x0000000000000001  r10: 0x000000010888d430  r11: 0x0000000107881018
      r12: 0x0000000102120240  r13: 0x000000010887cb80  r14: 0x00000000000003b8  r15: 0x000000000000027f
      rip: 0x00000001019020a1  rfl: 0x0000000000010202  cr2: 0x0000000000000070
    Logical CPU: 1
    
    Binary Images:
           0x100000000 -        0x100d48fff +com.teamspeak.TeamSpeak3 (??? - ???) <11F83C17-9948-35C3-897E-B97848FBD117> /Users/USER/*/TeamSpeak 3 Client.app/Contents/MacOS/ts3client_mac
           0x100e0e000 -        0x101303fff +libQt5Core.5.2.1.dylib (5.2.1 - compatibility 5.2.0) <9DB951AD-CC0F-38E8-AF4F-7E1B514EA6D1> /Users/USER/*/TeamSpeak 3 Client.app/Contents/Frameworks/libQt5Core.5.2.1.dylib
           0x1013f2000 -        0x10176ffff +libQt5Gui.5.2.1.dylib (5.2.1 - compatibility 5.2.0) <0946B0B0-A824-379A-A686-EDFF6286A652> /Users/USER/*/TeamSpeak 3 Client.app/Contents/Frameworks/libQt5Gui.5.2.1.dylib
           0x101883000 -        0x101d35fff +libQt5Widgets.5.2.1.dylib (5.2.1 - compatibility 5.2.0) <4EECA8D5-C7C9-3641-A8B9-D7DCA340915B> /Users/USER/*/TeamSpeak 3 Client.app/Contents/Frameworks/libQt5Widgets.5.2.1.dylib
           0x101ed6000 -        0x101fd9fff +libQt5Network.5.2.1.dylib (5.2.1 - compatibility 5.2.0) <C9DED57A-0270-35AD-ABDF-346C24F93487> /Users/USER/*/TeamSpeak 3 Client.app/Contents/Frameworks/libQt5Network.5.2.1.dylib
           0x10203d000 -        0x102066fff +libQt5Sql.5.2.1.dylib (5.2.1 - compatibility 5.2.0) <235FD516-71CB-3450-8B3B-A37B6E7F117A> /Users/USER/*/TeamSpeak 3 Client.app/Contents/Frameworks/libQt5Sql.5.2.1.dylib
           0x10207d000 -        0x1020a4fff +libquazip.1.0.0.dylib (??? - ???) <33FFBF23-DD1A-3632-BC01-3DD573EB6B05> /Users/USER/*/TeamSpeak 3 Client.app/Contents/Frameworks/libquazip.1.0.0.dylib
           0x1020b4000 -        0x1020bafff  com.apple.agl (3.2.0 - AGL-3.2.0) <AB0B5D3F-BA2A-3366-830A-EF9258C18276> /System/Library/Frameworks/AGL.framework/Versions/A/AGL
           0x1025ed000 -        0x1025f1fff  com.apple.audio.AudioIPCPlugIn (1.2.3 - 1.2.3) <F94D690D-3196-3B01-B798-09708367D28D> /System/Library/Extensions/AudioIPCDriver.kext/Contents/Resources/AudioIPCPlugIn.bundle/Contents/MacOS/AudioIPCPlugIn
           0x1025f6000 -        0x1025fbfff  com.apple.audio.AppleHDAHALPlugIn (2.2.5 - 2.2.5a5) <4EC4981B-68AE-357E-960F-3D4603A61E9F> /System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAHALPlugIn.bundle/Contents/MacOS/AppleHDAHALPlugIn
           0x102783000 -        0x1027acfff +libQt5PrintSupport.5.2.1.dylib (5.2.1 - compatibility 5.2.0) <B5DBB2A3-F9C9-3CC6-9E87-15107A16206A> /Users/USER/*/TeamSpeak 3 Client.app/Contents/Frameworks/libQt5PrintSupport.5.2.1.dylib
           0x1027eb000 -        0x1027f1ff7 +libqgif.dylib (??? - ???) <06854E98-669D-3946-9466-BDF863ED34EE> /Users/USER/*/TeamSpeak 3 Client.app/Contents/Plugins/imageformats/libqgif.dylib
           0x104a2e000 -        0x104abcff7 +libqcocoa.dylib (??? - ???) <93292EF9-EE50-3909-8B5C-742545556B7E> /Users/USER/*/TeamSpeak 3 Client.app/Contents/Plugins/platforms/libqcocoa.dylib
           0x104c0b000 -        0x104ce2ff7 +libqsqlite.dylib (??? - ???) <A7CB8291-D608-3275-8D11-17CA037AD086> /Users/USER/*/TeamSpeak 3 Client.app/Contents/Plugins/sqldrivers/libqsqlite.dylib
           0x104d7c000 -        0x104d8cff7 +libcoreaudio_mac.dylib (??? - ???) <AAE53E45-8A7A-35FD-82AE-C768E3D08DE1> /Users/USER/*/TeamSpeak 3 Client.app/Contents/SharedSupport/soundbackends/libcoreaudio_mac.dylib
    
    Model: iMac9,1, BootROM IM91.008D.B08, 2 processors, Intel Core 2 Duo, 2.93 GHz, 4 GB, SMC 1.45f0
    Graphics: NVIDIA GeForce GT 130, NVIDIA GeForce GT 130, PCIe, 512 MB
    Any suggestions on how to fix this issue?

    best regards,
    astrokiste.

  2. #2
    Join Date
    June 2008
    Posts
    18,303
    The error message you get is a generall message.

    Please try to reinstall the client. Maybe the binary or libary is broken.
    Or try change the port , when you use an USB Headset.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    March 2015
    Posts
    2
    I reinstalled the client several times. I also deleted the folder in the Library-path before reinstall. I use a normal line-in/headphone-jack headset. I also tried different sound settings in the system's audio pref-pane. Of course, I rebooted the system after reinstalling the client. The issue remains the same :-/

    Is it possible to DL an older version of ts3 only to see if the issue is still there?

    regards.

  4. #4
    Join Date
    June 2008
    Posts
    18,303
    Yes this is possible.

    http://dl.4players.de/ts/releases/
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  5. #5
    Join Date
    April 2015
    Posts
    1
    I'm having the same issue.. i even reinstalled 3 different versions to try. I can't really do anything in the program.. As soon as i hit connect it crashes... Occasionally it will get into the server for a split second then crash... also if i try to clear the cache or anything in the settings window it will crash as well.


    my log is here
    Attached Files Attached Files

  6. #6
    Join Date
    June 2015
    Posts
    2

    My client crashes

    Hello,

    My client keeps crashing over and over again.
    I cleaned the cache as well but it doesn't work... here is what my report says, please help me!:

    Process: ts3client_mac [873]
    Path: /Applications/TeamSpeak 3 Client.app/Contents/MacOS/ts3client_mac
    Identifier: com.teamspeak.TeamSpeak3
    Version: ???
    Code Type: X86-64 (Native)
    Parent Process: ??? [1]
    Responsible: ts3client_mac [873]
    User ID: 501

    Date/Time: 2015-06-29 18:44:19.093 +0200
    OS Version: Mac OS X 10.10.2 (14C109)
    Report Version: 11


    Sleep/Wake UUID: 33F5CCF0-1C36-47B4-9D17-D428D866E69F

    Time Awake Since Boot: 1900 seconds

    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x000000008000007b

    VM Regions Near 0x8000007b:

  7. #7
    Join Date
    June 2015
    Posts
    2
    I think I figured it out, in finder, under devices you have to eject team speak and then it works!

  8. #8
    Join Date
    July 2015
    Posts
    1
    Quote Originally Posted by JosefinM View Post
    I think I figured it out, in finder, under devices you have to eject team speak and then it works!
    This exact same thing is happening to me, and sadly this easy fix did not work. Even tried ejecting all other devices attached to the computer with no different results.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: December 28th, 2013, 10:03 PM
  2. Client crashes when I connect
    By Aeterna in forum Linux
    Replies: 3
    Last Post: July 29th, 2011, 06:58 PM
  3. Teamspeak 3 client crashes on connect
    By xorth in forum Windows
    Replies: 6
    Last Post: April 25th, 2010, 11:12 PM
  4. Client crashes on connect
    By lonewolf9567 in forum Windows
    Replies: 3
    Last Post: April 9th, 2010, 09:04 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •