Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 9 of 9
  1. #1
    Join Date
    April 2015
    Posts
    2

    SRV Hostname Configuring

    I'm trying to get a domain to redirect to my teamspeak.
    These are my settings http://i57.tinypic.com/2l819i.jpg

    I think everything is in order however when i connect to ts3.philrossisin.space it asks me for a password. Strange.

  2. #2
    Join Date
    April 2011
    Location
    Germany
    Posts
    1,266
    That's because there is not valid SRV record to say it in DNS ... NXDOMAIN

  3. #3
    Join Date
    December 2004
    Location
    RF
    Posts
    3,008
    I can't see, what is there in order.
    Total mess with no sign of sense. You've managed to screw even most basic things in there.
    Please refer to http://forum.teamspeak.com/showthrea...288#post383288 and http://tools.ietf.org/html/rfc2782

  4. #4
    Join Date
    April 2015
    Posts
    2
    Quote Originally Posted by ANR Daemon View Post
    I can't see, what is there in order.
    Total mess with no sign of sense. You've managed to screw even most basic things in there.
    Please refer to http://forum.teamspeak.com/showthrea...288#post383288 and http://tools.ietf.org/html/rfc2782
    I was assured by live support that everything i had entered was correct, however i apologize for my lack of knowledge on the topic.
    However, i can't even decipher what you're trying to say in that thread you linked me and rest assured it's for a vps with totally different inputs, and is therefore hurting my head trying to figure out what it means.

    Why if i connect to ts3.philrossisin.space is requests a password? Is there anyway to look through the domain and find the IP you're connecting to, this would allow me to see where along i've went wrong.
    Thanks.



    UPDATE
    ts.philrossisin.space:22307 will connect me to my teamspeak server. How do i set it so it doesn't require with port with srv settings?
    http://i58.tinypic.com/2d75x1c.jpg

    The port being 22307.
    The IP being 85.236.yadda
    and the multiplay domain being 707692.yaddayadda.com
    Seems everything is working but the port not just being entered automatically.
    When not using the port it prompts for a password
    Last edited by reecelol; April 6th, 2015 at 03:21 PM.

  5. #5
    Join Date
    January 2010
    Location
    El Prat de Llobregat (Barcelona, Spain)
    Posts
    2,698
    Quote Originally Posted by reecelol View Post
    I'm trying to get a domain to redirect to my teamspeak.
    These are my settings http://i57.tinypic.com/2l819i.jpg

    I think everything is in order however when i connect to ts3.philrossisin.space it asks me for a password. Strange.
    None of your two SRV records are working and they seem to be misdeclared, so better you should deleted them.

    I would try the following:
    _SERVICE: _ts3.
    _PROTOCOL: _udp.ts.
    Priority: 10
    Weight: 5
    Port: 22307
    Target: 85.236.100.27

    With that, ts.philrossisin.space should resolve 85.236.100.27:22307

    and you could use ts3.philrossisin.space:22307 in case of a SRV record fail.

  6. #6
    Join Date
    April 2011
    Location
    Germany
    Posts
    1,266
    Quote Originally Posted by PotaBlava View Post
    Target: 85.236.100.27
    Using an IP as target is forbidden by SRV RFCs. You HAVE to use an A record. All other is just lottery as any resolver can ignore a SRV that doesn't have a A record as target. It might work if the dns resolver is very tollerant (and not strict RFC complient), but you'll never know.

  7. #7
    Join Date
    January 2010
    Location
    El Prat de Llobregat (Barcelona, Spain)
    Posts
    2,698
    Quote Originally Posted by Barungar View Post
    Using an IP as target is forbidden by SRV RFCs. You HAVE to use an A record. All other is just lottery as any resolver can ignore a SRV that doesn't have a A record as target. It might work if the dns resolver is very tollerant (and not strict RFC complient), but you'll never know.
    Ok, Barungar.
    Then,
    instead of
    Target: 85.236.100.27
    reecelol should indicate
    Target: ts3.philrossisin.space

  8. #8
    Join Date
    January 2010
    Location
    El Prat de Llobregat (Barcelona, Spain)
    Posts
    2,698
    Quote Originally Posted by reecelol View Post

    UPDATE
    ts.philrossisin.space:22307 will connect me to my teamspeak server. How do i set it so it doesn't require with port with srv settings?
    http://i58.tinypic.com/2d75x1c.jpg

    The port being 22307.
    The IP being 85.236.yadda
    and the multiplay domain being 707692.yaddayadda.com
    Seems everything is working but the port not just being entered automatically.
    When not using the port it prompts for a password
    Oh my god. You have changed the configuration in an Update that I didn't notice.
    My suggestion is based in the original image: http://i57.tinypic.com/2l819i.jpg
    where there is not any ts.philrossisin.space definition.

  9. #9
    Join Date
    December 2004
    Location
    RF
    Posts
    3,008
    Quote Originally Posted by PotaBlava View Post
    None of your two SRV records are working and they seem to be misdeclared, so better you should deleted them.

    I would try the following:
    _SERVICE: _ts3.
    _PROTOCOL: _udp.ts.
    Priority: 10
    Weight: 5
    Port: 22307
    Target: 85.236.100.27

    With that, ts.philrossisin.space should resolve 85.236.100.27:22307

    and you could use ts3.philrossisin.space:22307 in case of a SRV record fail.
    That will produce the record "_ts3.._udp.ts." or even "__ts3..__udp.ts." instead of the required "_ts3._udp.philrossisin.space."
    Depends, how really brain-damaged the backend.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. configuring
    By rockyrayner1 in forum Windows
    Replies: 1
    Last Post: May 3rd, 2010, 02:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •