Forum

Results 1 to 4 of 4
  1. #1
    Join Date
    April 2015
    Posts
    2

    Query Client - connection Lost

    Hello Community,

    hopefully I'll get any guidance in here.

    I've wrote a query bot for my Teamspeak server. This bot connects via telnet to proceed query commands on my server.

    Bot and server are on the same machine! My bot is connection via the loopback address.

    My Problem is that the bot will be disconnected after 10 Minutes without any action.

    Code:
    24.04.2015 13:20:20	VirtualServer	Info	query client connected 'Exylian TS3 Bot from 127.0.0.1:37586'(id:310)	
    24.04.2015 13:30:20	VirtualServerBase	Info	query client disconnected 'Exylian TS3 Bot from 127.0.0.1:37586'(id:310) reason 'reasonmsg=connection lost'	
    24.04.2015 13:30:20	VirtualServer	Info	query client connected 'Exylian TS3 Bot from 127.0.0.1:37587'(id:310)	
    24.04.2015 13:40:20	VirtualServerBase	Info	query client disconnected 'Exylian TS3 Bot from 127.0.0.1:37587'(id:310) reason 'reasonmsg=connection lost'	
    24.04.2015 13:40:20	VirtualServer	Info	query client connected 'Exylian TS3 Bot from 127.0.0.1:37588'(id:310)	
    24.04.2015 13:50:20	VirtualServerBase	Info	query client disconnected 'Exylian TS3 Bot from 127.0.0.1:37588'(id:310) reason 'reasonmsg=connection lost'	
    24.04.2015 13:50:20	VirtualServer	Info	query client connected 'Exylian TS3 Bot from 127.0.0.1:37590'(id:310)
    I "solved" the problem with starting my bot as a daemon which connects again when the bot crashed.

    The Problem must be created by my Teamspeak Server cause on some other Servers I got not problems like that.


    Best regards
    Felix H.

  2. #2
    Join Date
    June 2008
    Posts
    18,151
    This is a wanted timeout from the server on inactivity.
    Just perform a fake command every 5 minutes.

    IDK how other bots do it, but thats an easy way to solve this.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    April 2015
    Posts
    2
    Yeah that's true and I'm on to implement it to my code but this solution is not really effective in my opinion.

    Is there no possibility to turn off the wanted timeout. As I said on some other Servers I have no problems....

  4. #4
    Join Date
    December 2004
    Location
    RF
    Posts
    3,006
    10 minutes is a long way to go. You could just make a cron job to poll the server every 10 minutes. Will give you same results with much less hassle.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [No Bug] Query Client + Connection Info = invalid client type
    By Linnun in forum Bug Reports [EN/DE]
    Replies: 1
    Last Post: January 19th, 2015, 07:38 AM
  2. Connection lost issue and client suspension
    By Arahnor in forum Windows
    Replies: 0
    Last Post: November 7th, 2012, 01:57 PM
  3. Client gets Connection Lost
    By Pitz_ in forum Bug Reports [EN/DE]
    Replies: 20
    Last Post: March 2nd, 2011, 02:35 PM
  4. Client connection lost Reason
    By imadhermina in forum Windows
    Replies: 5
    Last Post: December 29th, 2009, 06:47 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •