Forum

Results 1 to 7 of 7
  1. #1
    Join Date
    April 2015
    Posts
    5

    Teamspeak3 Client not connecting on Debian

    Hello Guys,
    my TS3Client on my Debian is not connecting to the TS3 server. Here is the full log:

    Code:
     INFO   Starting instance ts3server://127.0.0.1?port=9987&nickname=Musikbot%20von%20ChaoZz&password=&channel=&channelpassword=
    2015-04-27 13:13:18.687860|INFO    |              |   | TeamSpeak 3 Client 3.0.16 (2014-08-04 13:42:43)
    2015-04-27 13:13:18.688003|INFO    |              |   | SystemInformation: Linux 3.14.32-xxxx-grs-ipv6-64 #1 SMP Sat Feb 7 11:35:27 CET 2015 x86_64 Binary: 64bit
    2015-04-27 13:13:18.688056|INFO    |              |   | Using hardware aes
    2015-04-27 13:13:18.702402|DEBUG   |PulseAudio    |   | connected to pulse audio server
    2015-04-27 13:13:18.725608|INFO    |              |   | Loading plugin: libappscanner_plugin
    2015-04-27 13:13:18.725672|INFO    |              |   | Loading plugin: libclientquery_plugin
    2015-04-27 13:13:18.725712|INFO    |              |   | Loading plugin: liblua_plugin
    2015-04-27 13:13:18.725745|INFO    |              |   | Loading plugin: libsoundbot_plugin
    2015-04-27 13:13:18.725779|INFO    |              |   | Loading plugin: libtest_plugin
    2015-04-27 13:13:18.727384|INFO    |Query         |   | listening on 127.0.0.1:25639
    ClientQueryPlugin: currentServerConnectionChanged 1 (0)
    2015-04-27 13:13:18.969745|INFO    |              |   | *** Time [MAINWINDOW]: 110
    2015-04-27 13:13:18.969896|INFO    |              |   | *** Time [INIT]: 110
    2015-04-27 13:13:18.973598|INFO    |ClientUI      |   | Failed to init text to speech engine
    2015-04-27 13:13:18.973696|INFO    |ClientUI      |   | Qt version: 5.2.1
    2015-04-27 13:13:18.973741|INFO    |ClientUI      |   | Using configuration location: /home/Teamspeak3-MBot/data/ts3/40a31cea-8db6-467e-a40a-ee4a80f66082/dc35916f-8156-441b-8d41-3b07a40a5070/settings.db
    2015-04-27 13:13:19.270123|INFO    |ClientUI      |   | ts3server: 127.0.0.1?port=9987&nickname=Musikbot%20von%20ChaoZz&password=&channel=&channelpassword=
    2015-04-27 13:13:19.270788|INFO    |ClientUI      |  1| Connect to server: 127.0.0.1
    2015-04-27 13:13:19.271755|INFO    |ClientUI      |  1| Blacklist check ok
    2015-04-27 13:13:19.271832|INFO    |ClientUI      |  1| Initiating connection: 127.0.0.1:9987 127.0.0.1
    2015-04-27 13:13:19.556671|INFO    |PreProSpeex   |  1| Speex version: 1.2rc1
    warning: The VAD has been replaced by a hack pending a complete rewrite
    2015-04-27 13:13:19.654510|INFO    |ClientUI      |  1| Connect status: Connecting
    2015-04-27 13:13:19.657782|INFO    |ClientUI      |   | Last update check was: So. Jan. 1 00:00:01 2017
    2015-04-27 13:13:19.658975|DEVELOP |PktHandler    |   | Puzzle solve time: 4
    2015-04-27 13:13:19.671137|INFO    |ClientUI      |  1| Connect status: Disconnected
    2015-04-27 13:13:19.671211|INFO    |ClientUI      |  1| Disconnected or forced to leave, want autoreconnect = 0
    If you need some more information you can post it here.
    I hope someone can help me.

    ChaoZz

  2. #2
    Join Date
    June 2008
    Posts
    17,851
    Is there a server running and listening to 127.0.0.1 on the same machine ?
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    April 2015
    Posts
    5
    Yes there is a TS3 server listening on 127.0.0.1 but what shall i change?

  4. #4
    Join Date
    April 2015
    Posts
    5
    Can no one help me?
    How can i have client and server on one linux system?

  5. #5
    Join Date
    June 2008
    Posts
    17,851
    Quote Originally Posted by ChaoZz View Post
    Yes there is a TS3 server listening on 127.0.0.1 but what shall i change?
    Make sure that the server is realy running/listen on 127.0.0.1 on port 9987.

    Quote Originally Posted by ChaoZz View Post
    Can no one help me?
    How can i have client and server on one linux system?
    Normal this can be done in any operation system (Linux / FreeBSD / OSX / Windows). I do test that weekly.
    It will not work, when 127.0.0.1 is not your ip.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  6. #6
    Join Date
    April 2015
    Posts
    5
    The server listens on 0.0.0.0:9987
    Problem is still there. Maybe becuase this warning pops?:
    warning: The VAD has been replaced by a hack pending a complete rewrite
    Edit: when i try to start the client via './ts3client_runscript.sh' i get this:
    QXcbConnection: Could not connect to display
    Last edited by ChaoZz; May 9th, 2015 at 03:13 PM.

  7. #7
    Join Date
    June 2008
    Posts
    17,851
    VAD = voice activation detection. This has nothing to do with connection.
    QXcbConnection: Could not connect to display = The GUI can not load and be shown an your desktop.

    Your first log does look a bit different from a normal client.
    Is this a real client installed on a Computer with a Desktop and not only a console?
    In case you do not have a desktop OS: We do not support that.

    I can not solve your problem. check your firewall settings or whatever blocks the client from connecting to 127.0.0.1. also do try another server to valid that your client can connect to other servers.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Teamspeak3 Client not connecting to any servers?
    By STARBUCK_107 in forum Windows
    Replies: 0
    Last Post: August 24th, 2015, 12:54 AM
  2. TeamSpeak3 autostart Linux Debian 5
    By nfsmw15 in forum Tools / Web Based
    Replies: 4
    Last Post: February 12th, 2015, 09:56 AM
  3. [DEBIAN] Trying to start teamspeak3 server with screen
    By Ghostaunt in forum Linux / FreeBSD
    Replies: 22
    Last Post: November 10th, 2013, 11:55 AM
  4. Teamspeak3 Client 3.0.10 not connecting
    By Ray Lang in forum Windows
    Replies: 7
    Last Post: January 3rd, 2013, 08:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •