Forum

Results 1 to 3 of 3
  1. #1
    Join Date
    June 2015
    Posts
    2

    Outside connection issues with new NIC

    Hey all, I'd appreciate some suggestions since I seem to be stuck.

    I've been running a free / unlicensed Teamspeak 3 server for a long while now for friends and I to communicate while gaming. Yesterday I had a D-Link 100mb PCI NIC start to die on me, so I swapped it out with a TP-Link TG-3269 1000mb PCI NIC.

    Since I did this, none of my friends can connect to my Teamspeak server. I can still connect via localhost.


    Some background info:

    My PC has a dynamic local IP on my home network. The IP is the same as it was before the card swap.
    I run my home LAN on a non-managed 16 port gigabit switch connected to an AT&T Uverse gateway / router.
    My network connection is wired.


    I've made sure the correct ports are still forwarded on my router and even tried changing to a DMZ with no luck. I deleted the Teamspeak server entries in Windows Firewall and let Windows recreate them. Again no luck. I tried deleting the entries and manually recreating them and again had no luck. I noticed that Windows didn't have an outbound rule for Teamspeak (never has apparently) and created one with no luck.

    I can access the web, Steam, Battlenet, my paid back up rented Teamspeak server, etc. just fine. Nothing seems to be malfunctioning at all on this system except the Teamspeak server not allowing outside connections.

    Since the version we run is a little old (version 3.0.10.2) I even shut it down and installed the latest release to try and see if others could access it from outside, but again no dice. I've flushed DNS and repaired the TCP/IP stack and there is no difference.

    I even went so far as to disable IPv4 checksum offload on the new NIC since I found an older post recommending it. Again no change.


    I'm seriously stumped here but have a feeling it's something really minor I'm missing. I'd appreciate some suggestions guys!


    EDIT:

    Forgot to add, I also tried disabling Windows firewall completely (not while on DMZ of course but with ports forwarded) and others still couldn't connect from outside my local network. :-/

  2. #2
    Join Date
    June 2015
    Posts
    2
    Still not having any luck here. There has to be someone else who's run into this same issue when swapping out an NIC?

    I even enabled showing disconnected hardware in device manager to check if there was possibly a duplicate NIC. I found a very old entry (motherboard NIC which I used for a week) and uninstalled it, but still no luck.


    I'm really drawing a blank here now.

  3. #3
    Join Date
    April 2010
    Location
    UK
    Posts
    218
    Check your router ( the one where you made the ports )
    Sometimes ports can be linked to the mac address rather than the ip address.
    Even if your ports still point to x.x.x.x IP it may point to x.x.x.x on xy mac address.
    Any new network card will have a different mac address.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Connection Issues
    By weredperson in forum Server Support
    Replies: 0
    Last Post: July 7th, 2013, 11:09 PM
  2. Connection issues
    By SkippTekk in forum Windows
    Replies: 11
    Last Post: February 26th, 2013, 02:19 AM
  3. Connection Issues
    By herpaderpa in forum Windows
    Replies: 3
    Last Post: February 16th, 2012, 04:30 PM
  4. Connection Issues
    By phrozen_ in forum Windows
    Replies: 9
    Last Post: January 19th, 2012, 01:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •