Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3
  1. #1
    Join Date
    December 2009
    Location
    Wangaratta
    Posts
    9

    Server List Problem

    Hi,

    I know this question has been ask a number of times and followed all instructions. To answer the questions I will be asked.

    Reporting to server list is enabled.
    Port 2010 UDP is not blocked.
    IP-To Country resolves correct country.
    I have used all filters and search.
    I am able to query the server. https://api.planetteamspeak.com/serv...1.159.235:9987

    The below is enabled, however JSON returns "serverquery":false
    b_virtualserver_info_view
    b_virtualserver_client_list
    b_virtualserver_channel_list

    I have 3 other TeamSpeak servers hosted on the same server.
    Each server has a different port, query and file port. They also do not show up.

    Is it possible that Port 2010 UDP being used by multiple servers causing the issue?
    Gametracker is able to scan the server and any other PHP scripts.

    Any help would be a great relief.

    Thanks

    *EDIT*
    Updates every 15minutes so I could be wrong about the API Query. However, still does not display in the server list.
    https://www.planetteamspeak.com/serv....159.235:9987/

    Additional information

    # tcpdump -vv -i eth0 'port 2010'
    tcpdump: listening on eth0, link-type EN10MB (Ethernet), capture size 262144 bytes
    00:09:36.249382 IP (tos 0x0, ttl 64, id 21849, offset 0, flags [DF], proto UDP (17), length 32)
    teamspeak.clanhost.com.au.40206 > hardy.teamspeak.4players.de.2010: [bad udp cksum 0xb1e7 -> 0xa423!] UDP, length 4
    00:09:36.553493 IP (tos 0x0, ttl 52, id 0, offset 0, flags [none], proto UDP (17), length 36)
    hardy.teamspeak.4players.de.2010 > teamspeak.clanhost.com.au.40206: [udp sum ok] UDP, length 8
    00:09:36.554807 IP (tos 0x0, ttl 64, id 21896, offset 0, flags [DF], proto UDP (17), length 44)
    teamspeak.clanhost.com.au.40206 > hardy.teamspeak.4players.de.2010: [bad udp cksum 0xb1f3 -> 0x0a9a!] UDP, length 16
    00:09:36.858684 IP (tos 0x0, ttl 52, id 0, offset 0, flags [none], proto UDP (17), length 33)
    hardy.teamspeak.4players.de.2010 > teamspeak.clanhost.com.au.40206: [udp sum ok] UDP, length 5
    Last edited by Chris; July 10th, 2015 at 01:31 PM.

  2. #2
    Join Date
    October 2003
    Location
    Germany
    Posts
    2,527
    Quote Originally Posted by ADF-Sniper View Post
    The below is enabled, however JSON returns "serverquery":false
    b_virtualserver_info_view
    b_virtualserver_client_list
    b_virtualserver_channel_list
    I'm the owner of the Planet TeamSpeak website... let me try to explain how this works:

    The list on the site is filled with the exact same data you'll get within your TS3 Client and contains all servers that have server list reporting enabled. Per default, a TS3 Server will not be queried to gather additional data. You'll have to claim that you're the owner of the server and then enable the ServerQuery functionality. The serverquery flag in the JSON output you've mentioned simply indicates whether or not the ServerQuery functionality is enabled.

    Here's an example:

    https://www.planetteamspeak.com/serv...11.30.15:9987/

    Claiming a server will require a *FREE* registration. I'm currently working on the last few bits to make everything sing so please tay tuned to the Blog where I'll be posting an official release announcement soon:

    https://www.planetteamspeak.com/about/blog/

  3. #3
    Join Date
    October 2003
    Location
    Germany
    Posts
    2,527
    Registration is open now...


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Server List Problem
    By ADF-Sniper in forum Linux / FreeBSD
    Replies: 2
    Last Post: June 26th, 2015, 04:29 PM
  2. Web Server List(not ordinary problem)
    By DominatorBlazer in forum Server Support
    Replies: 14
    Last Post: September 23rd, 2010, 07:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •