Forum

Results 1 to 3 of 3
  1. #1
    Join Date
    April 2011
    Posts
    8

    MariaDb IO blocking - Maybe

    I have a teamspeak3 server latest version on Ubuntu 14.04 and Maria DB, with increased cache values.
    So here is the issue, at first with normal cache values whenever someone changed a channel or deleted everyone would Drop out of the server.

    So I increased the values to a few dozens MB more of cache, everyone in the server got a disconnect when the server deleted a channel, and someone with a 'Bang*' in the nickname left afterwards (nicknames replaced with ### for obvious reasons).

    I suspect that Ts3 server has a blocking problem with the DB, if it does not respond immediately 200 ppl...ish get connection lost.
    Server has NPL.

    2015-07-31 21:17:22.628330|INFO |VirtualServerBase| 1| client disconnected '######'(id:54395) reason 'reasonmsg=leaving'
    2015-07-31 21:17:24.703768|INFO |VirtualServerBase| 1| client disconnected '#########'(id:54840) reason 'reasonmsg=Leaving'

    2015-07-31 21:18:31.125513|INFO |VirtualServerBase| 1| channel 'PTL'(id:42556) deleted by 'server'(id:0)

    2015-07-31 21:18:31.995558|INFO |VirtualServerBase| 1| client disconnected '#######'(id:48770) reason 'reasonmsg=leaving'
    2015-07-31 21:18:32.886026|INFO |VirtualServerBase| 1| client disconnected '#######'(id:25948) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:32.891429|INFO |VirtualServerBase| 1| client disconnected '######'(id:54056) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:32.894898|INFO |VirtualServerBase| 1| client disconnected ####''(id:52382) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:32.898359|INFO |VirtualServerBase| 1| client disconnected '#######'(id:54827) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:32.901938|INFO |VirtualServerBase| 1| client disconnected '########'(id:37305) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:32.905424|INFO |VirtualServerBase| 1| client disconnected '#######'(id:51182) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:32.908304|INFO |VirtualServerBase| 1| client disconnected '####'(id:54828) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:32.911415|INFO |VirtualServerBase| 1| client disconnected '#######'(id:53909) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:32.914815|INFO |VirtualServerBase| 1| client disconnected '#######'(id:41209) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:32.919137|INFO |VirtualServerBase| 1| client disconnected '#####'(id:30819) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:32.942576|INFO |VirtualServerBase| 1| client disconnected '####'(id:53296) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:33.317292|INFO |VirtualServerBase| 1| client disconnected '#####'(id:49670) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:33.392210|INFO |VirtualServerBase| 1| client disconnected '#####'(id:53852) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:33.396684|INFO |VirtualServerBase| 1| client disconnected '#####'(id:48016) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:33.403250|INFO |VirtualServerBase| 1| client disconnected '#####'(id:53772) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:33.419045|INFO |VirtualServerBase| 1| client disconnected '#####'(id:44825) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:33.436040|INFO |VirtualServerBase| 1| client disconnected '####'(id:54809) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:33.444133|INFO |VirtualServerBase| 1| client disconnected '###'(id:54810) reason 'reasonmsg=connection lost'
    2015-07-31 21:18:33.449325|INFO |VirtualServerBase| 1| client disconnected '######'(id:47016) reason 'reasonmsg=connection lost'


    and a lot more

  2. #2
    Join Date
    June 2008
    Posts
    18,414
    You already explained your hand made problem.
    You never should play with the databse while software want's to read or write on it.

    Is there a question to this left?
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    April 2011
    Posts
    8
    Quote Originally Posted by dante696 View Post
    You already explained your hand made problem.
    You never should play with the database while software want's to read or write on it.

    Is there a question to this left?
    Oh there is quite are a lot, but I am going to accept that I explain myself very badly and that I found out about databases yesterday.

    Anyways I did not express the time of events correctly and I will try to clarify.

    The server is on a mariadb, ubuntu server 14.04.2 64 bit, teamspeak 11.3

    2 week before this specific event:
    - server was crashing(connection lost) 100+ users every time someone deleted or changed a room in the server.
    - while debuging I found a strange delay between the command issued from ts3server and the actual writing on the db.
    - solution was to increase the cache variables and update the ubuntu server. stop everything, reboot, start teamspeak server and everything is better, lovely and very responsive.

    On this specific event:
    - server deleted a temporary room automatically and crashed (lost connection) to 100+ users.
    - checked log's and found out maybe half a second delay between users getting crashed and room being deleted.
    - solution is to go to team speak forums and ask about if there is an issue with blocking with mariaDb.


    So assuming my hand was not the issue and getting back to the issue at hand, is there any solution for this problem or any logs you might need, maybe I have corrupted tables, ts3 server has blocking issue while using the same connection to the DB when it actually has almost half a dozen, some security failures, a bug?

    I have tried to check everything that might be blocking but everything seems fine on the database end, innodb tables, good cache values, database is only 16Mb FYI.

    So feel free to ask me for more information that I can provide so that I can fix this issue.

    Thank you

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MariaDB 10.0 Support
    By X3r0X in forum Linux / FreeBSD
    Replies: 2
    Last Post: September 6th, 2015, 10:44 AM
  2. MariaDB errors
    By dbsDev in forum Linux / FreeBSD
    Replies: 15
    Last Post: September 4th, 2015, 11:19 AM
  3. Ts3 not working Mariadb
    By PRAWKC in forum Linux / FreeBSD
    Replies: 2
    Last Post: January 28th, 2015, 08:44 AM
  4. [Resolved] Upgrade from 3.0.10.3 to 3.0.11.1 (MySQL/MariaDB)
    By h0rst in forum Server Support
    Replies: 6
    Last Post: November 14th, 2014, 03:47 PM
  5. MariaDB information
    By Death_Balgor in forum General Questions
    Replies: 0
    Last Post: October 9th, 2014, 04:20 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •