Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 5 of 5
  1. #1
    Join Date
    August 2015
    Posts
    4

    strange behaviour when chrooted

    Hi im trying to get ts running with chroot under linux.
    it runs but:
    -no .pid is created (which makes it hard to stop
    and it outputs this when manually started
    TeamSpeak 3 server could not start
    but it actually started

  2. #2
    Join Date
    June 2008
    Posts
    18,513
    I don't think that chroot is supposed to work with Teamsepak at all.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    August 2015
    Posts
    4

    it does

    Quote Originally Posted by dante696 View Post
    I don't think that chroot is supposed to work with Teamsepak at all.
    it runs fine besides that two issues. so it is probably just a missing binary.

  4. #4
    Join Date
    August 2015
    Posts
    4

    to be more precise

    This is the shell
    Code:
    [email protected]:~/ts3server$ ./ts3server_startscript.sh start
    Starting the TeamSpeak 3 server
    TeamSpeak 3 server could not start
    This is the logfile
    Code:
    2015-08-21 00:19:44.412590|INFO    |ServerLibPriv |   | TeamSpeak 3 Server 3.0.11.3 (2015-04-13 13:26:31)
    2015-08-21 00:19:44.412749|INFO    |ServerLibPriv |   | SystemInformation: Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u3 (2015-08-04) x86_64 Binary: 64bit
    2015-08-21 00:19:44.412801|INFO    |ServerLibPriv |   | Using hardware aes
    2015-08-21 00:19:44.413832|INFO    |DatabaseQuery |   | dbPlugin name:    MariaDB plugin, (c)TeamSpeak Systems GmbH
    2015-08-21 00:19:44.413901|INFO    |DatabaseQuery |   | dbPlugin version: 1
    2015-08-21 00:19:44.570747|INFO    |Accounting    |   | Licensing Information
    2015-08-21 00:19:44.570815|INFO    |Accounting    |   | type              : Non-profit
    2015-08-21 00:19:44.570864|INFO    |Accounting    |   | starting date     : Sat Aug  1 00:00:00 2015
    2015-08-21 00:19:44.570906|INFO    |Accounting    |   | ending date       : Fri Feb 12 00:00:00 2016
    2015-08-21 00:19:44.570944|INFO    |Accounting    |   | max virtualservers: 10
    2015-08-21 00:19:44.570981|INFO    |Accounting    |   | max slots         : 512
    2015-08-21 00:19:45.045244|INFO    |              |   | Puzzle precompute time: 462
    2015-08-21 00:19:45.045537|INFO    |FileManager   |   | listening on 0.0.0.0:30033
    2015-08-21 00:19:45.110263|INFO    |CIDRManager   |   | updated query_ip_whitelist ips: 127.0.0.1, 
    2015-08-21 00:19:45.110925|INFO    |Query         |   | listening on 0.0.0.0:10011
    rights for the complete folder are 755 and its the owner who executes the startscript. so it should create the .pid-file. but it does not.

  5. #5
    Join Date
    August 2015
    Posts
    4

    libs and bin

    could i get a list of libs and bianies that TS3 needs?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Serverquery list commands strange behaviour
    By lallo1 in forum General Questions
    Replies: 2
    Last Post: November 7th, 2011, 11:44 PM
  2. microphone odd behaviour
    By kmeyer666 in forum Windows
    Replies: 0
    Last Post: December 23rd, 2010, 04:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •