Forum

Results 1 to 12 of 12
  1. #1
    Join Date
    September 2015
    Location
    NDS, Germany
    Posts
    7

    Random Server Crashes

    Hello everyone,
    I have an unusual behavior at my TeamSpeak Server.(Its a NPL-Server with one 400 Slot server and 2 Small ones)
    The Server crashes without any Messages in the Log. This happens sometimes a few hours after start, sometimes the Server is running fine for days. I have already switched to a new root server without any changes.

    What happends when the server is crashed:
    The CPU-Usage is dropping to zero and the server isn't reacting to a SIGTERM, I have to use SIGKILL to kill the process.

    Do you have any Ideas what that could be?

  2. #2
    Join Date
    June 2008
    Posts
    18,119
    We have no idea without any log detail or error message or server version or os version.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  3. #3
    Join Date
    September 2015
    Location
    NDS, Germany
    Posts
    7
    Ok, sorry, I forgot that.
    As said before, there aren't any Log Entrys beside normal join and leave Messages.

    OS: Linux 2.6.32-042stab108.2
    Debian 7 64 Bit

    Server Version: 3.0.11.3

    Edit: Server Hardware:
    Quad-Core CPU
    4 GB RAM
    50GB of storage
    200 MBit network interface
    openVZ Container, have tried KVM also
    Last edited by SecretMineDE; September 9th, 2015 at 07:49 AM. Reason: Added Server Specs

  4. #4
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,344
    Server log.

  5. #5
    Join Date
    September 2015
    Location
    NDS, Germany
    Posts
    7
    Code:
    [email protected]:/home/ts/tserver/logs# tail -n 10 ts3server_2015-09-08__04_21_10.648426_*
    ==> ts3server_2015-09-08__04_21_10.648426_0.log <==
    2015-09-08 20:20:01.316267|INFO    |Query         |   | query from 14196 xxx.xxx.xxx.xxx:41780 issued: login with account "serveradmin"(serveradmin)
    2015-09-08 20:20:01.316493|INFO    |Query         |   | query from 14197 xxx.xxx.xxx.xxx:41781 issued: login with account "serveradmin"(serveradmin)
    2015-09-08 20:20:02.221384|INFO    |Query         |   | query from 14198 xxx.xxx.xxx.xxx:41788 issued: login with account "serveradmin"(serveradmin)
    2015-09-08 20:20:02.285654|INFO    |Query         |   | query from 14199 xxx.xxx.xxx.xxx:41793 issued: login with account "serveradmin"(serveradmin)
    2015-09-08 20:20:02.295709|INFO    |Query         |   | query from 14200 xxx.xxx.xxx.xxx:41794 issued: login with account "serveradmin"(serveradmin)
    2015-09-08 20:20:02.305977|INFO    |Query         |   | query from 14201 xxx.xxx.xxx.xxx:41795 issued: login with account "serveradmin"(serveradmin)
    2015-09-08 20:20:02.393375|INFO    |Query         |   | query from 14202 xxx.xxx.xxx.xxx:41796 issued: login with account "serveradmin"(serveradmin)
    2015-09-08 20:20:02.479681|INFO    |Query         |   | query from 14203 xxx.xxx.xxx.xxx:41801 issued: login with account "serveradmin"(serveradmin)
    2015-09-08 20:20:02.692414|INFO    |Query         |   | query from 14204 xxx.xxx.xxx.xxx:41806 issued: login with account "serveradmin"(serveradmin)
    2015-09-08 20:20:03.209565|INFO    |Query         |   | query from 14205 xxx.xxx.xxx.xxx:41807 issued: login with account "serveradmin"(serveradmin)
    
    ==> ts3server_2015-09-08__04_21_10.648426_1.log <==
    2015-09-08 20:04:57.889432|INFO    |VirtualServerBase|  1| client disconnected 'xx'(id:xxxxxx) reason 'reasonmsg=Verlassen'
    2015-09-08 20:05:05.372769|INFO    |VirtualServerBase|  1| client disconnected 'xx'(id:xxxxxx) reason 'reasonmsg=Verlassen'
    2015-09-08 20:05:27.757442|INFO    |VirtualServerBase|  1| client disconnected 'xx'(id:xxxxxx) reason 'reasonmsg=Verlassen'
    2015-09-08 20:05:28.865912|INFO    |VirtualServerBase|  1| client disconnected 'xx'(id:xxxxxx) reason 'reasonmsg=Verlassen'
    2015-09-08 20:05:29.016586|INFO    |VirtualServerBase|  1| client disconnected 'xx'(id:xxxxxx) reason 'reasonmsg=Verlassen'
    2015-09-08 20:05:29.033179|INFO    |VirtualServerBase|  1| client disconnected 'xx'(id:xxxxxx) reason 'reasonmsg=Verlassen'
    2015-09-08 20:07:51.791764|INFO    |VirtualServerBase|  1| client connected 'xx'(id:xxxxxx) from xxx.xxx.xxx.xxx:64711
    2015-09-08 20:13:11.710498|INFO    |VirtualServerBase|  1| client connected 'xx'(id:xxxxxx) from xxx.xxx.xxx.xxx:58933
    2015-09-08 20:13:48.622841|INFO    |VirtualServerBase|  1| client disconnected 'xx'(id:xxxxxx) reason 'reasonmsg=connection lost'
    2015-09-08 20:14:29.797142|INFO    |VirtualServerBase|  1| client disconnected 'xx'(id:xxxxxx) reason 'reasonmsg=Verlassen'
    
    ==> ts3server_2015-09-08__04_21_10.648426_15.log <==
    2015-09-08 04:21:12.654092|INFO    |VirtualServer | 15| listening on 0.0.0.0:999x
    
    ==> ts3server_2015-09-08__04_21_10.648426_2.log <==
    2015-09-08 04:21:12.576827|INFO    |VirtualServer |  2| listening on 0.0.0.0:998x
    
    ==> ts3server_2015-09-08__04_21_10.648426_6.log <==
    2015-09-08 04:21:12.616255|INFO    |VirtualServer |  6| listening on 0.0.0.0:998x
    (Because of privacy I replaced all private Data with x)
    This are the last 10 Lines of every Serverlog at that time. As you can see, nothing unusual.

  6. #6
    Join Date
    June 2008
    Posts
    18,119
    There is nothing about a crash in the server , also there is no error at all.

    Why does your Query login 7 times in a second???
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  7. #7
    Join Date
    September 2015
    Location
    NDS, Germany
    Posts
    7
    I know that there are no errors or any unusual messages in the Log. That is one reason, why I opened this Thread. That Query Logins are from my Bots.
    Can that be a reason for the crashes?

  8. #8
    Join Date
    June 2008
    Posts
    18,119
    I have no idea :/
    you could try without the bot for a while.

    But please update your server to version 3.0.11.4 first!
    http://www.teamspeak.com/downloads
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

  9. #9
    Join Date
    September 2015
    Location
    NDS, Germany
    Posts
    7
    Oh. I didn't See that there was an update...
    I will installiert it later this day, maybe that can help.

  10. #10
    Join Date
    June 2011
    Location
    Germany
    Posts
    4,344
    Why do you need so many bots at all? Spying on channel chat?

  11. #11
    Join Date
    September 2015
    Location
    NDS, Germany
    Posts
    7
    No, but I have seperated scripts for e.g. Checking Usernames, Moving AFK, deleting old channels and so on.
    I added a sleep to most of the scripts so they run time-shifted. Maybe that helps

  12. #12
    Join Date
    September 2015
    Location
    NDS, Germany
    Posts
    7
    Server is Running for two Weeks now, after I added some sleeps to my scripts so they run with a little delay.
    Thanks for your help!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Server random crashes
    By NyxBiker in forum Server Support
    Replies: 3
    Last Post: April 22nd, 2015, 07:24 AM
  2. random crashes for one server
    By nik1990 in forum Windows
    Replies: 1
    Last Post: January 16th, 2013, 01:08 PM
  3. Teamspeak crashes on random time
    By AJFire in forum Windows
    Replies: 1
    Last Post: May 13th, 2011, 02:36 AM
  4. Hosting Server random Crashes
    By squirrel5911 in forum Server Support
    Replies: 8
    Last Post: December 23rd, 2009, 07:02 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •