Forum


Notice to all users

We are migrating towards a new forum system located at community.teamspeak.com, as such this forum will become read-only on January 29, 2020

Results 1 to 2 of 2
  1. #1
    Join Date
    September 2015
    Posts
    1

    Weird voice issues

    Hey, having some issues with my laptop and using teamspeak 3, its upgraded to the newest version, and I am currently using a ACER Aspire 7741G. It has windows 10 running on it, but I'm finding whenever I go into Teamspeak with my friends I sound like a guy.

    Like I enter the channel, talk and at first people don't realize its me cause it sounds like a man, or so I'm being told, not deep baritone, but deeper than my normal voice. I reset the sound drivers and that fixes it, but its kind of disconcerting that this keeps happening. Does anyone have any idea why, or how I can stop this?

  2. #2
    Join Date
    June 2008
    Posts
    18,513
    I'm sure windows 10 drivers are not bug free yet.
    And mabye their settings do change for an unknown reason.
    You may search for driver updates.
    When sending me private messages: Please make sure to include reference link to your forum thread or post.

    TeamSpeak FAQ || What should i report, when i open a client thread?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. TS3 causing weird issues with MWO
    By Horrigan in forum Bug Reports [EN/DE]
    Replies: 1
    Last Post: August 4th, 2015, 10:11 PM
  2. Weird sound issues
    By Noctropolitan in forum Windows
    Replies: 0
    Last Post: June 15th, 2014, 09:50 PM
  3. Really weird issues, some addresses connect, some don't
    By TelFiRE in forum Linux / FreeBSD
    Replies: 2
    Last Post: April 23rd, 2013, 08:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •