Notice to all users

We are migrating towards a new forum system located at, as such this forum will become read-only on January 29, 2020

Results 1 to 3 of 3

Hybrid View

  1. #1
    Join Date
    November 2015

    TS prevents other programs from accessing the default playback device G930

    I've had this problem since I started travelling last week but wasn't able to track it down to TS until today. When I open TS it seems to take hold of the playback device and not allow other programs to use it. Opening a video in VLC will leave VLC mute, trying to watch a video on youtube will actually cause the video not to play at all, not simply playing without sound. That was a hell of a false lead right there. All these problems can be solved by turning off TS or just muting speakers/headphones from the tray.

    I found some very old threads describing similar behavior while googling so have tried going to the communication tab and changing "Reduce the volume of other sounds by 80%" to do nothing. I have updated TS to the latest version, and I have disabled all plugins.

    What more can I do?

    My playback device is a Logitech G930 headset, also up the latest drivers. I used this on my desktop previously and had no issues like this, it has only appeared since I started using my laptop, a Gateway NE 722.

    Let me know if you need any additional information, and thanks!

  2. #2
    Join Date
    January 2016

    any answer ?

    Hey just wanted to know, I have the exact same issue, any answer to this problem ?

  3. #3
    Join Date
    April 2010
    G930 user here also.

    I found any thing newer than 8.58.183 version is just not good.
    win7 user.

    if you have win10 that may be your problem?
    win10 is having problems with a lot of drivers at the moment,it's just too new.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Custum Capture Device(s) with Default Playback Device
    By Mike Holland in forum General Questions
    Replies: 0
    Last Post: July 3rd, 2014, 04:18 PM
  2. Help with playback device
    By TLLucifer in forum General Questions
    Replies: 0
    Last Post: May 28th, 2014, 11:35 PM
  3. Replies: 0
    Last Post: March 1st, 2014, 02:43 AM
  4. [On Todo] Mac Playback & Capture device cannot be changed from system default
    By speakingof in forum Bug Reports [EN/DE]
    Replies: 9
    Last Post: October 6th, 2011, 09:12 AM
  5. Playback device not found
    By PureTryOut in forum Windows
    Replies: 1
    Last Post: August 26th, 2011, 11:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts